summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-12-21 21:07:11 +0000
committerMike Frysinger <vapier@gentoo.org>2011-12-21 21:07:11 +0000
commita453494a1187ac81a3da41aa1036dd5295b7575b (patch)
tree82c70d13e69a4090b9acbf901b30c3d9aca042bf /sys-devel/crossdev
parentMark stable for gcc cxx/nocxx changes #394665 by Andrey Hippo. (diff)
downloadgentoo-2-a453494a1187ac81a3da41aa1036dd5295b7575b.tar.gz
gentoo-2-a453494a1187ac81a3da41aa1036dd5295b7575b.tar.bz2
gentoo-2-a453494a1187ac81a3da41aa1036dd5295b7575b.zip
Add support for msp430 targets by Tim Harder.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog7
-rw-r--r--sys-devel/crossdev/crossdev-20111221.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index ef6733432ec6..b50ccfd3eacc 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.86 2011/12/21 21:04:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.87 2011/12/21 21:07:11 vapier Exp $
+
+*crossdev-20111221 (21 Dec 2011)
+
+ 21 Dec 2011; Mike Frysinger <vapier@gentoo.org> +crossdev-20111221.ebuild:
+ Add support for msp430 targets by Tim Harder.
21 Dec 2011; Mike Frysinger <vapier@gentoo.org> crossdev-20111018.ebuild,
crossdev-20111118.ebuild:
diff --git a/sys-devel/crossdev/crossdev-20111221.ebuild b/sys-devel/crossdev/crossdev-20111221.ebuild
new file mode 100644
index 000000000000..affd2489949b
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20111221.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20111221.ebuild,v 1.1 2011/12/21 21:07:11 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}