summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-14 01:16:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-14 01:16:15 +0000
commit0939f3b6eeb550c5486666ff59faeafa193c57db (patch)
treef6a30fe29423f51b998d1b4bf2d5e69c3b09a232 /sys-devel/crossdev
parentold (diff)
downloadgentoo-2-0939f3b6eeb550c5486666ff59faeafa193c57db.tar.gz
gentoo-2-0939f3b6eeb550c5486666ff59faeafa193c57db.tar.bz2
gentoo-2-0939f3b6eeb550c5486666ff59faeafa193c57db.zip
Make sure the stupid ABI var doesnt screw us up.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-0.9.6-r1.ebuild21
-rwxr-xr-xsys-devel/crossdev/files/crossdev5
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.6-r10
4 files changed, 32 insertions, 2 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 95f1e334d739..6e6d6014281c 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.18 2005/06/20 20:06:33 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.19 2005/07/14 01:16:15 vapier Exp $
+
+*crossdev-0.9.6-r1 (14 Jul 2005)
+
+ 14 Jul 2005; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9.6-r1.ebuild:
+ Make sure the stupid ABI var doesnt screw us up.
20 Jun 2005; Markus Rothe <corsair@gentoo.org> crossdev-0.9.6.ebuild:
Stable on ppc64
diff --git a/sys-devel/crossdev/crossdev-0.9.6-r1.ebuild b/sys-devel/crossdev/crossdev-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..22133af95708
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.6-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.6-r1.ebuild,v 1.1 2005/07/14 01:16:15 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="sys-apps/portage
+ app-shells/bash
+ sys-apps/coreutils"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index e8e59426bb7d..a59fa691a06c 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.25 2005/07/10 06:13:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.26 2005/07/14 01:16:15 vapier Exp $
if [[ ${ROOT:-/} != "/" ]] ; then
echo "Sorry, but crossdev does not support ROOT."
@@ -340,6 +340,9 @@ doemerge() {
eend 0
}
+# make sure multilib crap doesn't screw us over
+export ABI="this-abi-var-sucks"
+
# we include the '-u' so that we don't re-emerge packages
EOPTS="${UOPTS} -u --nodeps"
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.6-r1 b/sys-devel/crossdev/files/digest-crossdev-0.9.6-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.6-r1