summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 15:52:03 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 15:52:03 +0000
commitb025acda79c70ca1fafe47a4350b5a93968906e7 (patch)
tree3ff053c05e7eaac080149c2f8fedbdd0d26e2710 /sys-cluster
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-b025acda79c70ca1fafe47a4350b5a93968906e7.tar.gz
gentoo-2-b025acda79c70ca1fafe47a4350b5a93968906e7.tar.bz2
gentoo-2-b025acda79c70ca1fafe47a4350b5a93968906e7.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/lam-mpi/ChangeLog5
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild13
2 files changed, 7 insertions, 11 deletions
diff --git a/sys-cluster/lam-mpi/ChangeLog b/sys-cluster/lam-mpi/ChangeLog
index bb20ea639015..84e216a27ea8 100644
--- a/sys-cluster/lam-mpi/ChangeLog
+++ b/sys-cluster/lam-mpi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/lam-mpi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.83 2010/05/02 23:14:10 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/ChangeLog,v 1.84 2010/12/16 15:52:03 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> lam-mpi-7.1.4-r1.ebuild:
+ Removal of fortran.eclass, #348851
02 May 2010; Jonathan Callen <abcd@gentoo.org> lam-mpi-7.1.4-r1.ebuild:
Bump to EAPI-3, add prefix support & keywords
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild
index 625080c7441b..a8588e1101e3 100644
--- a/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild
+++ b/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild,v 1.12 2010/05/02 23:14:10 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.1.4-r1.ebuild,v 1.13 2010/12/16 15:52:03 jlec Exp $
EAPI="3"
-inherit autotools eutils fortran flag-o-matic multilib portability
+inherit autotools eutils flag-o-matic multilib portability toolchain-funcs
IUSE="crypt pbs fortran xmpi romio examples"
@@ -72,7 +72,6 @@ pkg_setup() {
elog "implementation, http://www.openmpi.org"
elog " ---From the lam-mpi hompage. Please consider upgrading."
einfo
- # fortran_pkg_setup should -not- be run here.
}
src_configure() {
@@ -98,12 +97,6 @@ src_configure() {
# in the current tree.
rm -rf "${S}"/share/ssi/boot/{bproc,globus,slurm}
- if use fortran; then
- fortran_pkg_setup
- # this is NOT in pkg_setup as it is NOT needed for RDEPEND right away it
- # can be installed after merging from binary, and still have things fine
- fi
-
# Disable totalview, see #245439 and #276194
econf \
--with-ltdl-include="${EPREFIX}"/usr/include \
@@ -115,7 +108,7 @@ src_configure() {
--with-threads=posix \
--disable-tv \
$(use_with romio) \
- $(use_with fortran fc "${FORTRANC}") \
+ $(use_with fortran fc "$(tc-getFC)") \
${myconf}
}