summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-08-11 13:57:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-08-11 13:57:38 +0000
commit88c0042c4fd46dd581cfbd07788272eee0a04010 (patch)
treea7b97524f941fcae86bcf39f04b88fc48a46985d /sys-cluster
parentStop using /etc/udev which is reserved for user defined rules. Stop using /li... (diff)
downloadgentoo-2-88c0042c4fd46dd581cfbd07788272eee0a04010.tar.gz
gentoo-2-88c0042c4fd46dd581cfbd07788272eee0a04010.tar.bz2
gentoo-2-88c0042c4fd46dd581cfbd07788272eee0a04010.zip
Stop hardcoding /lib/udev in src/lib/dev.c and redefine udevdir for install target from udev.pc pkg-config file.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog9
-rw-r--r--sys-cluster/vzctl/vzctl-3.3-r1.ebuild70
-rw-r--r--sys-cluster/vzctl/vzctl-9999.ebuild15
3 files changed, 88 insertions, 6 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 611f104385e7..7c1a5bbbb73f 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.92 2012/07/17 05:35:02 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.93 2012/08/11 13:57:38 ssuominen Exp $
+
+*vzctl-3.3-r1 (11 Aug 2012)
+
+ 11 Aug 2012; Samuli Suominen <ssuominen@gentoo.org> +vzctl-3.3-r1.ebuild,
+ vzctl-9999.ebuild:
+ Stop hardcoding /lib/udev in src/lib/dev.c and redefine udevdir for install
+ target from udev.pc pkg-config file.
*vzctl-3.3 (17 Jul 2012)
diff --git a/sys-cluster/vzctl/vzctl-3.3-r1.ebuild b/sys-cluster/vzctl/vzctl-3.3-r1.ebuild
new file mode 100644
index 000000000000..41cec3b032cc
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.3-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.3-r1.ebuild,v 1.1 2012/08/11 13:57:38 ssuominen Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 eutils toolchain-funcs
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ sys-cluster/ploop"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo added
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ sed -i -e "s:/lib/udev:${udevdir}:" src/lib/dev.c || die
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate
+}
+
+src_install() {
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ emake DESTDIR="${D}" udevdir="${udevdir}"/rules.d install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+}
diff --git a/sys-cluster/vzctl/vzctl-9999.ebuild b/sys-cluster/vzctl/vzctl-9999.ebuild
index ec79cf7a2f76..1f6e19510088 100644
--- a/sys-cluster/vzctl/vzctl-9999.ebuild
+++ b/sys-cluster/vzctl/vzctl-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.10 2012/07/17 05:35:02 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.11 2012/08/11 13:57:38 ssuominen Exp $
EAPI="4"
-inherit bash-completion-r1 autotools git-2
+inherit bash-completion-r1 autotools git-2 toolchain-funcs
DESCRIPTION="OpenVZ ConTainers control utility"
HOMEPAGE="http://openvz.org/"
@@ -22,13 +22,16 @@ RDEPEND="
sys-apps/iproute2
sys-fs/vzquota"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
src_prepare() {
# Set default OSTEMPLATE on gentoo
sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
eautoreconf
- sed -e '/udevdir/{s|$(sysconfdir)|/lib|}' -i etc/udev/Makefile.in || die
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ sed -i -e "s:/lib/udev:${udevdir}:" src/lib/dev.c || die
}
src_configure() {
@@ -40,7 +43,9 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install install-gentoo
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ emake DESTDIR="${D}" udevdir="${udevdir}"/rules.d install install-gentoo
# install the bash-completion script into the right location
rm -rf "${ED}"/etc/bash_completion.d