summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-05-16 07:19:13 +0000
committerPeter Volkov <pva@gentoo.org>2011-05-16 07:19:13 +0000
commite28187910b152c2216e25cd3e3d228c8cb0ee4d4 (patch)
treea42308af7614d5404c6b0f9ba64d8a0e81d91232 /sys-cluster/vzctl
parentUpdate Manifest due to aborted commit (was: Version bump.) (diff)
downloadgentoo-2-e28187910b152c2216e25cd3e3d228c8cb0ee4d4.tar.gz
gentoo-2-e28187910b152c2216e25cd3e3d228c8cb0ee4d4.tar.bz2
gentoo-2-e28187910b152c2216e25cd3e3d228c8cb0ee4d4.zip
Version bump.
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog7
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.26.3.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 072791fa58f9..b80ade17adae 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.75 2011/04/01 11:34:55 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.76 2011/05/16 07:19:13 pva Exp $
+
+*vzctl-3.0.26.3 (16 May 2011)
+
+ 16 May 2011; Peter Volkov <pva@gentoo.org> +vzctl-3.0.26.3.ebuild:
+ Version bump.
*vzctl-3.0.26.2-r1 (01 Apr 2011)
diff --git a/sys-cluster/vzctl/vzctl-3.0.26.3.ebuild b/sys-cluster/vzctl/vzctl-3.0.26.3.ebuild
new file mode 100644
index 000000000000..8763770f6fa8
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.26.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.26.3.ebuild,v 1.1 2011/05/16 07:19:13 pva Exp $
+
+EAPI="4"
+
+inherit bash-completion eutils
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="bash-completion"
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ $(use_enable bash-completion bashcomp) \
+ --enable-logrotate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ dobashcompletion etc/bash_completion.d/vzctl.sh vzctl
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ local conf_without_OSTEMPLATE
+ for file in \
+ $(find "${EROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
+ if ! grep '^OSTEMPLATE' $file > /dev/null; then
+ conf_without_OSTEMPLATE+=" $file"
+ fi
+ done
+
+ if [[ -n ${conf_without_OSTEMPLATE} ]]; then
+ ewarn
+ ewarn "OSTEMPLATE default was changed from redhat-like to gentoo."
+ ewarn "This means that any VEID.conf files without explicit or correct"
+ ewarn "OSTEMPLATE set will use gentoo scripts instead of redhat."
+ ewarn "Please check the following configs:"
+ for file in ${conf_without_OSTEMPLATE}; do
+ ewarn "${file}"
+ done
+ ewarn
+ fi
+
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+}