summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2007-11-29 01:01:36 +0000
committerJustin Bronder <jsbronder@gentoo.org>2007-11-29 01:01:36 +0000
commit88ff6c73ce61a6ea4eab88149e6b68f09547b746 (patch)
tree01254d8f4276c2d2cfbfc56bf770c6f61ed2687e /sys-cluster/torque
parentBug #199860, snapshot support code was not being built properly when non-stat... (diff)
downloadgentoo-2-88ff6c73ce61a6ea4eab88149e6b68f09547b746.tar.gz
gentoo-2-88ff6c73ce61a6ea4eab88149e6b68f09547b746.tar.bz2
gentoo-2-88ff6c73ce61a6ea4eab88149e6b68f09547b746.zip
Added pkg_config for basic setup. Moved PBS_SERVER_HOME to env.d only.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog10
-rw-r--r--sys-cluster/torque/files/digest-torque-2.2.1-r13
-rw-r--r--sys-cluster/torque/files/pbs_mom-init.d-2.2.1-r148
-rw-r--r--sys-cluster/torque/files/pbs_sched-init.d-2.2.1-r148
-rw-r--r--sys-cluster/torque/files/pbs_server-init.d-2.2.1-r162
-rw-r--r--sys-cluster/torque/files/torque-conf.d-2.2.1-r114
-rw-r--r--sys-cluster/torque/files/torque-env.d-2.2.1-r17
-rw-r--r--sys-cluster/torque/torque-2.2.1-r1.ebuild224
8 files changed, 415 insertions, 1 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
index 8ecc52f10ab4..e08a9a2707db 100644
--- a/sys-cluster/torque/ChangeLog
+++ b/sys-cluster/torque/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/torque
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.52 2007/11/24 17:47:09 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.53 2007/11/29 01:01:35 jsbronder Exp $
+
+*torque-2.2.1-r1 (29 Nov 2007)
+
+ 29 Nov 2007; <jbronder@gentoo.org> +files/pbs_mom-init.d-2.2.1-r1,
+ +files/pbs_sched-init.d-2.2.1-r1, +files/pbs_server-init.d-2.2.1-r1,
+ +files/torque-conf.d-2.2.1-r1, +files/torque-env.d-2.2.1-r1,
+ +torque-2.2.1-r1.ebuild:
+ Added pkg_config for basic setup. Moved PBS_SERVER_HOME to env.d only.
*torque-2.2.1 (24 Nov 2007)
diff --git a/sys-cluster/torque/files/digest-torque-2.2.1-r1 b/sys-cluster/torque/files/digest-torque-2.2.1-r1
new file mode 100644
index 000000000000..a860e555ae54
--- /dev/null
+++ b/sys-cluster/torque/files/digest-torque-2.2.1-r1
@@ -0,0 +1,3 @@
+MD5 4eebd8714435b52041ea99cc1a8beb03 torque-2.2.1.tar.gz 5370260
+RMD160 219e5a4234a1bbf0241c15f568a720752e48587c torque-2.2.1.tar.gz 5370260
+SHA256 6d2674d471e300df6ebda56ef80c2a7be0de33fc619f98ee78eee69af1d179b8 torque-2.2.1.tar.gz 5370260
diff --git a/sys-cluster/torque/files/pbs_mom-init.d-2.2.1-r1 b/sys-cluster/torque/files/pbs_mom-init.d-2.2.1-r1
new file mode 100644
index 000000000000..62d474dcbd62
--- /dev/null
+++ b/sys-cluster/torque/files/pbs_mom-init.d-2.2.1-r1
@@ -0,0 +1,48 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+. /etc/conf.d/torque
+PBS_SERVER_HOME="$(. /etc/env.d/25torque; echo ${PBS_SERVER_HOME})"
+
+depend() {
+ need net
+ after pbs_server
+ after pbs_sched
+ after logger
+}
+
+checkconfig() {
+ for i in "server_name" "mom_priv/config"; do
+ if [ ! -e ${PBS_SERVER_HOME}/${i} ]; then
+ eerror "Missing config file ${PBS_SERVER_HOME}/${i}"
+ return 1
+ fi
+ done
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Torque pbs_mom"
+ local extra_args=""
+ if [ -n "${PBS_MOM_LOG}" ]; then
+ extra_args="-L ${PBS_MOM_LOG}"
+ fi
+ start-stop-daemon --start -p ${PBS_SERVER_HOME}/mom_priv/mom.lock \
+ --exec /usr/sbin/pbs_mom -- -d ${PBS_SERVER_HOME} ${extra_args}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Torque pbs_mom"
+ /usr/sbin/momctl -s || start-stop-daemon --stop -p ${PBS_SERVER_HOME}/mom_priv/mom.lock
+ eend ${?}
+}
+
+restart() {
+ svc_stop
+ sleep 3
+ svc_start
+}
+# vim:ts=4
diff --git a/sys-cluster/torque/files/pbs_sched-init.d-2.2.1-r1 b/sys-cluster/torque/files/pbs_sched-init.d-2.2.1-r1
new file mode 100644
index 000000000000..b3ae047cc544
--- /dev/null
+++ b/sys-cluster/torque/files/pbs_sched-init.d-2.2.1-r1
@@ -0,0 +1,48 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+. /etc/conf.d/torque
+PBS_SERVER_HOME="$(. /etc/env.d/25torque; echo ${PBS_SERVER_HOME})"
+
+depend() {
+ need net
+ after pbs_server
+ before pbs_mom
+ after logger
+}
+
+checkconfig() {
+ for i in "server_name"; do
+ if [ ! -e ${PBS_SERVER_HOME}/${i} ]; then
+ eerror "Missing config file ${PBS_SERVER_HOME}/${i}"
+ return 1
+ fi
+ done
+
+ if [ -z "$(grep 'queue_type' ${PBS_SERVER_HOME}/server_priv/queues/*)" ]; then
+ eerror "No queues have been defined yet."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Torque pbs_sched"
+ local extra_args=""
+ if [ -n "${PBS_SCHED_LOG}" ]; then
+ extra_args="-L ${PBS_SCHED_LOG}"
+ fi
+
+ start-stop-daemon --start -p ${PBS_SERVER_HOME}/sched_priv/sched.lock \
+ --exec /usr/sbin/pbs_sched -- -d ${PBS_SERVER_HOME} ${extra_args}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Torque pbs_sched"
+ start-stop-daemon --stop -p ${PBS_SERVER_HOME}/sched_priv/sched.lock
+ eend ${?}
+}
+# vim:ts=4
diff --git a/sys-cluster/torque/files/pbs_server-init.d-2.2.1-r1 b/sys-cluster/torque/files/pbs_server-init.d-2.2.1-r1
new file mode 100644
index 000000000000..86e16a41b70b
--- /dev/null
+++ b/sys-cluster/torque/files/pbs_server-init.d-2.2.1-r1
@@ -0,0 +1,62 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+. /etc/conf.d/torque
+PBS_SERVER_HOME="$(. /etc/env.d/25torque; echo ${PBS_SERVER_HOME})"
+
+depend() {
+ need net
+ before pbs_sched
+ before pbs_mom
+ after logger
+}
+
+checkconfig() {
+ for i in "server_name" "server_priv/nodes"; do
+ if [ ! -e "${PBS_SERVER_HOME}/${i}" ]; then
+ eerror "Missing config file ${PBS_SERVER_HOME}/${i}"
+ return 1
+ fi
+ done
+
+ for i in "acl_svr/operators" "serverdb"; do
+ if [ ! -e "${PBS_SERVER_HOME}/server_priv/${i}" ]; then
+ eerror "Torque has not been fully configured to run."
+ eerror "Missing ${i}"
+ return 1
+ fi
+ done
+
+ if [ -z "$(grep 'queue_type' ${PBS_SERVER_HOME}/server_priv/queues/*)" ]; then
+ eerror "No queues have been defined yet."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting Torque pbs_server"
+ local extra_args=""
+ if [ -n "${PBS_SERVER_LOG}" ]; then
+ extra_args="-L ${PBS_SERVER_LOG}"
+ fi
+
+ start-stop-daemon --start -p ${PBS_SERVER_HOME}/server_priv/server.lock \
+ --exec /usr/sbin/pbs_server -- -d ${PBS_SERVER_HOME} ${extra_args}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping Torque pbs_server"
+ stop_type="${PBS_SERVER_STOP}"
+ if [ -z "${stop_type}" ]; then
+ ewarn "PBS_SERVER_STOP is not defined, defaulting to quick"
+ stop_type=quick
+ fi
+
+ /usr/bin/qterm -t ${stop_type} || start-stop-daemon --stop -p ${PBS_SERVER_HOME}/server_priv/server.lock
+ eend ${?}
+}
+# vim:ts=4
diff --git a/sys-cluster/torque/files/torque-conf.d-2.2.1-r1 b/sys-cluster/torque/files/torque-conf.d-2.2.1-r1
new file mode 100644
index 000000000000..a6e6b08beace
--- /dev/null
+++ b/sys-cluster/torque/files/torque-conf.d-2.2.1-r1
@@ -0,0 +1,14 @@
+# The default logging takes place in $PBS_SERVER_HOME/<mom/server/sched>_priv.
+# If you'd like to change that, use the following per service.
+PBS_SERVER_LOG=/var/log/pbs_server.log
+PBS_MOM_LOG=/var/log/pbs_mom.log
+PBS_SCHED_LOG=/var/log/pbs_sched.log
+
+
+# There are a number of ways to stop the pbs server. For more details, man qterm
+# At the time of writing, checkpoint is probably not working.
+# immediate: All jobs are killed.
+# delay: Checkpoint, rerun or wait for jobs to finish before stopping
+# quick: Remember running jobs, and let them run without interaction with pbs_server.
+# This is the default action
+PBS_SERVER_STOP=quick
diff --git a/sys-cluster/torque/files/torque-env.d-2.2.1-r1 b/sys-cluster/torque/files/torque-env.d-2.2.1-r1
new file mode 100644
index 000000000000..13f5bb3995b5
--- /dev/null
+++ b/sys-cluster/torque/files/torque-env.d-2.2.1-r1
@@ -0,0 +1,7 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+# Configuration files that are included in the initial Torque install
+PBS_SERVER_HOME="/var/spool/torque"
+CONFIG_PROTECT="${PBS_SERVER_HOME}/sched_priv/{holidays,resource_group,dedicated_time,sched_config} ${PBS_SERVER_HOME}/{server_name,pbs_environment}"
+
diff --git a/sys-cluster/torque/torque-2.2.1-r1.ebuild b/sys-cluster/torque/torque-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..c824fbfabafe
--- /dev/null
+++ b/sys-cluster/torque/torque-2.2.1-r1.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-2.2.1-r1.ebuild,v 1.1 2007/11/29 01:01:35 jsbronder Exp $
+
+inherit autotools flag-o-matic eutils
+
+DESCRIPTION="Resource manager and queuing system based on OpenPBS"
+HOMEPAGE="http://www.clusterresources.com/products/torque/"
+SRC_URI="http://www.clusterresources.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="openpbs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="tk crypt server syslog doc"
+PROVIDE="virtual/pbs"
+
+# ed is used by makedepend-sh
+DEPEND_COMMON="virtual/libc
+ sys-libs/ncurses
+ sys-libs/readline
+ tk? ( dev-lang/tk )
+ syslog? ( virtual/logger )
+ !virtual/pbs
+ !sys-cluster/openpbs-common"
+
+DEPEND="${DEPEND_COMMON}
+ sys-apps/ed"
+
+RDEPEND="${DEPEND_COMMON}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )"
+
+
+[ -n "${PBS_SERVER_HOME}" ] || PBS_SERVER_HOME="/var/spool/torque"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-setuid-safety-am.patch
+ # Otherwise we'll fail due to strings over ISO C89 defined length 509
+ sed -i 's:gcc_warning_flags="\(.*\)-Werror":gcc_warning_flags="\1":' configure.ac
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ if use crypt; then
+ myconf="--with-rcp=scp"
+ else
+ myconf="--with-rcp=mom_rcp"
+ fi
+
+ [ -n "${PBS_SERVER_NAME}" ] || PBS_SERVER_NAME=$(hostname -f)
+
+ # TODO: Allow cpusets
+ econf \
+ $(use_enable tk gui) \
+ $(use_enable syslog) \
+ $(use_enable server) \
+ --with-server-home=${PBS_SERVER_HOME} \
+ --with-environ=/etc/pbs_environment \
+ --with-default-server=${PBS_SERVER_NAME} \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+# WARNING
+# OpenPBS is extremely stubborn about directory permissions. Sometimes it will
+# just fall over with the error message, but in some spots it will just ignore
+# you and fail strangely. Likewise it also barfs on our .keep files!
+pbs_createspool() {
+ local root="$1"
+ local s="$(dirname "${PBS_SERVER_HOME}")"
+ local h="${PBS_SERVER_HOME}"
+ local sp="${h}/server_priv"
+ einfo "Building spool directory under ${D}${h}"
+ local a d m
+ local dir_spec="
+ 0755:${h}/aux 0700:${h}/checkpoint
+ 0755:${h}/mom_logs 0751:${h}/mom_priv 0751:${h}/mom_priv/jobs
+ 1777:${h}/spool 1777:${h}/undelivered"
+
+ if use server; then
+ dir_spec="${dir_spec} 0755:${h}/sched_logs
+ 0755:${h}/sched_priv/accounting 0755:${h}/server_logs
+ 0750:${h}/server_priv 0755:${h}/server_priv/accounting
+ 0750:${h}/server_priv/acl_groups 0750:${h}/server_priv/acl_hosts
+ 0750:${h}/server_priv/acl_svr 0750:${h}/server_priv/acl_users
+ 0750:${h}/server_priv/jobs 0750:${h}/server_priv/queues"
+ fi
+
+ for a in ${dir_spec}; do
+ d="${a/*:}"
+ m="${a/:*}"
+ if [[ ! -d "${root}${d}" ]]; then
+ install -d -m${m} "${root}${d}"
+ else
+ chmod ${m} "${root}${d}"
+ fi
+ # (#149226) If we're running in src_*, then keepdir
+ if [[ "${root}" = "${D}" ]]; then
+ keepdir ${d}
+ fi
+ done
+}
+
+src_install() {
+ # Make directories first
+ pbs_createspool "${D}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc CHANGELOG DEVELOPMENT README.* Release_Notes || die "dodoc failed"
+ if use doc; then
+ dodoc doc/admin_guide.ps doc/*.pdf || die "dodoc failed"
+ fi
+
+ # this file MUST exist for PBS/Torque to work
+ # but try to preserve any customatizations that the user has made
+ dodir /etc
+ mv "${D}"${PBS_SERVER_HOME}/pbs_environment "${D}"/etc/
+
+ # The build script isn't alternative install location friendly,
+ # So we have to fix some hard-coded paths in tclIndex for xpbs* to work
+ for file in `find "${D}" -iname tclIndex`; do
+ sed -e "s/${D//\// }/ /" "${file}" > "${file}.new"
+ mv "${file}.new" "${file}"
+ done
+
+ if use server; then
+ newinitd "${FILESDIR}"/pbs_server-init.d-2.2.1-r1 pbs_server
+ newinitd "${FILESDIR}"/pbs_sched-init.d-2.2.1-r1 pbs_sched
+ fi
+ newinitd "${FILESDIR}"/pbs_mom-init.d-2.2.1-r1 pbs_mom
+ newconfd "${FILESDIR}"/torque-conf.d-2.2.1-r1 torque
+ newenvd "${FILESDIR}"/torque-env.d-2.2.1-r1 25torque
+}
+
+pkg_preinst() {
+ if [[ -f "${ROOT}etc/pbs_environment" ]]; then
+ cp "${ROOT}etc/pbs_environment" "${D}"/etc/pbs_environment
+ fi
+
+ if [ -n "${PBS_SERVER_NAME}" ]; then
+ echo "${PBS_SERVER_NAME}" > "${D}${PBS_SERVER_HOME}/server_name"
+ elif [[ -f "${ROOT}${PBS_SERVER_HOME}/server_name" ]]; then
+ cp "${ROOT}${PBS_SERVER_HOME}/server_name" "${D}${PBS_SERVER_HOME}/server_name"
+ fi
+
+ # Fix up the conf.d file to use our set server home.
+ sed -i "s:^PBS_SERVER_HOME=.*:PBS_SERVER_HOME=\"${PBS_SERVER_HOME}\":" \
+ "${D}/etc/env.d/25torque"
+}
+
+pkg_postinst() {
+ pbs_createspool "${ROOT}"
+ elog "If this is the first time torque has been installed, then you are not"
+ elog "ready to start the server. Please refer to the documentation located at:"
+ elog "http://www.clusterresources.com/wiki/doku.php?id=torque:torque_wiki"
+
+ elog "For a basic setup, you may use emerge --config ${PN}"
+
+ elog "There are a couple of changes in this ebuild."
+ elog "1.) The pbs-server-home has been moved from /var/spool/PBS to /var/spool/torque."
+ elog "2.) pbs_server, pbs_mom and pbs_sched now have separate init scripts"
+
+ elog "Be sure to run env-update if this is your first install or you"
+ elog "changed PBS_SERVER_HOME!"
+}
+
+
+# Either the correct PBS_SERVER_HOME and PBS_SERVER_NAME are set
+# or we use the default HOME and the localhost as the server.
+# root will be setup as the primary operator/manager, the local machine
+# will be added as a node and we'll create a simple queue, batch.
+pkg_config() {
+ local h="${ROOT}/${PBS_SERVER_HOME}"
+ local rc=0
+
+ ebegin "Configuring Torque"
+ [ -n "${PBS_SERVER_NAME}" ] || PBS_SERVER_NAME=$(hostname -f)
+ einfo "Using ${PBS_SERVER_HOME} as the pbs homedir"
+ einfo "Using ${PBS_SERVER_NAME} as the pbs_server"
+
+ # Check for previous configuration and bail if found.
+ if [ -e "${h}/server_priv/acl_svr/operators" ] \
+ || [ -e "${h}/server_priv/nodes" ] \
+ || [ -e "${h}/mom_priv/config" ]; then
+ ewarn "Previous Torque configuration detected. Press any key to"
+ ewarn "continue or press Control-C to abort now"
+ read
+ fi
+
+ # pbs_mom configuration.
+ echo "\$pbsserver ${PBS_SERVER_NAME}" > "${h}/mom_priv/config"
+ echo "\$logevent 255" >> "${h}/mom_priv/config"
+
+ if use server; then
+ local qmgr="${ROOT}/usr/bin/qmgr -c"
+ if ! echo "y" | "${ROOT}"/usr/sbin/pbs_server \
+ -d "${ROOT}${PBS_SERVER_HOME}" -t create &>/dev/null; then
+ eerror "Failed to start pbs_server"
+ rc=1
+ else
+ ${qmgr} "set server operators = root@$(hostname -f)" ${PBS_SERVER_NAME}
+ ${qmgr} "create queue batch" ${PBS_SERVER_NAME}
+ ${qmgr} "set queue batch queue_type = Execution" ${PBS_SERVER_NAME}
+ ${qmgr} "set queue batch started = True" ${PBS_SERVER_NAME}
+ ${qmgr} "set queue batch enabled = True" ${PBS_SERVER_NAME}
+ ${qmgr} "set server default_queue = batch" ${PBS_SERVER_NAME}
+ ${qmgr} "set server resources_default.nodes = 1" ${PBS_SERVER_NAME}
+ ${qmgr} "set server scheduling = True" ${PBS_SERVER_NAME}
+
+ "${ROOT}"/usr/bin/qterm -t quick ${PBS_SERVER_NAME} || rc=1
+
+ # Add the local machine as a node.
+ echo "$(hostname -f) np=1" > "${h}/server_priv/nodes"
+ fi
+ fi
+ eend ${rc}
+}