summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-27 00:41:28 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-27 00:41:28 +0000
commit554730456bd81e98c2147279e182529be85b6928 (patch)
treedf93559c7f3a067e2dde295fe73320e2368992ea /sys-cluster/neutron
parentAutomated update. (diff)
downloadgentoo-2-554730456bd81e98c2147279e182529be85b6928.tar.gz
gentoo-2-554730456bd81e98c2147279e182529be85b6928.tar.bz2
gentoo-2-554730456bd81e98c2147279e182529be85b6928.zip
new logdir, olso dep fix, /sbin/ip fix, initscript fix, bridge-utils dep fix
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster/neutron')
-rw-r--r--sys-cluster/neutron/ChangeLog11
-rw-r--r--sys-cluster/neutron/files/neutron-initd4
-rw-r--r--sys-cluster/neutron/neutron-2012.2.4-r7.ebuild (renamed from sys-cluster/neutron/neutron-2012.2.4-r6.ebuild)9
-rw-r--r--sys-cluster/neutron/neutron-2013.1.3-r6.ebuild (renamed from sys-cluster/neutron/neutron-2013.1.3-r5.ebuild)10
-rw-r--r--sys-cluster/neutron/neutron-2013.1.9999.ebuild10
-rw-r--r--sys-cluster/neutron/neutron-9999.ebuild10
6 files changed, 43 insertions, 11 deletions
diff --git a/sys-cluster/neutron/ChangeLog b/sys-cluster/neutron/ChangeLog
index b76fa7b2713d..d2d3c07d4a0c 100644
--- a/sys-cluster/neutron/ChangeLog
+++ b/sys-cluster/neutron/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-cluster/neutron
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.10 2013/09/13 20:44:32 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/ChangeLog,v 1.11 2013/09/27 00:41:28 prometheanfire Exp $
+
+*neutron-2013.1.3-r6 (27 Sep 2013)
+*neutron-2012.2.4-r7 (27 Sep 2013)
+
+ 27 Sep 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +neutron-2012.2.4-r7.ebuild, +neutron-2013.1.3-r6.ebuild,
+ -neutron-2012.2.4-r6.ebuild, -neutron-2013.1.3-r5.ebuild, files/neutron-initd,
+ neutron-2013.1.9999.ebuild, neutron-9999.ebuild:
+ new logdir, olso dep fix, /sbin/ip fix, initscript fix, bridge-utils dep fix
*neutron-2013.1.3-r5 (13 Sep 2013)
*neutron-2012.2.4-r6 (13 Sep 2013)
diff --git a/sys-cluster/neutron/files/neutron-initd b/sys-cluster/neutron/files/neutron-initd
index 6ecae4046b01..348e62766c6d 100644
--- a/sys-cluster/neutron/files/neutron-initd
+++ b/sys-cluster/neutron/files/neutron-initd
@@ -28,7 +28,7 @@ start() {
fi
start-stop-daemon --start \
- --user quantum:quantum \
+ --user neutron:neutron \
--quiet \
--pidfile "${PID_PATH}/${SVCNAME}.pid" \
--make-pidfile \
@@ -47,7 +47,7 @@ stop() {
ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --user quantum --quiet --pidfile "${PID_PATH}/${SVCNAME}.pid" \
+ start-stop-daemon --stop --user neutron --quiet --pidfile "${PID_PATH}/${SVCNAME}.pid" \
--exec /usr/bin/${SVCNAME} -- \
--config-file /etc/quantum/quantum.conf \
--config-file /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini \
diff --git a/sys-cluster/neutron/neutron-2012.2.4-r6.ebuild b/sys-cluster/neutron/neutron-2012.2.4-r7.ebuild
index 2ee71ed678ef..6e578db83427 100644
--- a/sys-cluster/neutron/neutron-2012.2.4-r6.ebuild
+++ b/sys-cluster/neutron/neutron-2012.2.4-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2012.2.4-r6.ebuild,v 1.1 2013/09/13 20:44:32 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2012.2.4-r7.ebuild,v 1.1 2013/09/27 00:41:28 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -57,6 +57,7 @@ RDEPEND="=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
~dev-python/webob-1.0.8[${PYTHON_USEDEP}]
net-misc/openvswitch
+ net-misc/bridge-utils
dhcp? ( net-dns/dnsmasq[dhcp-tools] )"
pkg_setup() {
@@ -75,11 +76,15 @@ python_install() {
use metadata && dosym /etc/init.d/quantum /etc/init.d/quantum-metadata-agent
use openvswitch && dosym /etc/init.d/quantum /etc/init.d/quantum-openvswitch-agent
- dodir /var/log/neutron
+ diropts -m 750
+ dodir /var/log/neutron /var/log/quantum
fowners neutron:neutron /var/log/neutron
keepdir /etc/quantum
insinto /etc/quantum
+ #it's /bin/ip not /sbin/ip
+ sed -i 's/sbin\/ip\,/bin\/ip\,/g' "etc/quantum/rootwrap.d/*"
+
doins "etc/api-paste.ini"
doins "etc/dhcp_agent.ini"
doins "etc/l3_agent.ini"
diff --git a/sys-cluster/neutron/neutron-2013.1.3-r5.ebuild b/sys-cluster/neutron/neutron-2013.1.3-r6.ebuild
index 1e83b3967387..0722fc7d20b6 100644
--- a/sys-cluster/neutron/neutron-2013.1.3-r5.ebuild
+++ b/sys-cluster/neutron/neutron-2013.1.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.3-r5.ebuild,v 1.1 2013/09/13 20:44:32 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.3-r6.ebuild,v 1.1 2013/09/27 00:41:28 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -61,7 +61,9 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
dev-python/pyudev[${PYTHON_USEDEP}]
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
+ net-misc/bridge-utils
net-misc/openvswitch
dhcp? ( net-dns/dnsmasq[dhcp-tools] )"
@@ -81,11 +83,15 @@ python_install() {
use metadata && dosym /etc/init.d/quantum /etc/init.d/quantum-metadata-agent
use openvswitch && dosym /etc/init.d/quantum /etc/init.d/quantum-openvswitch-agent
- dodir /var/log/neutron
+ diropts -m 750
+ dodir /var/log/neutron /var/log/quantum
fowners neutron:neutron /var/log/neutron
keepdir /etc/quantum
insinto /etc/quantum
+ #it's /bin/ip not /sbin/ip
+ sed -i 's/sbin\/ip\,/bin\/ip\,/g' "etc/quantum/rootwrap.d/*"
+
doins "etc/api-paste.ini"
doins "etc/dhcp_agent.ini"
doins "etc/l3_agent.ini"
diff --git a/sys-cluster/neutron/neutron-2013.1.9999.ebuild b/sys-cluster/neutron/neutron-2013.1.9999.ebuild
index d4dbbe99c545..a06b14414d85 100644
--- a/sys-cluster/neutron/neutron-2013.1.9999.ebuild
+++ b/sys-cluster/neutron/neutron-2013.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.9999.ebuild,v 1.9 2013/09/13 20:44:32 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-2013.1.9999.ebuild,v 1.10 2013/09/27 00:41:28 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -61,7 +61,9 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
+ net-misc/bridge-utils
net-misc/openvswitch
dhcp? ( net-dns/dnsmasq[dhcp-tools] )"
@@ -81,11 +83,15 @@ python_install() {
use metadata && dosym /etc/init.d/quantum /etc/init.d/quantum-metadata-agent
use openvswitch && dosym /etc/init.d/quantum /etc/init.d/quantum-openvswitch-agent
- dodir /var/log/neutron
+ diropts -m 750
+ dodir /var/log/neutron /var/log/quantum
fowners neutron:neutron /var/log/neutron
keepdir /etc/quantum
insinto /etc/quantum
+ #it's /bin/ip not /sbin/ip
+ sed -i 's/sbin\/ip\,/bin\/ip\,/g' "etc/quantum/rootwrap.d/*"
+
doins "etc/api-paste.ini"
doins "etc/dhcp_agent.ini"
doins "etc/l3_agent.ini"
diff --git a/sys-cluster/neutron/neutron-9999.ebuild b/sys-cluster/neutron/neutron-9999.ebuild
index 9717b5f50502..ec2e0f0a41f9 100644
--- a/sys-cluster/neutron/neutron-9999.ebuild
+++ b/sys-cluster/neutron/neutron-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.6 2013/09/12 22:11:38 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/neutron/neutron-9999.ebuild,v 1.7 2013/09/27 00:41:28 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -60,7 +60,9 @@ RDEPEND=">=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
<dev-python/sqlalchemy-0.7.10[postgres,${PYTHON_USEDEP}] )
>=dev-python/webob-1.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ <dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
+ net-misc/bridge-utils
net-misc/openvswitch
dhcp? ( net-dns/dnsmasq[dhcp-tools] )"
@@ -80,11 +82,15 @@ python_install() {
use metadata && dosym /etc/init.d/neutron /etc/init.d/neutron-metadata-agent
use openvswitch && dosym /etc/init.d/neutron /etc/init.d/neutron-openvswitch-agent
- dodir /var/log/neutron
+ diropts -m 750
+ dodir /var/log/neutron /var/log/quantum
fowners neutron:neutron /var/log/neutron
keepdir /etc/neutron
insinto /etc/neutron
+ #it's /bin/ip not /sbin/ip
+ sed -i 's/sbin\/ip\,/bin\/ip\,/g' "etc/quantum/rootwrap.d/*"
+
doins "etc/api-paste.ini"
doins "etc/dhcp_agent.ini"
doins "etc/l3_agent.ini"