summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-12-11 07:04:13 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-12-11 07:04:13 +0000
commit8ba96a8dab7c886fde09914b4ff7143c4f193ac6 (patch)
tree7424da3802fec593da5ef6849cddef49d2e56496 /sys-cluster/mpiexec
parentNew package: Protein multiple-alignment-based sequence annealing. It's based ... (diff)
downloadgentoo-2-8ba96a8dab7c886fde09914b4ff7143c4f193ac6.tar.gz
gentoo-2-8ba96a8dab7c886fde09914b4ff7143c4f193ac6.tar.bz2
gentoo-2-8ba96a8dab7c886fde09914b4ff7143c4f193ac6.zip
(#156593) Bump (Joseph Spadavecchia). Adds support for new Torque; supports concurrent parallel tasks; increased scalability through use of poll() rather than select().
(Portage version: 2.1.2_rc3-r1)
Diffstat (limited to 'sys-cluster/mpiexec')
-rw-r--r--sys-cluster/mpiexec/ChangeLog9
-rw-r--r--sys-cluster/mpiexec/files/digest-mpiexec-0.823
-rw-r--r--sys-cluster/mpiexec/mpiexec-0.82.ebuild48
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-cluster/mpiexec/ChangeLog b/sys-cluster/mpiexec/ChangeLog
index b0bb3d4458e8..127d84f8985d 100644
--- a/sys-cluster/mpiexec/ChangeLog
+++ b/sys-cluster/mpiexec/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/mpiexec
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/ChangeLog,v 1.13 2006/09/29 16:41:33 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpiexec/ChangeLog,v 1.14 2006/12/11 07:04:13 dberkholz Exp $
+
+*mpiexec-0.82 (11 Dec 2006)
+
+ 11 Dec 2006; Donnie Berkholz <dberkholz@gentoo.org>; +mpiexec-0.82.ebuild:
+ (#156593) Bump (Joseph Spadavecchia). Adds support for new Torque; supports
+ concurrent parallel tasks; increased scalability through use of poll()
+ rather than select().
29 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
mpiexec-0.76-r2.ebuild:
diff --git a/sys-cluster/mpiexec/files/digest-mpiexec-0.82 b/sys-cluster/mpiexec/files/digest-mpiexec-0.82
new file mode 100644
index 000000000000..14cb3ea4c7b4
--- /dev/null
+++ b/sys-cluster/mpiexec/files/digest-mpiexec-0.82
@@ -0,0 +1,3 @@
+MD5 27d12ca52b37186094b2b56b67cc6d40 mpiexec-0.82.tgz 200841
+RMD160 45c483a51e0202e25ae7604f764f7bd0c9bd8109 mpiexec-0.82.tgz 200841
+SHA256 db796cd7b59d9a51e07e8d29d9917ca09893d468c188f109c9a3d453af3d3ace mpiexec-0.82.tgz 200841
diff --git a/sys-cluster/mpiexec/mpiexec-0.82.ebuild b/sys-cluster/mpiexec/mpiexec-0.82.ebuild
new file mode 100644
index 000000000000..4b33d8389b4a
--- /dev/null
+++ b/sys-cluster/mpiexec/mpiexec-0.82.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="replacement for mpirun, integrates MPI with PBS."
+SRC_URI="http://www.osc.edu/~pw/mpiexec/${P}.tgz"
+HOMEPAGE="http://www.osc.edu/~pw/mpiexec/"
+IUSE="sharedmem"
+
+DEPEND="virtual/libc
+ virtual/pbs
+ virtual/mpi"
+RDEPEND="net-misc/openssh"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+src_compile() {
+ # sharedmem should NOT be used on SMP boxes
+ myconf="`use_enable sharedmem p4-shmem`"
+
+ # mpich-p4 is the best default
+ append-ldflags -L/usr/$(get_libdir)/pbs/lib
+ ./configure --mandir=/usr/share/man/man1/ \
+ --prefix=/usr \
+ --with-pbs=/usr \
+ --with-default-comm=mpich-p4 \
+ ${myconf} || die "configure failed"
+
+ make || die "compile failed"
+
+ ## demo-hello: usefull for debugging
+ make hello || die "compile hello failed"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1/ \
+ install || die "install failed"
+
+ ## demo-hello:
+ dodoc hello.c
+ newbin hello hello_mpiexec
+
+ dodoc LICENSE README README.lam ChangeLog
+}