summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-26 04:33:09 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-26 04:33:09 +0000
commit5bbc16364a2e4b564f012c2ad8ecec1a641c5d09 (patch)
tree528d52b29aafdf1a54d272871884b812f130c0b9 /sys-cluster/maui
parentStable x86; ^.^ (diff)
downloadgentoo-2-5bbc16364a2e4b564f012c2ad8ecec1a641c5d09.tar.gz
gentoo-2-5bbc16364a2e4b564f012c2ad8ecec1a641c5d09.tar.bz2
gentoo-2-5bbc16364a2e4b564f012c2ad8ecec1a641c5d09.zip
Bump. Works with PBS installed to /usr/libdir/pbs/lib, so blocks on older openpbs. May not work on torque 1.x either.
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'sys-cluster/maui')
-rw-r--r--sys-cluster/maui/ChangeLog11
-rw-r--r--sys-cluster/maui/files/3.2.6_p16-autoconf-2.60-compat.patch17
-rw-r--r--sys-cluster/maui/files/3.2.6_p16-link-pbs-after-moab.patch25
-rw-r--r--sys-cluster/maui/files/3.2.6_p16-set-pbs-cflags-ldflags.patch26
-rw-r--r--sys-cluster/maui/files/digest-maui-3.2.6_p132
-rw-r--r--sys-cluster/maui/files/digest-maui-3.2.6_p13-r12
-rw-r--r--sys-cluster/maui/files/digest-maui-3.2.6_p163
-rw-r--r--sys-cluster/maui/maui-3.2.6_p16.ebuild47
8 files changed, 132 insertions, 1 deletions
diff --git a/sys-cluster/maui/ChangeLog b/sys-cluster/maui/ChangeLog
index 761cc23a2c5d..489ae55a2baa 100644
--- a/sys-cluster/maui/ChangeLog
+++ b/sys-cluster/maui/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-cluster/maui
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.4 2006/09/25 05:56:33 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/ChangeLog,v 1.5 2006/09/26 04:33:09 dberkholz Exp $
+
+*maui-3.2.6_p16 (26 Sep 2006)
+
+ 26 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/3.2.6_p16-autoconf-2.60-compat.patch,
+ +files/3.2.6_p16-link-pbs-after-moab.patch,
+ +files/3.2.6_p16-set-pbs-cflags-ldflags.patch, +maui-3.2.6_p16.ebuild:
+ Bump. Works with PBS installed to /usr/libdir/pbs/lib, so blocks on older
+ openpbs. May not work on torque 1.x either.
25 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
maui-3.2.6_p13-r1.ebuild:
diff --git a/sys-cluster/maui/files/3.2.6_p16-autoconf-2.60-compat.patch b/sys-cluster/maui/files/3.2.6_p16-autoconf-2.60-compat.patch
new file mode 100644
index 000000000000..e22453dc0b1b
--- /dev/null
+++ b/sys-cluster/maui/files/3.2.6_p16-autoconf-2.60-compat.patch
@@ -0,0 +1,17 @@
+--- maui-3.2.6p16.orig/Makefile.in 2006-05-23 15:20:49.000000000 -0700
++++ maui-3.2.6p16/Makefile.in 2006-09-25 20:42:24.000000000 -0700
+@@ -18,7 +18,13 @@
+ # ============================
+ # Resource Manager section
+ # ============================
+-@ll_definitions@@sdr_definitions@@pbs_definitions@@sge_definitions@@lsf_definitions@@mx_definitions@@pcre_definitions@
++@ll_definitions@
++@sdr_definitions@
++@pbs_definitions@
++@sge_definitions@
++@lsf_definitions@
++@mx_definitions@
++@pcre_definitions@
+
+ # ============================
+ # Master Makefile for @PACKAGE_NAME@-@PACKAGE_VERSION@
diff --git a/sys-cluster/maui/files/3.2.6_p16-link-pbs-after-moab.patch b/sys-cluster/maui/files/3.2.6_p16-link-pbs-after-moab.patch
new file mode 100644
index 000000000000..a4675abe304a
--- /dev/null
+++ b/sys-cluster/maui/files/3.2.6_p16-link-pbs-after-moab.patch
@@ -0,0 +1,25 @@
+--- maui-3.2.6p16.orig/src/server/Makefile 2006-09-25 16:08:33.000000000 -0700
++++ maui-3.2.6p16/src/server/Makefile 2006-09-25 21:12:47.000000000 -0700
+@@ -88,11 +88,11 @@
+ $(CC) $(IP) $(DEFS) $(CFLAGS) $(SOURCE) -c $<
+
+ $(SERVER): $(SOBJECTS)
+- $(LD) $(SOBJECTS) -o $(BIN)/$@ $(LP) $(LIBS) $(OSLDFLAGS)
++ $(LD) $(SOBJECTS) -o $(BIN)/$@ $(LIBS) $(LP) $(OSLDFLAGS)
+ chmod 711 $(BIN)/$@ || true
+
+ mclient: mclient.o
+- $(LD) mclient.o -o $(BIN)/$@ $(OSLDFLAGS) $(LP) $(LIBS)
++ $(LD) mclient.o -o $(BIN)/$@ $(OSLDFLAGS) $(LIBS) $(LP)
+ chmod 751 $(BIN)/$@
+ for i in $(MCLIENTS); do \
+ ln -f $(BIN)/$@ $(BIN)/$$i; \
+@@ -100,7 +100,7 @@
+ done
+
+ mprof: $(POBJECTS)
+- $(LD) $(POBJECTS) -o $(BIN)/$@ $(OSLDFLAGS) $(LP) $(LIBS)
++ $(LD) $(POBJECTS) -o $(BIN)/$@ $(OSLDFLAGS) $(LIBS) $(LP)
+ chmod 751 $(BIN)/$@
+
+ clean:
diff --git a/sys-cluster/maui/files/3.2.6_p16-set-pbs-cflags-ldflags.patch b/sys-cluster/maui/files/3.2.6_p16-set-pbs-cflags-ldflags.patch
new file mode 100644
index 000000000000..7455350a0dc0
--- /dev/null
+++ b/sys-cluster/maui/files/3.2.6_p16-set-pbs-cflags-ldflags.patch
@@ -0,0 +1,26 @@
+--- maui-3.2.6p16.orig/configure.ac 2006-09-25 16:08:33.000000000 -0700
++++ maui-3.2.6p16/configure.ac 2006-09-25 21:29:17.000000000 -0700
+@@ -149,13 +149,19 @@
+ else
+ AC_MSG_ERROR([Only one Resource Manager can be specified (PBS, $RMTYPE)])
+ fi
+- if test "$OS" = "OSF"; then
+- PBSLIBS="$PBSTARGETDIR/ilib/libnet.a -lpbs"
++ if pbs-config --cflags 1>/dev/null 2>&1;then
++ PBSCFLAGS=`pbs-config --cflags`
+ else
+- PBSLIBS="-lnet -lpbs"
++ PBSCFLAGS=-I$PBSTARGETDIR/include
+ fi
++ if pbs-config --libs 1>/dev/null 2>&1;then
++ PBSLDFLAGS=`pbs-config --libs`
++ else
++ PBSLDFLAGS="-L$PBSTARGETDIR/lib -lnet -lpbs"
++ fi
++ AC_SUBST(PBSCFLAGS)
++ AC_SUBST(PBSLDFLAGS)
+ AC_SUBST(PBSTARGETDIR)
+- AC_SUBST(PBSLIBS)
+ AC_SUBST_FILE(pbs_definitions)
+ pbs_definitions=include/Makefile.inc.pbs
+ fi
diff --git a/sys-cluster/maui/files/digest-maui-3.2.6_p13 b/sys-cluster/maui/files/digest-maui-3.2.6_p13
index 908a4a6baf89..5192daf5109e 100644
--- a/sys-cluster/maui/files/digest-maui-3.2.6_p13
+++ b/sys-cluster/maui/files/digest-maui-3.2.6_p13
@@ -1 +1,3 @@
MD5 b330867069ded056f2cf33253fd34c7b maui-3.2.6p13.tar.gz 883810
+RMD160 e712802cf9c39305844e017f604f2f6e0d9dd85d maui-3.2.6p13.tar.gz 883810
+SHA256 a13d347c087300e1dd92d48dd7fbdbe54881be4adc89441dbfc53ff85eb8cf7c maui-3.2.6p13.tar.gz 883810
diff --git a/sys-cluster/maui/files/digest-maui-3.2.6_p13-r1 b/sys-cluster/maui/files/digest-maui-3.2.6_p13-r1
index 908a4a6baf89..5192daf5109e 100644
--- a/sys-cluster/maui/files/digest-maui-3.2.6_p13-r1
+++ b/sys-cluster/maui/files/digest-maui-3.2.6_p13-r1
@@ -1 +1,3 @@
MD5 b330867069ded056f2cf33253fd34c7b maui-3.2.6p13.tar.gz 883810
+RMD160 e712802cf9c39305844e017f604f2f6e0d9dd85d maui-3.2.6p13.tar.gz 883810
+SHA256 a13d347c087300e1dd92d48dd7fbdbe54881be4adc89441dbfc53ff85eb8cf7c maui-3.2.6p13.tar.gz 883810
diff --git a/sys-cluster/maui/files/digest-maui-3.2.6_p16 b/sys-cluster/maui/files/digest-maui-3.2.6_p16
new file mode 100644
index 000000000000..bde967cb9c4f
--- /dev/null
+++ b/sys-cluster/maui/files/digest-maui-3.2.6_p16
@@ -0,0 +1,3 @@
+MD5 7f0da58f1dabb8343538506ac0a47895 maui-3.2.6p16.tar.gz 900100
+RMD160 a5b73924fa56013675b3e7563f2c5a4193a73bcb maui-3.2.6p16.tar.gz 900100
+SHA256 6b86bd90f9e4339f22fc19e1396a0f4c4f453d0274d711373a993ae3d2bcfffb maui-3.2.6p16.tar.gz 900100
diff --git a/sys-cluster/maui/maui-3.2.6_p16.ebuild b/sys-cluster/maui/maui-3.2.6_p16.ebuild
new file mode 100644
index 000000000000..fe34c3b6122d
--- /dev/null
+++ b/sys-cluster/maui/maui-3.2.6_p16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/maui/maui-3.2.6_p16.ebuild,v 1.1 2006/09/26 04:33:09 dberkholz Exp $
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Maui Cluster Scheduler"
+HOMEPAGE="http://www.clusterresources.com/products/maui/"
+SRC_URI="http://www.clusterresources.com/downloads/maui/${P/_/}.tar.gz"
+IUSE=""
+DEPEND="virtual/pbs
+ !<sys-cluster/openpbs-2.3.16-r4"
+RDEPEND="${DEPEND}
+ virtual/libc"
+SLOT="0"
+LICENSE="maui"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="fetch nomirror"
+
+S="${WORKDIR}/${P/_/}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-set-pbs-cflags-ldflags.patch
+ epatch "${FILESDIR}"/${PV}-autoconf-2.60-compat.patch
+ epatch "${FILESDIR}"/${PV}-link-pbs-after-moab.patch
+ sed -i \
+ -e "s~BUILDROOT=~BUILDROOT=${D}~" \
+ "${S}"/Makefile.in
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-spooldir=/usr/spool/maui \
+ --with-pbs=/usr/$(get_libdir)/pbs \
+ || die "econf failed!"
+ emake || die "emake failed!"
+}
+
+src_install() {
+ make install INST_DIR=${D}/usr
+
+ cd docs
+ dodoc README mauidocs.html
+}