summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2009-11-15 13:38:29 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2009-11-15 13:38:29 +0000
commit232bc97a17d7eaad308db55c24a9f602d0cd152a (patch)
tree1a2a33d9fdaeda9c8df2c70fe2e06fa47172f93c /sys-cluster/csync2
parentDrop removed cruft from p.mask (diff)
downloadgentoo-2-232bc97a17d7eaad308db55c24a9f602d0cd152a.tar.gz
gentoo-2-232bc97a17d7eaad308db55c24a9f602d0cd152a.tar.bz2
gentoo-2-232bc97a17d7eaad308db55c24a9f602d0cd152a.zip
Fixed compilation with gnutls-2.xx, thanks to Giampaolo Tomassoni <g.tomassoni@libero.it>.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/csync2')
-rw-r--r--sys-cluster/csync2/ChangeLog8
-rw-r--r--sys-cluster/csync2/csync2-1.34.ebuild23
2 files changed, 23 insertions, 8 deletions
diff --git a/sys-cluster/csync2/ChangeLog b/sys-cluster/csync2/ChangeLog
index 4250ae0321c7..b405db38a6b4 100644
--- a/sys-cluster/csync2/ChangeLog
+++ b/sys-cluster/csync2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/csync2
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.26 2008/11/13 00:29:00 darkside Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.27 2009/11/15 13:38:29 xmerlin Exp $
+
+ 15 Nov 2009; Christian Zoffoli <xmerlin@gentoo.org> csync2-1.34.ebuild:
+ Fixed compilation with gnutls-2.xx, thanks to Giampaolo Tomassoni
+ <g.tomassoni@libero.it>.
13 Nov 2008; Jeremy Olexa <darkside@gentoo.org> csync2-1.34.ebuild:
amd64 stable, bug #246419
diff --git a/sys-cluster/csync2/csync2-1.34.ebuild b/sys-cluster/csync2/csync2-1.34.ebuild
index 854229171570..38524f789f77 100644
--- a/sys-cluster/csync2/csync2-1.34.ebuild
+++ b/sys-cluster/csync2/csync2-1.34.ebuild
@@ -1,29 +1,40 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.34.ebuild,v 1.6 2008/11/13 00:29:00 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.34.ebuild,v 1.7 2009/11/15 13:38:29 xmerlin Exp $
+
+inherit eutils
DESCRIPTION="Cluster synchronization tool."
-SRC_URI="http://oss.linbit.com/csync2/${P}.tar.gz"
+SRC_URI="http://oss.linbit.com/csync2/${P}.tar.gz
+ http://dev.gentoo.org/~xmerlin/dist/csync2-1.34-pure-gnutls.patch.bz2
+ "
HOMEPAGE="http://oss.linbit.com/csync2/"
LICENSE="GPL-2"
KEYWORDS="amd64 x86"
-IUSE=""
+IUSE="ssl"
DEPEND=">=net-libs/librsync-0.9.5
=dev-db/sqlite-2.8*
- >=net-libs/gnutls-1.0.0
+ >=net-libs/gnutls-2.7.3
"
RDEPEND="${DEPEND}"
SLOT="0"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-pure-gnutls.patch || die #274213
+}
+
src_compile() {
econf \
--localstatedir=/var \
--sysconfdir=/etc/csync2 \
+ $(use_enable ssl gnutls) \
|| die "configure problem"
emake || die "compile problem"
@@ -41,7 +52,7 @@ src_install() {
dodir /var/lib/csync2/ || die
keepdir /var/lib/csync2/
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO csync2_locheck.sh
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO csync2_locheck.sh
}
pkg_postinst() {