summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-01-20 11:00:37 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-01-20 11:00:37 +0000
commitd751c35e7c05aa2ce6a62a3e6d96414fc5b1c366 (patch)
tree77b64b940a98b18595fb88f1f9cda9d15198d9e5 /sys-cluster/cman-lib
parentPrevent installation with gtkhtml > 3.30 due bug #341351. (diff)
downloadgentoo-2-d751c35e7c05aa2ce6a62a3e6d96414fc5b1c366.tar.gz
gentoo-2-d751c35e7c05aa2ce6a62a3e6d96414fc5b1c366.tar.bz2
gentoo-2-d751c35e7c05aa2ce6a62a3e6d96414fc5b1c366.zip
Respect multilib paths, cleanup. Drop unused patch.
(Portage version: 2.2.0_alpha10_p22/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/cman-lib')
-rw-r--r--sys-cluster/cman-lib/ChangeLog10
-rw-r--r--sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild47
-rw-r--r--sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch20
3 files changed, 55 insertions, 22 deletions
diff --git a/sys-cluster/cman-lib/ChangeLog b/sys-cluster/cman-lib/ChangeLog
index 018a79e2112b..a85f1e516432 100644
--- a/sys-cluster/cman-lib/ChangeLog
+++ b/sys-cluster/cman-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/cman-lib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman-lib/ChangeLog,v 1.7 2010/10/20 12:34:52 cla Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman-lib/ChangeLog,v 1.8 2011/01/20 11:00:37 xarthisius Exp $
+
+*cman-lib-2.03.09-r1 (20 Jan 2011)
+
+ 20 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ -files/cman-lib-2.02.00-include.patch, +cman-lib-2.03.09-r1.ebuild:
+ Respect multilib paths, cleanup. Drop unused patch.
20 Oct 2010; Dawid Węgliński <cla@gentoo.org> cman-lib-2.03.09.ebuild:
Respect LDFLAGS (#337652)
diff --git a/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild b/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
new file mode 100644
index 000000000000..61ea798dc8ef
--- /dev/null
+++ b/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman-lib/cman-lib-2.03.09-r1.ebuild,v 1.1 2011/01/20 11:00:37 xarthisius Exp $
+
+inherit eutils versionator multilib
+
+MY_P=cluster-${PV}
+
+MAJ_PV=$(get_major_version)
+MIN_PV=$(get_version_component_range 2).$(get_version_component_range 3)
+
+DESCRIPTION="A library for cluster management common to the various pieces of Cluster Suite."
+HOMEPAGE="http://sources.redhat.com/cluster/wiki/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!sys-cluster/cman-headers
+ !sys-cluster/cman-kernel
+ !=sys-cluster/cman-1*"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/${PN/-//}
+
+src_compile() {
+ (cd "${WORKDIR}"/${MY_P};
+ ./configure \
+ --cc="$(tc-getCC)" \
+ --libdir=/usr/$(get_libdir) \
+ --cflags="-Wall" \
+ --disable_kernel_check \
+ --somajor="$MAJ_PV" \
+ --sominor="$MIN_PV" \
+ ) || die "configure problem"
+
+ sed -e 's:\($(CC)\):\1 $(LDFLAGS):' \
+ -i Makefile "${WORKDIR}/${MY_P}/make/cobj.mk" || die
+
+ emake clean all || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch b/sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch
deleted file mode 100644
index 9dc8de388904..000000000000
--- a/sys-cluster/cman-lib/files/cman-lib-2.02.00-include.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- cluster-2.02.00/cman/lib/Makefile.orig 2008-02-26 15:37:43.000000000 +0000
-+++ cluster-2.02.00/cman/lib/Makefile 2008-03-16 15:08:59.000000000 +0000
-@@ -13,6 +13,8 @@
-
- TARGET= libcman
-
-+include ../../make/defines.mk
-+
- LIBDIRT=$(TARGET).a \
- $(TARGET).so.$(RELEASE_MAJOR).$(RELEASE_MINOR)
-
-@@ -21,8 +23,6 @@
-
- INCDIRT=$(TARGET).h
-
--include ../../make/defines.mk
--
- SHAREDLIB=$(TARGET).so.${RELEASE_MAJOR}.${RELEASE_MINOR}
- STATICLIB=$(TARGET).a
-