summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-05-15 09:34:46 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-05-15 09:34:46 +0000
commita0d2df03a8ad34797ddebcc00d624818b0a154d6 (patch)
tree8e6c046f38ed80d28684b65eb7b471d32e74a769 /sys-boot
parentTidy up ebuild. Thanks to Thomas L. Kjeldsen <tlk@mayi.dk>, closing bug #4483... (diff)
downloadgentoo-2-a0d2df03a8ad34797ddebcc00d624818b0a154d6.tar.gz
gentoo-2-a0d2df03a8ad34797ddebcc00d624818b0a154d6.tar.bz2
gentoo-2-a0d2df03a8ad34797ddebcc00d624818b0a154d6.zip
Long overdue version bump...
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/colo/ChangeLog7
-rw-r--r--sys-boot/colo/Manifest4
-rw-r--r--sys-boot/colo/colo-1.9.ebuild96
-rw-r--r--sys-boot/colo/files/digest-colo-1.91
4 files changed, 106 insertions, 2 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index cf5492db0def..3dcac83e5120 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/colo
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.3 2004/04/29 08:14:07 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.4 2004/05/15 09:34:46 kumba Exp $
+
+*colo-1.9 (15 May 2004)
+
+ 15 May 2004; Joshua Kinard <kumba@gentoo.org> +colo-1.9.ebuild:
+ Long overdue version bump...
*colo-1.8 (29 Apr 2004)
diff --git a/sys-boot/colo/Manifest b/sys-boot/colo/Manifest
index 9a88434828d6..a464d2eb9124 100644
--- a/sys-boot/colo/Manifest
+++ b/sys-boot/colo/Manifest
@@ -1,11 +1,13 @@
MD5 2b00b89b8df12875085e6bfb2524a632 colo-1.4.ebuild 3326
MD5 821bbe104fd36eab5f08495277bc5adb metadata.xml 364
MD5 00d25f205e33c99d1a1550b3310de157 colo-1.6.ebuild 3052
-MD5 ed9cd2f5c0d2e0dabf3d659797acb36d ChangeLog 815
+MD5 aed008a26160164d6f444cc0b93e583d ChangeLog 938
MD5 7c43d761abc1fea2ad306f14e17db6d6 colo-1.8.ebuild 3106
+MD5 7c43d761abc1fea2ad306f14e17db6d6 colo-1.9.ebuild 3106
MD5 c1b257fb8b0e15a8f27cbef798f5aede files/colo-1.4-gentoo.patch 2631
MD5 7c11a1ef9a1547e23ae00c09ef797d11 files/digest-colo-1.4 63
MD5 6a9e242bf3b159c4ead248ff40151b32 files/default.boot.example 9
MD5 da6cc3a10feca032228e456bd9e77502 files/colo-1.6-gentoo.patch 1285
MD5 68f29ebc1f7fc45aaf0b1a75db19a3e5 files/digest-colo-1.6 60
MD5 8d935262da6b9a313b6dd36c04cc441a files/digest-colo-1.8 60
+MD5 75b80c5c0056c4f9ccd4b18f783a34c9 files/digest-colo-1.9 60
diff --git a/sys-boot/colo/colo-1.9.ebuild b/sys-boot/colo/colo-1.9.ebuild
new file mode 100644
index 000000000000..a8f3b0334cc6
--- /dev/null
+++ b/sys-boot/colo/colo-1.9.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.9.ebuild,v 1.1 2004/05/15 09:34:46 kumba Exp $
+
+inherit eutils
+
+DESCRIPTION="CObalt Linux lOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND=""
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" != "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for the Cobalt Microserver MIPS-based"
+ eerror "systems. It will not function on any other MIPS-based system or any"
+ eerror "other architecture"
+ echo -e ""
+ die
+ fi
+}
+
+# Not needed for this release, maybe others...
+#src_unpack() {
+# unpack ${A}
+#
+# # patch Docs
+# cd ${S}
+# epatch ${FILESDIR}/${P}-gentoo.patch
+#}
+
+src_compile() {
+ # boot-loader
+ cd ${S}
+ make clean || die # emake breaks the build
+ make || die
+
+ # flash-tool
+ cd ${S}/tools/flash-tool
+ make clean || die
+ make || die
+}
+
+src_install() {
+ # bins
+ cd ${S}
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf ${D}/usr/lib/colo
+ cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+ cp ${FILESDIR}/default.boot.example ${D}/usr/lib/colo/default.colo.example
+
+ # docs
+ dodoc CHANGES COPYING INSTALL README README.{restore,shell} TODO
+
+ # flash-tool
+ dosbin tools/flash-tool/flash-tool
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Binaries for this bootloader have been stored in"
+ einfo "/usr/lib/cobalt-bootloader. Documentation has been"
+ einfo "installed in /usr/share/doc/${PF}. The flash utility"
+ einfo "has been installed as /usr/sbin/flash-tool. An example"
+ einfo "default.colo has been placed in /usr/lib/colo. It is"
+ einfo "a script file the bootloader uses to execute a series"
+ einfo "of commands to load the machine. If you desire the"
+ einfo "machine to boot to the bootloader command prompt, copy"
+ einfo "/usr/lib/colo/default.colo.example to /boot/default.colo,"
+ einfo "otherwise the bootloader will attempt to automatically"
+ einfo "boot /boot/vmlinux.gz. It is recommended that you edit"
+ einfo "the default.colo.example script to fit your needs and"
+ einfo "place it in /boot as default.colo."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}
diff --git a/sys-boot/colo/files/digest-colo-1.9 b/sys-boot/colo/files/digest-colo-1.9
new file mode 100644
index 000000000000..3bd45e092fee
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.9
@@ -0,0 +1 @@
+MD5 b1394a8a4b981f00976d0e996cfb59e8 colo-1.9.tar.gz 192492