summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-10-17 04:11:03 +0000
committerMike Gilbert <floppym@gentoo.org>2013-10-17 04:11:03 +0000
commit9cb9b9de350fb76a85197e4adc548d89889165a1 (patch)
treed3f29e8811a3deab42d3d3b138a57f3b88a30cd1 /sys-boot
parentVersion bump. (diff)
downloadgentoo-2-9cb9b9de350fb76a85197e4adc548d89889165a1.tar.gz
gentoo-2-9cb9b9de350fb76a85197e4adc548d89889165a1.tar.bz2
gentoo-2-9cb9b9de350fb76a85197e4adc548d89889165a1.zip
Work around funky emu platform with USE=static by setting HOST_LDFLAGS instead of LDFLAGS. Bug 488182 by Hodur.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-2.00_p5107-r2.ebuild5
-rw-r--r--sys-boot/grub/grub-9999.ebuild6
3 files changed, 13 insertions, 5 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 8126f334f16c..b395eab40597 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.284 2013/10/16 14:58:17 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.285 2013/10/17 04:11:03 floppym Exp $
+
+ 17 Oct 2013; Mike Gilbert <floppym@gentoo.org> grub-2.00_p5107-r2.ebuild,
+ grub-9999.ebuild:
+ Work around funky emu platform with USE=static by setting HOST_LDFLAGS instead
+ of LDFLAGS. Bug 488182 by Hodur.
*grub-2.00_p5107-r2 (16 Oct 2013)
diff --git a/sys-boot/grub/grub-2.00_p5107-r2.ebuild b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
index 79e8cb4f4181..4e58e33f964f 100644
--- a/sys-boot/grub/grub-2.00_p5107-r2.ebuild
+++ b/sys-boot/grub/grub-2.00_p5107-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.1 2013/10/16 14:58:17 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00_p5107-r2.ebuild,v 1.2 2013/10/17 04:11:03 floppym Exp $
EAPI=5
@@ -79,6 +79,7 @@ DEPEND="${RDEPEND}
sys-apps/help2man
sys-apps/texinfo
static? (
+ app-arch/xz-utils[static-libs(+)]
truetype? (
app-arch/bzip2[static-libs(+)]
media-libs/freetype[static-libs(+)]
@@ -200,7 +201,7 @@ grub_configure() {
src_configure() {
use custom-cflags || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
- use static && append-ldflags -static
+ use static && export HOST_LDFLAGS="${HOST_LDFLAGS} -static"
if version_is_at_least 4.8 "$(gcc-version)"; then
export TARGET_LDFLAGS+=" -fuse-ld=bfd"
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 1e20cf8872ae..96af16188c97 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.107 2013/09/21 21:44:55 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.108 2013/10/17 04:11:03 floppym Exp $
EAPI=5
@@ -79,6 +79,7 @@ DEPEND="${RDEPEND}
sys-apps/help2man
sys-apps/texinfo
static? (
+ app-arch/xz-utils[static-libs(+)]
truetype? (
app-arch/bzip2[static-libs(+)]
media-libs/freetype[static-libs(+)]
@@ -179,6 +180,7 @@ grub_configure() {
--htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
$(use_enable debug mm-debug)
$(use_enable debug grub-emu-usb)
+ $(use_enable device-mapper)
$(use_enable mount grub-mount)
$(use_enable nls)
$(use_enable truetype grub-mkfont)
@@ -199,7 +201,7 @@ grub_configure() {
src_configure() {
use custom-cflags || unset CCASFLAGS CFLAGS CPPFLAGS LDFLAGS
- use static && append-ldflags -static
+ use static && export HOST_LDFLAGS="${HOST_LDFLAGS} -static"
if version_is_at_least 4.8 "$(gcc-version)"; then
export TARGET_LDFLAGS+=" -fuse-ld=bfd"