summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2006-06-16 20:32:54 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2006-06-16 20:32:54 +0000
commit4f5e9324a912b37ce60542ce5b0cb2ae6738ac77 (patch)
tree86c01aa1452e321004766924469c3b0829dc870b /sys-boot
parentUpdated ancient DESCRIPTION. Thank Andrew 'Truck' Holland. Cleaning purposele... (diff)
downloadgentoo-2-4f5e9324a912b37ce60542ce5b0cb2ae6738ac77.tar.gz
gentoo-2-4f5e9324a912b37ce60542ce5b0cb2ae6738ac77.tar.bz2
gentoo-2-4f5e9324a912b37ce60542ce5b0cb2ae6738ac77.zip
Major cleanup & revbump
(Portage version: 2.1)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/silo/ChangeLog11
-rw-r--r--sys-boot/silo/files/digest-silo-1.4.123
-rw-r--r--sys-boot/silo/silo-1.4.12.ebuild55
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-boot/silo/ChangeLog b/sys-boot/silo/ChangeLog
index 783acb3a38ca..681d6d33147a 100644
--- a/sys-boot/silo/ChangeLog
+++ b/sys-boot/silo/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-boot/silo
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.28 2006/04/24 20:41:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/ChangeLog,v 1.29 2006/06/16 20:32:54 gustavoz Exp $
+
+*silo-1.4.12 (16 Jun 2006)
+
+ 16 Jun 2006; Gustavo Zacarias <gustavoz@gentoo.org>
+ -files/silo-1.4.9-sparc_cpu.patch, -silo-1.3.1.ebuild,
+ -silo-1.3.1-r1.ebuild, -silo-1.3.2.ebuild, -silo-1.3.2-r1.ebuild,
+ -silo-1.4.8.ebuild, -silo-1.4.9.ebuild, -silo-1.4.10.ebuild,
+ +silo-1.4.12.ebuild:
+ Major cleanup & revbump
24 Apr 2006; Gustavo Zacarias <gustavoz@gentoo.org> silo-1.4.11-r1.ebuild:
Stable on sparc
diff --git a/sys-boot/silo/files/digest-silo-1.4.12 b/sys-boot/silo/files/digest-silo-1.4.12
new file mode 100644
index 000000000000..8204879f40ac
--- /dev/null
+++ b/sys-boot/silo/files/digest-silo-1.4.12
@@ -0,0 +1,3 @@
+MD5 15e77558c57cae19a790fc100783d8f3 silo-1.4.12.tar.gz 168839
+RMD160 68ec1291630c7d1e58f6d52f31529c226fa982b0 silo-1.4.12.tar.gz 168839
+SHA256 232d23a18236a71bff3c9fe0d081a7bbb5913056a4637496782401b0ed5bdf60 silo-1.4.12.tar.gz 168839
diff --git a/sys-boot/silo/silo-1.4.12.ebuild b/sys-boot/silo/silo-1.4.12.ebuild
new file mode 100644
index 000000000000..f23ccfebd22b
--- /dev/null
+++ b/sys-boot/silo/silo-1.4.12.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/silo/silo-1.4.12.ebuild,v 1.1 2006/06/16 20:32:54 gustavoz Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="SPARC/UltraSPARC Improved Loader, a boot loader for sparc"
+SRC_URI="http://www.sparc-boot.org/pub/silo/${P}.tar.gz"
+HOMEPAGE="http://www.sparc-boot.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* ~sparc"
+IUSE="hardened"
+
+PROVIDE="virtual/bootloader"
+
+DEPEND="sys-fs/e2fsprogs
+ sys-apps/sparc-utils"
+
+ABI_ALLOW="sparc32"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/silo-1.4.x-noglibc_time.patch
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ if use hardened
+ then
+ make ${MAKEOPTS} CC="$(tc-getCC) -fno-stack-protector -fno-pic"
+ else
+ make ${MAKEOPTS} CC="$(tc-getCC)" || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc COPYING ChangeLog first-isofs/README.SILO_ISOFS docs/README*
+
+ # Fix maketilo manpage
+ rm ${D}/usr/share/man/man1/maketilo.1
+ dosym /usr/share/man/man1/tilo.1 /usr/share/man/man1/maketilo.1
+}
+
+pkg_postinst() {
+ ewarn "NOTE: If this is an upgrade to an existing SILO install,"
+ ewarn " you will need to re-run silo as the /boot/second.b"
+ ewarn " file has changed, else the system will fail to load"
+ ewarn " SILO at the next boot."
+}