summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-05-12 16:27:23 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-05-12 16:27:23 +0000
commit1adda15dd620647b56ba2494c12ee9a26e6dfbb4 (patch)
tree46c89f739b45898f0b607bd73beea7b60e701b19 /sys-boot/yaboot
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-1adda15dd620647b56ba2494c12ee9a26e6dfbb4.tar.gz
gentoo-2-1adda15dd620647b56ba2494c12ee9a26e6dfbb4.tar.bz2
gentoo-2-1adda15dd620647b56ba2494c12ee9a26e6dfbb4.zip
gcc - 3.4 compilation fix
Diffstat (limited to 'sys-boot/yaboot')
-rw-r--r--sys-boot/yaboot/files/yaboot-3.4.patch13
-rw-r--r--sys-boot/yaboot/yaboot-1.3.11.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/sys-boot/yaboot/files/yaboot-3.4.patch b/sys-boot/yaboot/files/yaboot-3.4.patch
new file mode 100644
index 000000000000..57964d8a911c
--- /dev/null
+++ b/sys-boot/yaboot/files/yaboot-3.4.patch
@@ -0,0 +1,13 @@
+--- ./lib/strstr.c.orig 2004-05-12 16:16:44.249220125 +0000
++++ ./lib/strstr.c 2004-05-12 16:14:47.245465904 +0000
+@@ -76,7 +76,9 @@
+ a = *++haystack;
+ if (a == '\0')
+ goto ret0;
+-shloop: }
++shloop:
++ a = a;
++ }
+ while (a != b);
+
+ jin: a = *++haystack;
diff --git a/sys-boot/yaboot/yaboot-1.3.11.ebuild b/sys-boot/yaboot/yaboot-1.3.11.ebuild
index ffcf02ca5041..2f163c4ce057 100644
--- a/sys-boot/yaboot/yaboot-1.3.11.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.11.ebuild,v 1.4 2004/03/22 18:26:46 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.11.ebuild,v 1.5 2004/05/12 16:27:23 pvdabeel Exp $
inherit eutils
@@ -26,6 +26,7 @@ src_compile() {
export -n CXXFLAGS
[ -n "${CC}" ] || CC="gcc"
# dual boot patch
+ epatch ${FILESDIR}/yaboot-3.4.patch
epatch ${FILESDIR}/yabootconfig-${PV}.patch
epatch ${FILESDIR}/chrpfix.patch
emake ${MAKEOPTS} CC="${CC}" || die