summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-02-02 07:32:58 +0000
committerJeroen Roovers <jer@gentoo.org>2009-02-02 07:32:58 +0000
commitdc703856da73027c90535cf3a4644015036352e5 (patch)
treec84100a27fee18779256957796d54d84535fe39a /sys-boot/unetbootin
parentDepend on tl-genericrecommended for epsf.tex, bug #257082 (diff)
downloadgentoo-2-dc703856da73027c90535cf3a4644015036352e5.tar.gz
gentoo-2-dc703856da73027c90535cf3a4644015036352e5.tar.bz2
gentoo-2-dc703856da73027c90535cf3a4644015036352e5.zip
Rename patch. Version bump (and use qt4.eclass instead of INSTALL).
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'sys-boot/unetbootin')
-rw-r--r--sys-boot/unetbootin/ChangeLog10
-rw-r--r--sys-boot/unetbootin/files/unetbootin-gentoo.patch (renamed from sys-boot/unetbootin/files/unetbootin-304-syslinux-gentoo.patch)0
-rw-r--r--sys-boot/unetbootin/unetbootin-304-r1.ebuild4
-rw-r--r--sys-boot/unetbootin/unetbootin-307.ebuild4
-rw-r--r--sys-boot/unetbootin/unetbootin-310.ebuild35
5 files changed, 48 insertions, 5 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index 6bbfafe57390..da2a1c30c686 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.3 2009/01/26 03:52:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.4 2009/02/02 07:32:58 jer Exp $
+
+*unetbootin-310 (02 Feb 2009)
+
+ 02 Feb 2009; Jeroen Roovers <jer@gentoo.org>
+ -files/unetbootin-304-syslinux-gentoo.patch,
+ +files/unetbootin-gentoo.patch, unetbootin-304-r1.ebuild,
+ unetbootin-307.ebuild, +unetbootin-310.ebuild:
+ Rename patch. Version bump (and use qt4.eclass instead of INSTALL).
*unetbootin-307 (26 Jan 2009)
diff --git a/sys-boot/unetbootin/files/unetbootin-304-syslinux-gentoo.patch b/sys-boot/unetbootin/files/unetbootin-gentoo.patch
index ce9425668566..ce9425668566 100644
--- a/sys-boot/unetbootin/files/unetbootin-304-syslinux-gentoo.patch
+++ b/sys-boot/unetbootin/files/unetbootin-gentoo.patch
diff --git a/sys-boot/unetbootin/unetbootin-304-r1.ebuild b/sys-boot/unetbootin/unetbootin-304-r1.ebuild
index 1728f9ef0b34..34e93c3aaaea 100644
--- a/sys-boot/unetbootin/unetbootin-304-r1.ebuild
+++ b/sys-boot/unetbootin/unetbootin-304-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-304-r1.ebuild,v 1.1 2009/01/11 16:01:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-304-r1.ebuild,v 1.2 2009/02/02 07:32:58 jer Exp $
inherit eutils
@@ -24,7 +24,7 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${P}-syslinux-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-gentoo.patch
}
src_compile() {
diff --git a/sys-boot/unetbootin/unetbootin-307.ebuild b/sys-boot/unetbootin/unetbootin-307.ebuild
index ca83b3e511de..f0807336d970 100644
--- a/sys-boot/unetbootin/unetbootin-307.ebuild
+++ b/sys-boot/unetbootin/unetbootin-307.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-307.ebuild,v 1.1 2009/01/26 03:52:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-307.ebuild,v 1.2 2009/02/02 07:32:58 jer Exp $
inherit eutils
@@ -24,7 +24,7 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}"/${PN}-304-syslinux-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-gentoo.patch
}
src_compile() {
diff --git a/sys-boot/unetbootin/unetbootin-310.ebuild b/sys-boot/unetbootin/unetbootin-310.ebuild
new file mode 100644
index 000000000000..329076b7a104
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-310.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-310.ebuild,v 1.1 2009/02/02 07:32:58 jer Exp $
+
+inherit qt4
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unetbootin/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_compile() {
+ lupdate unetbootin.pro
+ lrelease unetbootin.pro
+ eqmake4 unetbootin.pro
+ emake || die "make failed"
+}
+
+src_install() {
+ dodoc README.TXT
+ dobin unetbootin || die "dobin failed"
+}