summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-07-23 06:14:33 +0000
committerMichael Weber <xmw@gentoo.org>2013-07-23 06:14:33 +0000
commit5e1f0c76d8b5e79ecc9f4ff614c19ab03d08e877 (patch)
tree1a4c6c0c5f49d600a44c4d3ba17ce36fb5e0cc95 /sys-boot/raspberrypi-firmware
parentRemove vulnerable versions (diff)
downloadgentoo-2-5e1f0c76d8b5e79ecc9f4ff614c19ab03d08e877.tar.gz
gentoo-2-5e1f0c76d8b5e79ecc9f4ff614c19ab03d08e877.tar.bz2
gentoo-2-5e1f0c76d8b5e79ecc9f4ff614c19ab03d08e877.zip
Version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-boot/raspberrypi-firmware')
-rw-r--r--sys-boot/raspberrypi-firmware/ChangeLog8
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130722.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-boot/raspberrypi-firmware/ChangeLog b/sys-boot/raspberrypi-firmware/ChangeLog
index f98ba0f57f29..58f4bb26902a 100644
--- a/sys-boot/raspberrypi-firmware/ChangeLog
+++ b/sys-boot/raspberrypi-firmware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/raspberrypi-firmware
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.4 2013/07/19 12:43:29 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/ChangeLog,v 1.5 2013/07/23 06:14:33 xmw Exp $
+
+*raspberrypi-firmware-0_p20130722 (23 Jul 2013)
+
+ 23 Jul 2013; Michael Weber <xmw@gentoo.org>
+ +raspberrypi-firmware-0_p20130722.ebuild:
+ Version bump
19 Jul 2013; Michael Weber <xmw@gentoo.org>
raspberrypi-firmware-0_p20130711.ebuild,
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130722.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130722.ebuild
new file mode 100644
index 000000000000..de144acf49a3
--- /dev/null
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130722.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0_p20130722.ebuild,v 1.1 2013/07/23 06:14:33 xmw Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="Raspberry PI boot loader and firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_COMMIT="89ac8f4661"
+SRC_URI=""
+for my_src_uri in bootcode.bin fixup{,_cd,_x}.dat start{,_cd,_x}.elf ; do
+ SRC_URI="${SRC_URI} https://github.com/raspberrypi/firmware/raw/${MY_COMMIT}/boot/${my_src_uri} -> ${PN}-${MY_COMMIT}-${my_src_uri}"
+done
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+KEYWORDS="~arm -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+RESTRICT="binchecks strip"
+
+src_unpack() { :; }
+
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ local msg=""
+ if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+ if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
+ msg+="/boot/config.txt "
+ fi
+ if [ -n "${msg}" ] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove(backup) your copies durning install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
+ fi
+}
+
+src_install() {
+ insinto /boot
+ local a
+ for a in ${A} ; do
+ newins "${DISTDIR}"/${a} ${a#${PN}-${MY_COMMIT}-}
+ done
+ newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
+ newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
+ newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"