summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2006-07-17 20:40:09 +0000
committerNed Ludd <solar@gentoo.org>2006-07-17 20:40:09 +0000
commit82cc4f7903a7d18b885f5c012f32822f8c76db5c (patch)
tree8828034076b631803734a38f840512e101053da0 /sys-boot/lilo/lilo-22.7.1.ebuild
parentmissing dep (diff)
downloadgentoo-2-82cc4f7903a7d18b885f5c012f32822f8c76db5c.tar.gz
gentoo-2-82cc4f7903a7d18b885f5c012f32822f8c76db5c.tar.bz2
gentoo-2-82cc4f7903a7d18b885f5c012f32822f8c76db5c.zip
- lilo needs to the LC_ALL=C or strange things can and do happen which must not be risked on a bootloader. bug 140209
(Portage version: 2.1.1_pre2-r7)
Diffstat (limited to 'sys-boot/lilo/lilo-22.7.1.ebuild')
-rw-r--r--sys-boot/lilo/lilo-22.7.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-boot/lilo/lilo-22.7.1.ebuild b/sys-boot/lilo/lilo-22.7.1.ebuild
index 3ffb3aad2ce9..53d57b29199f 100644
--- a/sys-boot/lilo/lilo-22.7.1.ebuild
+++ b/sys-boot/lilo/lilo-22.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.1.ebuild,v 1.1 2006/01/07 13:42:35 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.7.1.ebuild,v 1.2 2006/07/17 20:40:09 solar Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -60,6 +60,9 @@ src_unpack() {
}
src_compile() {
+ # lilo needs this. bug 140209
+ export LC_ALL=C
+
# hardened automatic PIC plus PIE building should be suppressed
# because of assembler instructions that cannot be compiled PIC
HARDENED_CFLAGS="`test-flags-CC -fno-pic -nopie`"