summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-15 23:39:52 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-15 23:39:52 +0000
commitf752634d2cd8740411b12245724739afc4b53c3d (patch)
treea76cef4f1ae5b401295fa9c229a11804ef7a298b /sys-boot/grub/grub-0.96.ebuild
parentamd64 multilib check #85423 (diff)
downloadgentoo-2-f752634d2cd8740411b12245724739afc4b53c3d.tar.gz
gentoo-2-f752634d2cd8740411b12245724739afc4b53c3d.tar.bz2
gentoo-2-f752634d2cd8740411b12245724739afc4b53c3d.zip
Putting ABI stuff inside an 'if use amd64' block.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-boot/grub/grub-0.96.ebuild')
-rw-r--r--sys-boot/grub/grub-0.96.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sys-boot/grub/grub-0.96.ebuild b/sys-boot/grub/grub-0.96.ebuild
index 1069c93892c2..75f4cae6faee 100644
--- a/sys-boot/grub/grub-0.96.ebuild
+++ b/sys-boot/grub/grub-0.96.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96.ebuild,v 1.3 2005/03/11 04:29:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.96.ebuild,v 1.4 2005/03/15 23:39:52 eradicator Exp $
inherit mount-boot eutils flag-o-matic gcc gnuconfig toolchain-funcs
@@ -22,16 +22,18 @@ DEPEND="${RDEPEND}
PROVIDE="virtual/bootloader"
pkg_setup() {
- if ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "If you are on amd64, make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit objects!"
+ if use amd64; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "If you are on amd64, make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit objects!"
+ fi
+
+ ABI_ALLOW="x86"
+ ABI="x86"
fi
-
- ABI_ALLOW="x86"
- ABI="x86"
}
src_unpack() {