summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-25 22:13:20 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-25 22:13:20 +0000
commitdce6b2efb474138663fddfeefefa15309e8da49c (patch)
treea02f67df9d2784d04615fccb58d17c22343426e1 /sys-boot/grub-static
parentAdd ~AMD64 keyword. Tested on a Core 2 Duo T7700. (diff)
downloadgentoo-2-dce6b2efb474138663fddfeefefa15309e8da49c.tar.gz
gentoo-2-dce6b2efb474138663fddfeefefa15309e8da49c.tar.bz2
gentoo-2-dce6b2efb474138663fddfeefefa15309e8da49c.zip
Sync with sys-boot/grub.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-boot/grub-static')
-rw-r--r--sys-boot/grub-static/ChangeLog8
-rw-r--r--sys-boot/grub-static/grub-static-0.97.ebuild25
2 files changed, 19 insertions, 14 deletions
diff --git a/sys-boot/grub-static/ChangeLog b/sys-boot/grub-static/ChangeLog
index f2c7cf889ea2..f04de2f8f714 100644
--- a/sys-boot/grub-static/ChangeLog
+++ b/sys-boot/grub-static/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub-static
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/ChangeLog,v 1.13 2006/12/20 16:21:23 dsd Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/ChangeLog,v 1.14 2008/02/25 22:13:20 wolf31o2 Exp $
+
+ 25 Feb 2008; Chris Gianelloni <wolf31o2@gentoo.org>
+ grub-static-0.97.ebuild:
+ Sync with sys-boot/grub.
20 Dec 2006; Daniel Drake <dsd@gentoo.org> grub-static-0.97.ebuild:
Stable on amd64, bug #156459
diff --git a/sys-boot/grub-static/grub-static-0.97.ebuild b/sys-boot/grub-static/grub-static-0.97.ebuild
index 6ee9b748a982..b21a07664b12 100644
--- a/sys-boot/grub-static/grub-static-0.97.ebuild
+++ b/sys-boot/grub-static/grub-static-0.97.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/grub-static-0.97.ebuild,v 1.4 2006/12/20 16:21:23 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub-static/grub-static-0.97.ebuild,v 1.5 2008/02/25 22:13:20 wolf31o2 Exp $
inherit mount-boot
@@ -27,30 +27,30 @@ src_install() {
setup_boot_dir() {
local dir="${1}"
- [[ ! -e ${dir} ]] && die "${dir} does not exist!"
- [[ ! -e ${dir}/grub ]] && mkdir "${dir}/grub"
+ [[ ! -e "${dir}" ]] && die "${dir} does not exist!"
+ [[ ! -e "${dir}"/grub ]] && mkdir "${dir}/grub"
# change menu.lst to grub.conf
- if [[ ! -e ${dir}/grub/grub.conf ]] && [[ -e ${dir}/grub/menu.lst ]] ; then
+ if [[ ! -e "${dir}"/grub/grub.conf ]] && [[ -e "${dir}"/grub/menu.lst ]] ; then
mv -f "${dir}"/grub/menu.lst "${dir}"/grub/grub.conf
ewarn
ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
ewarn
fi
- if [[ ! -e ${dir}/grub/menu.lst ]]; then
+ if [[ ! -e "${dir}"/grub/menu.lst ]]; then
einfo "Linking from new grub.conf name to menu.lst"
ln -snf grub.conf "${dir}"/grub/menu.lst
fi
- [[ -e ${dir}/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
+ [[ -e "${dir}"/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
- einfo "Copying files from /lib/grub and /usr/lib/grub to "${dir}""
+ einfo "Copying files from /lib/grub and /usr/lib/grub to ${dir}"
for x in /lib*/grub/*/* /usr/lib*/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} "${dir}"/grub/
+ [[ -f "${x}" ]] && cp -p "${x}" "${dir}"/grub/
done
- if [[ -e ${dir}/grub/grub.conf ]] ; then
+ if [[ -e "${dir}"/grub/grub.conf ]] ; then
egrep \
-v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
"${dir}"/grub/grub.conf | \
@@ -61,7 +61,8 @@ setup_boot_dir() {
}
pkg_postinst() {
- [[ ${ROOT} != "/" ]] && return 0
+ [[ "${ROOT}" != "/" ]] && return 0
+ [[ -n ${DONT_MOUNT_BOOT} ]] && return 0
setup_boot_dir /boot
einfo "To install grub files to another device (like a usb stick), just run:"
einfo " emerge --config =${PF}"
@@ -71,5 +72,5 @@ pkg_config() {
local dir
einfo "Enter the directory where you want to setup grub:"
read dir
- setup_boot_dir ${dir}
+ setup_boot_dir "${dir}"
}