summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-27 23:11:13 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-27 23:11:13 +0000
commit63247d2d7d06b6b312d9a532ebef209e32f5f59b (patch)
tree0fe5cc9bf717b9c4a96d31826bc774e6cd476f25 /sys-block
parentArm love #388713 by Norman Shulman. (diff)
downloadgentoo-2-63247d2d7d06b6b312d9a532ebef209e32f5f59b.tar.gz
gentoo-2-63247d2d7d06b6b312d9a532ebef209e32f5f59b.tar.bz2
gentoo-2-63247d2d7d06b6b312d9a532ebef209e32f5f59b.zip
Version bump (bug #387933, acked by Ramereth). Rebundle libsysfs library (fixes bugs #377701 and #382839) and update to EAPI 4.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/megacli/ChangeLog9
-rwxr-xr-xsys-block/megacli/files/megacli-wrapper3
-rw-r--r--sys-block/megacli/megacli-8.02.16.ebuild74
3 files changed, 85 insertions, 1 deletions
diff --git a/sys-block/megacli/ChangeLog b/sys-block/megacli/ChangeLog
index 83bb8c597f54..cce33b9054f9 100644
--- a/sys-block/megacli/ChangeLog
+++ b/sys-block/megacli/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/megacli
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/ChangeLog,v 1.8 2011/07/11 18:42:13 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/ChangeLog,v 1.9 2011/10/27 23:11:13 radhermit Exp $
+
+*megacli-8.02.16 (27 Oct 2011)
+
+ 27 Oct 2011; Tim Harder <radhermit@gentoo.org> +megacli-8.02.16.ebuild,
+ +files/megacli-wrapper:
+ Version bump (bug #387933, acked by Ramereth). Rebundle libsysfs library
+ (fixes bugs #377701 and #382839) and update to EAPI 4.
*megacli-8.01.06 (11 Jul 2011)
diff --git a/sys-block/megacli/files/megacli-wrapper b/sys-block/megacli/files/megacli-wrapper
new file mode 100755
index 000000000000..ec6e2b8dc9da
--- /dev/null
+++ b/sys-block/megacli/files/megacli-wrapper
@@ -0,0 +1,3 @@
+#!/bin/sh
+export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:/opt/megacli/lib"
+exec /opt/megacli/megacli "$@"
diff --git a/sys-block/megacli/megacli-8.02.16.ebuild b/sys-block/megacli/megacli-8.02.16.ebuild
new file mode 100644
index 000000000000..4d3e96d90902
--- /dev/null
+++ b/sys-block/megacli/megacli-8.02.16.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/megacli-8.02.16.ebuild,v 1.1 2011/10/27 23:11:12 radhermit Exp $
+
+EAPI="4"
+
+inherit rpm
+
+DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
+HOMEPAGE="http://www.lsi.com/"
+SRC_URI="http://www.lsi.com/downloads/Public/MegaRAID%20Common%20Files/${PV}_MegaCLI.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ app-admin/chrpath"
+
+S="${WORKDIR}"
+
+RESTRICT="mirror"
+
+QA_PRESTRIPPED="/opt/megacli/megacli"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./LINUX/MegaCliLin.zip
+ rpm_unpack ./MegaCli-${PV}-1.i386.rpm
+ rpm_unpack ./Lib_Utils-1.00-09.noarch.rpm
+}
+
+src_install() {
+ exeinto /opt/megacli
+ libsysfs=libsysfs.so.2.0.2
+ case ${ARCH} in
+ amd64) MegaCli=MegaCli64 libsysfs=x86_64/${libsysfs};;
+ x86) MegaCli=MegaCli;;
+ *) die "invalid ARCH";;
+ esac
+ newexe opt/MegaRAID/MegaCli/${MegaCli} megacli
+
+ exeinto /opt/megacli/lib
+ doexe opt/lsi/3rdpartylibs/${libsysfs}
+
+ into /opt
+ newbin "${FILESDIR}"/${PN}-wrapper ${PN}
+ dosym ${PN} /opt/bin/MegaCli
+
+ dodoc ${PV}_MegaCLI.txt
+
+ # Get a rid of DT_RPATH
+ chrpath -d "${D}"/opt/megacli/megacli
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See /usr/share/doc/${PF}/${PV}_MegaCli.txt for a list of supported controllers"
+ einfo "(contains LSI model names only, not those sold by 3rd parties"
+ einfo "under custom names like Dell PERC etc)."
+ einfo
+ einfo "As there's no dedicated manual, you might want to have"
+ einfo "a look at the following cheat sheet (originally written"
+ einfo "for Dell PowerEdge Expandable RAID Controllers):"
+ einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
+ einfo
+ einfo "For more information about working with Dell PERCs see:"
+ einfo "http://tools.rapidsoft.de/perc/"
+ einfo
+}