summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-06 21:26:32 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-06 21:26:32 +0000
commit5a2b8f5f57e2b9da3d7adb9066c29d3c2643fb57 (patch)
treec0d348205bfaf15d49d14d4dd564890328ce1b65 /sys-block
parentmarked x86 per bug 450334 (diff)
downloadgentoo-2-5a2b8f5f57e2b9da3d7adb9066c29d3c2643fb57.tar.gz
gentoo-2-5a2b8f5f57e2b9da3d7adb9066c29d3c2643fb57.tar.bz2
gentoo-2-5a2b8f5f57e2b9da3d7adb9066c29d3c2643fb57.zip
Version bump #450612 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/di/ChangeLog10
-rw-r--r--sys-block/di/di-4.33.ebuild37
-rw-r--r--sys-block/di/files/di-4.33-build.patch40
3 files changed, 85 insertions, 2 deletions
diff --git a/sys-block/di/ChangeLog b/sys-block/di/ChangeLog
index 8e26fd8a8e3d..46ac54995b1e 100644
--- a/sys-block/di/ChangeLog
+++ b/sys-block/di/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/di
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/di/ChangeLog,v 1.41 2012/10/24 07:01:52 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/di/ChangeLog,v 1.42 2013/01/06 21:26:32 vapier Exp $
+
+*di-4.33 (06 Jan 2013)
+
+ 06 Jan 2013; Mike Frysinger <vapier@gentoo.org> +di-4.33.ebuild,
+ +files/di-4.33-build.patch:
+ Version bump #450612 by Agostino Sarubbo.
*di-4.32 (24 Oct 2012)
diff --git a/sys-block/di/di-4.33.ebuild b/sys-block/di/di-4.33.ebuild
new file mode 100644
index 000000000000..d7ae5915f864
--- /dev/null
+++ b/sys-block/di/di-4.33.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/di/di-4.33.ebuild,v 1.1 2013/01/06 21:26:32 vapier Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="test" #405205, #405471
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.33-build.patch
+}
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README
+}
diff --git a/sys-block/di/files/di-4.33-build.patch b/sys-block/di/files/di-4.33-build.patch
new file mode 100644
index 000000000000..adefb4993885
--- /dev/null
+++ b/sys-block/di/files/di-4.33-build.patch
@@ -0,0 +1,40 @@
+These are the first errors occuring:
+
+di.h:82:4: error: unknown type name ‘error’
+di.h:82:19: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘/’ token
+di.h:143:5: error: unknown type name ‘_fs_size_t’
+
+Then there is a lot more errors after above.
+
+memcpy can't be detected normally due to:
+ http://gcc.gnu.org/PR55890
+
+--- C/di.h
++++ C/di.h
+@@ -9,6 +9,8 @@
+
+ #include "config.h"
+
++#include <string.h>
++
+ /*****************************************************/
+
+ #include <stdio.h>
+@@ -79,7 +81,7 @@
+
+ #if ! _lib_memcpy && ! _define_memcpy
+ # if ! _lib_bcopy && ! _define_bcopy
+- #error No_memcpy/bcopy_available.
++ //#error No_memcpy/bcopy_available.
+ # else
+ # define memcpy(dst, src, cnt) (bcopy((src), (dst), (cnt)), dst)
+ # endif
+@@ -87,7 +89,7 @@
+
+ #if ! _lib_memset && ! _define_memset
+ # if ! _lib_bzero && ! _define_bzero
+- #error No_memset/bzero_available.
++ //#error No_memset/bzero_available.
+ # else
+ # define memset(s,c,n) (bzero ((s), (n)), s)
+ # endif