summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-09 09:19:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-09 09:19:21 +0000
commit3641b7841a7e5097d898029ee4b2bcec90d66168 (patch)
tree0923fd95e6a657abf9894ff74a72c3f948901d23 /sys-block
parentDo not depend on gconf, it's not used if a recent gsettings-desktop-schemas i... (diff)
downloadgentoo-2-3641b7841a7e5097d898029ee4b2bcec90d66168.tar.gz
gentoo-2-3641b7841a7e5097d898029ee4b2bcec90d66168.tar.bz2
gentoo-2-3641b7841a7e5097d898029ee4b2bcec90d66168.zip
Bug #400619: respect user CC/AR values during build.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/open-iscsi/ChangeLog7
-rw-r--r--sys-block/open-iscsi/files/open-iscsi-2.0.872-makefile-cleanup-pass2.patch55
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.872.ebuild11
3 files changed, 69 insertions, 4 deletions
diff --git a/sys-block/open-iscsi/ChangeLog b/sys-block/open-iscsi/ChangeLog
index faf0c2cede0f..875af0438b5b 100644
--- a/sys-block/open-iscsi/ChangeLog
+++ b/sys-block/open-iscsi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/open-iscsi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.40 2012/02/09 08:35:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/ChangeLog,v 1.41 2012/02/09 09:19:21 robbat2 Exp $
+
+ 09 Feb 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +files/open-iscsi-2.0.872-makefile-cleanup-pass2.patch,
+ open-iscsi-2.0.872.ebuild:
+ Bug #400619: respect user CC/AR values during build.
09 Feb 2012; Robin H. Johnson <robbat2@gentoo.org>
files/iscsid-2.0.871-r1.init.d, files/iscsid-conf.d:
diff --git a/sys-block/open-iscsi/files/open-iscsi-2.0.872-makefile-cleanup-pass2.patch b/sys-block/open-iscsi/files/open-iscsi-2.0.872-makefile-cleanup-pass2.patch
new file mode 100644
index 000000000000..fb563d10e1bc
--- /dev/null
+++ b/sys-block/open-iscsi/files/open-iscsi-2.0.872-makefile-cleanup-pass2.patch
@@ -0,0 +1,55 @@
+diff -NuarwbB open-iscsi-2.0-872/usr/Makefile open-iscsi-2.0-872.orig/usr/Makefile
+--- open-iscsi-2.0-872.orig/usr/Makefile 2012-02-09 08:58:04.402623915 +0000
++++ open-iscsi-2.0-872/usr/Makefile 2012-02-09 08:56:51.159070006 +0000
+@@ -65,6 +65,6 @@
+ rm -f *.o $(PROGRAMS) .depend $(LIBSYS)
+
+ depend:
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+- gcc $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+diff -NuarwbB open-iscsi-2.0-872/utils/fwparam_ibft/Makefile open-iscsi-2.0-872.orig/utils/fwparam_ibft/Makefile
+--- open-iscsi-2.0-872.orig/utils/fwparam_ibft/Makefile 2012-02-09 08:57:58.579273051 +0000
++++ open-iscsi-2.0-872/utils/fwparam_ibft/Makefile 2010-08-11 15:27:07.000000000 +0000
+@@ -38,6 +38,6 @@
+ $(OBJS): prom_parse.tab.h prom_parse.h fwparam_ibft.h
+
+ depend:
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+- gcc $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+diff -NuarwbB open-iscsi-2.0-872/utils/Makefile open-iscsi-2.0-872.orig/utils/Makefile
+--- open-iscsi-2.0-872.orig/utils/Makefile 2012-02-09 08:57:37.825877235 +0000
++++ open-iscsi-2.0-872/utils/Makefile 2012-02-09 08:56:51.145736633 +0000
+@@ -12,6 +12,6 @@
+ rm -f *.o $(PROGRAMS) .depend
+
+ depend:
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+- gcc $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+diff -NuarwbB open-iscsi-2.0-872/utils/open-isns/Makefile.in open-iscsi-2.0-872.orig/utils/open-isns/Makefile.in
+--- open-iscsi-2.0-872.orig/utils/open-isns/Makefile.in 2012-02-09 08:57:47.812573971 +0000
++++ open-iscsi-2.0-872/utils/open-isns/Makefile.in 2010-08-11 15:27:07.000000000 +0000
+@@ -77,6 +77,6 @@
+ ar cr $@ $(LIBOBJS)
+
+ depend:
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+- gcc $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
+diff -NuarwbB open-iscsi-2.0-872/utils/sysdeps/Makefile open-iscsi-2.0-872.orig/utils/sysdeps/Makefile
+--- open-iscsi-2.0-872.orig/utils/sysdeps/Makefile 2012-02-09 08:57:43.459227530 +0000
++++ open-iscsi-2.0-872/utils/sysdeps/Makefile 2010-08-11 15:27:07.000000000 +0000
+@@ -10,6 +10,6 @@
+ rm -f *.o .depend
+
+ depend:
++ $(CC) $(CFLAGS) -M `ls *.c` > .depend
+- gcc $(CFLAGS) -M `ls *.c` > .depend
+
+ -include .depend
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
index cfcc3c9f78a4..397e88e59b6a 100644
--- a/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
+++ b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild,v 1.4 2012/02/09 08:29:45 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild,v 1.5 2012/02/09 09:19:21 robbat2 Exp $
EAPI=2
-inherit versionator linux-info eutils flag-o-matic
+inherit versionator linux-info eutils flag-o-matic toolchain-funcs
DESCRIPTION="Open-iSCSI is a high performance, transport independent, multi-platform implementation of RFC3720"
HOMEPAGE="http://www.open-iscsi.org/"
@@ -46,6 +46,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-dont-call-configure.patch
epatch "${FILESDIR}"/${P}-ldflags.patch
epatch "${FILESDIR}"/${P}-isns-slp.patch
+ epatch "${FILESDIR}"/${PN}-2.0.872-makefile-cleanup-pass2.patch
}
src_configure() {
@@ -60,7 +61,11 @@ src_compile() {
local SLP_LIBS
use slp && SLP_LIBS="-lslp"
cd "${S}" && \
- KSRC="${KV_DIR}" CFLAGS="" emake OPTFLAGS="${CFLAGS}" SLP_LIBS="${SLP_LIBS}" user \
+ KSRC="${KV_DIR}" CFLAGS="" \
+ emake \
+ OPTFLAGS="${CFLAGS}" SLP_LIBS="${SLP_LIBS}" \
+ AR="$(tc-getAR)" CC="$(tc-getCC)" \
+ user \
|| die "emake failed"
}