summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-11-03 21:03:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-11-03 21:03:05 +0000
commit26f71de265d1d3128da9556af0093537889c52ff (patch)
tree3bffb59808fca5dbcf89b26aa2580419d13ef02c /sys-block
parentMask app-emulation/qenv for treecleaning, doesn't build, qemu changed too much. (diff)
downloadgentoo-2-26f71de265d1d3128da9556af0093537889c52ff.tar.gz
gentoo-2-26f71de265d1d3128da9556af0093537889c52ff.tar.bz2
gentoo-2-26f71de265d1d3128da9556af0093537889c52ff.zip
Version bump, also change description per bug #466166.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/fio/ChangeLog7
-rw-r--r--sys-block/fio/fio-2.0.15.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-block/fio/ChangeLog b/sys-block/fio/ChangeLog
index 52dcd0f1b157..098b7b6cbd32 100644
--- a/sys-block/fio/ChangeLog
+++ b/sys-block/fio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/fio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/ChangeLog,v 1.37 2013/11/03 06:06:57 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/ChangeLog,v 1.38 2013/11/03 21:03:05 robbat2 Exp $
+
+*fio-2.0.15 (03 Nov 2013)
+
+ 03 Nov 2013; Robin H. Johnson <robbat2@gentoo.org> +fio-2.0.15.ebuild:
+ Version bump, also change description per bug #466166.
03 Nov 2013; Matthew Thode <prometheanfire@gentoo.org> metadata.xml:
adding myself to the list of maintainers
diff --git a/sys-block/fio/fio-2.0.15.ebuild b/sys-block/fio/fio-2.0.15.ebuild
new file mode 100644
index 000000000000..34f726ac249b
--- /dev/null
+++ b/sys-block/fio/fio-2.0.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-2.0.15.ebuild,v 1.1 2013/11/03 21:03:05 robbat2 Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Write job files matching the I/O load one wants to simulate."
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e '/filter /s:-o:$(LDFLAGS) -o:' \
+ -e '/: depend$/d' \
+ -e '/^DEBUGFLAGS/s, -D_FORTIFY_SOURCE=2,,g' \
+ Makefile || die
+ epatch "$FILESDIR"/fio-2.0.14-pic-clobber-fix.patch
+}
+
+src_configure() {
+ : # not a real configure script
+ ./configure --extra-cflags="${CFLAGS}" --cc="$(tc-getCC)"
+}
+
+src_compile() {
+ append-flags -W
+ emake V=1
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+ doman fio.1
+}