summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-07-05 09:53:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-07-05 09:53:39 +0000
commitad4df4ee58a640e66f4c22bd431544e01faa4ec5 (patch)
treedc86b1f784a253d6160dd3962a5b05de8c4d0518 /sys-block/vblade
parentFixup for libtool-2.2 wrt bug #226525. Thanks Rafał Mużyło <galtgendo@o2.pl>. (diff)
downloadgentoo-2-ad4df4ee58a640e66f4c22bd431544e01faa4ec5.tar.gz
gentoo-2-ad4df4ee58a640e66f4c22bd431544e01faa4ec5.tar.bz2
gentoo-2-ad4df4ee58a640e66f4c22bd431544e01faa4ec5.zip
Bug #209792, use "vbladed?" and a shorter chunk of arguments to match more processes.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc4-00103-g1beee8d x86_64)
Diffstat (limited to 'sys-block/vblade')
-rw-r--r--sys-block/vblade/ChangeLog9
-rw-r--r--sys-block/vblade/files/init.d-vblade.vblade0-14-r1114
-rw-r--r--sys-block/vblade/vblade-14-r1.ebuild43
3 files changed, 165 insertions, 1 deletions
diff --git a/sys-block/vblade/ChangeLog b/sys-block/vblade/ChangeLog
index ba0b7a2a0469..ae71e0b72ec9 100644
--- a/sys-block/vblade/ChangeLog
+++ b/sys-block/vblade/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-block/vblade
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/ChangeLog,v 1.19 2008/01/14 02:14:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/ChangeLog,v 1.20 2008/07/05 09:53:38 robbat2 Exp $
+
+*vblade-14-r1 (05 Jul 2008)
+
+ 05 Jul 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/init.d-vblade.vblade0-14-r1, +vblade-14-r1.ebuild:
+ Bug #209792, use "vbladed?" and a shorter chunk of arguments to match more
+ processes.
14 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> metadata.xml,
-vblade-6.ebuild, -vblade-9.ebuild, -vblade-10.ebuild,
diff --git a/sys-block/vblade/files/init.d-vblade.vblade0-14-r1 b/sys-block/vblade/files/init.d-vblade.vblade0-14-r1
new file mode 100644
index 000000000000..93d0a92b251a
--- /dev/null
+++ b/sys-block/vblade/files/init.d-vblade.vblade0-14-r1
@@ -0,0 +1,114 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/files/init.d-vblade.vblade0-14-r1,v 1.1 2008/07/05 09:53:39 robbat2 Exp $
+
+opts="${opts} checkconfig"
+
+depend() {
+ need net
+}
+
+conf="$(add_suffix /etc/conf.d/vblade)"
+[[ -e "${conf}" ]] && source "${conf}"
+vblade_name="${myservice#*.}"
+vblade_conf_variable="config_${vblade_name}"
+vblade_conf="${!vblade_conf_variable}"
+pidfile="/var/run/vblade-${vblade_name}.pid"
+srvname="vblade.${vblade_name}"
+
+getconfig() {
+ tmp="${vblade_conf}"
+ shelf="${tmp/ *}"
+ tmp="${tmp#* }"
+ slot="${tmp/ *}"
+ tmp="${tmp#* }"
+ netif="${tmp/ *}"
+ tmp="${tmp#* }"
+ src="${tmp}"
+ export shelf slot netif src
+}
+
+
+checkconfig() {
+ if [ -z "${vblade_conf}" ]; then
+ eerror "vblade configuration not specified for ${vblade_name}"
+ return 1
+ fi
+ getconfig
+
+ is_valid_numeric "${shelf}" 0
+ if [[ $? -ne 0 ]]; then
+ eerror "Shelf '${shelf}' is non-numeric or less than zero."
+ return 1
+ fi
+ is_valid_numeric "${slot}" 0 15
+ if [[ $? -ne 0 ]]; then
+ eerror "Slot '${slot}' is outside the valid range [0..15]."
+ return 1
+ fi
+
+ sysfs_base="/sys/class/net/"
+ procfs_base="/proc/sys/net/ipv4/conf/"
+ if test ! \( -e "${sysfs_base}${netif}" -o -e "${procfs_base}${netif}" \); then
+ eerror "Network interface '${netif}' does not exist"
+ return 1
+ fi
+
+ if test ! \( -f "${src}" -o -b "${src}" \) ; then
+ eerror "Source '${src}' must be a file or block device"
+ return 1
+ fi
+
+ if test ! \( -e "${src}" -a -r "${src}" \) ; then
+ eerror "Source '${src}' is not readable."
+ return 1
+ fi
+
+ return 0
+}
+
+is_valid_numeric() {
+ num="${1}"
+ min="${2}"
+ max="${3}"
+ # non-numeric
+ test "$num" -ge "0" 2>/dev/null
+ rc=$?
+ test "$rc" -eq 2 && return 2
+ # check for min
+ test -z "$min" && return 0
+ test "$num" -lt "$min" && return 1
+ # check for max
+ test -z "$max" && return 0
+ test "$num" -gt "$max" && return 1
+ # done
+ return 0
+}
+
+start() {
+ checkconfig || return 1
+ getconfig
+ ebegin "Starting ${srvname}: e${shelf}.${slot} on ${netif} using '${src}'"
+ export LOGTAG="${srvname}"
+ start-stop-daemon --start --quiet \
+ --pidfile ${pidfile} --background \
+ --make-pidfile --exec /usr/sbin/vbladed -- \
+ ${shelf} ${slot} ${netif} "${src}"
+ eend $?
+
+ #${shelf} ${slot} ${netif} "${src}" 2>&1 | logger -t ${srvname} &
+}
+
+stop() {
+ ebegin "Stopping ${srvname}"
+ #start-stop-daemon --stop --quiet --pidfile ${pidfile}
+ getconfig
+ ps -Ao pid,args | egrep "^[[:space:]]*[[:digit:]]+ /usr/sbin/vbladed? ${shelf} ${slot}" | awk '{print $1}' | xargs kill
+ eend $?
+
+ #start-stop-daemon --stop --quiet --exec /usr/sbin/vblade
+}
+
+# vim: ft=gentoo-init-d syntax=gentoo-init-d :
+# vim: ai sw=4 sts=4 ts=4 :
diff --git a/sys-block/vblade/vblade-14-r1.ebuild b/sys-block/vblade/vblade-14-r1.ebuild
new file mode 100644
index 000000000000..db96ba8e7443
--- /dev/null
+++ b/sys-block/vblade/vblade-14-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/vblade/vblade-14-r1.ebuild,v 1.1 2008/07/05 09:53:38 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="vblade exports a block device using AoE"
+HOMEPAGE="http://sf.net/projects/aoetools/"
+#SRC_URI="mirror://sourceforge/aoetools/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/aoetools/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # messy tarball
+ make clean || die "Failed to clean up source"
+ sed -i 's,^CFLAGS.*,CFLAGS += -Wall,' makefile || die "Failed to clean up makefile"
+}
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ doman vblade.8
+ dodoc HACKING NEWS README
+ dosbin vblade
+ dosbin "${FILESDIR}"/vbladed
+ newconfd "${FILESDIR}"/conf.d-vblade vblade
+ newinitd "${FILESDIR}"/init.d-vblade.vblade0-14-r1 vblade.vblade0
+}
+
+pkg_postinst() {
+ einfo "We do now include an init.d script, please look in your init.d and"
+ einfo "conf.d directories for it."
+}