summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-14 20:00:20 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-14 20:00:20 +0000
commite7761f86cf97a88fa27ca6185a3c27f2a77a9a89 (patch)
treed99bbbcf39fad912d5d8b759440909badbacf6de /sys-block/gcloop/gcloop-0.99.20040621.ebuild
parentstable on amd64 and x86 wrt #84704 (diff)
downloadgentoo-2-e7761f86cf97a88fa27ca6185a3c27f2a77a9a89.tar.gz
gentoo-2-e7761f86cf97a88fa27ca6185a3c27f2a77a9a89.tar.bz2
gentoo-2-e7761f86cf97a88fa27ca6185a3c27f2a77a9a89.zip
Moved from sys-apps/gcloop to sys-block/gcloop.
Diffstat (limited to 'sys-block/gcloop/gcloop-0.99.20040621.ebuild')
-rw-r--r--sys-block/gcloop/gcloop-0.99.20040621.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-block/gcloop/gcloop-0.99.20040621.ebuild b/sys-block/gcloop/gcloop-0.99.20040621.ebuild
new file mode 100644
index 000000000000..02a74d9c70e8
--- /dev/null
+++ b/sys-block/gcloop/gcloop-0.99.20040621.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/gcloop/gcloop-0.99.20040621.ebuild,v 1.1 2005/03/14 20:00:20 ciaranm Exp $
+
+DESCRIPTION="Compressed loopback userspace tools and kernel patches"
+
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/gcloop"
+
+SRC_URI="http://dev.gentoo.org/~lu_zero/gcloop/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="alpha amd64 ppc64 ~hppa ppc ~sparc ~x86"
+
+IUSE=""
+
+DEPEND="dev-libs/ucl"
+
+S=${WORKDIR}/${PN}-0.99
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ exeinto /usr/bin
+
+ dobin compress_gcloop_ucl
+ dobin compressloop_ucl
+ dobin create_compressed_ucl_fs
+ dobin create_gcloop_ucl
+ dobin extract_compressed_ucl_fs
+ dobin extract_gcloop_ucl
+
+ doman ${S}/man/*.1
+
+ dodir /usr/share/gcloop/
+ insinto /usr/share/gcloop/
+ doins ${S}/*.patch
+ doins ${S}/busybox/*.patch
+ doins ${S}/util-linux/*.patch
+
+ dodoc CHANGELOG README*
+}
+
+pkg_postinst() {
+ ewarn "This is a gcloop prerelease, userspace tool may change."
+ ewarn "Please report any bug to lu_zero@gentoo.org via e-mail "
+ ewarn "or bugzilla. "
+ ewarn "REMEBER this is a PRERELEASE"
+ echo
+ einfo "the required patches are installed in /usr/share/gcloop ."
+ einfo "ppc-development-sources and gentoo-dev-sources are"
+ einfo "already patched."
+}