summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-01-17 20:46:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-01-17 20:46:17 +0000
commit27bec75b7460f5be550d146aff450f07865c1c65 (patch)
treec10f9fea7150c44ff3528758a1f7f87c5684b871 /sys-block/fio
parentPrevious form still fails when EPREFIX contains >= spaced (#452170#c4 by Arfr... (diff)
downloadgentoo-2-27bec75b7460f5be550d146aff450f07865c1c65.tar.gz
gentoo-2-27bec75b7460f5be550d146aff450f07865c1c65.tar.bz2
gentoo-2-27bec75b7460f5be550d146aff450f07865c1c65.zip
Bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-block/fio')
-rw-r--r--sys-block/fio/ChangeLog10
-rw-r--r--sys-block/fio/fio-2.0.13.ebuild44
2 files changed, 51 insertions, 3 deletions
diff --git a/sys-block/fio/ChangeLog b/sys-block/fio/ChangeLog
index cafd18a53903..c29d153aa8d3 100644
--- a/sys-block/fio/ChangeLog
+++ b/sys-block/fio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/fio
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/ChangeLog,v 1.26 2012/11/11 15:29:39 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/ChangeLog,v 1.27 2013/01/17 20:46:17 robbat2 Exp $
+
+*fio-2.0.13 (17 Jan 2013)
+
+ 17 Jan 2013; Robin H. Johnson <robbat2@gentoo.org> +fio-2.0.13.ebuild:
+ Bump.
*fio-2.0.10 (11 Nov 2012)
@@ -116,4 +121,3 @@
18 Aug 2007; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+fio-1.17.ebuild:
Initial Commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
-
diff --git a/sys-block/fio/fio-2.0.13.ebuild b/sys-block/fio/fio-2.0.13.ebuild
new file mode 100644
index 000000000000..156a6cf67f5e
--- /dev/null
+++ b/sys-block/fio/fio-2.0.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-2.0.13.ebuild,v 1.1 2013/01/17 20:46:17 robbat2 Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libaio"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e '/filter /s:-o:$(LDFLAGS) -o:' \
+ -e '/: depend$/d' \
+ Makefile || die
+}
+
+src_compile() {
+ append-flags -W
+ emake V=1 CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+ doman fio.1
+}