summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-05-07 09:20:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-05-07 09:20:17 +0000
commit67c9546aab93e13815e33a2d4701dc3a28963268 (patch)
tree6334efd7807ae5a10d747467f58b7d241ef29eb8 /sys-block/btrace/btrace-0.0.20060428050322.ebuild
parentCleanup the progress bar patch, fix the cs.po date translation, and add fix f... (diff)
downloadgentoo-2-67c9546aab93e13815e33a2d4701dc3a28963268.tar.gz
gentoo-2-67c9546aab93e13815e33a2d4701dc3a28963268.tar.bz2
gentoo-2-67c9546aab93e13815e33a2d4701dc3a28963268.zip
Initial package by Robin H. Johnson <robbat2@gentoo.org>.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'sys-block/btrace/btrace-0.0.20060428050322.ebuild')
-rw-r--r--sys-block/btrace/btrace-0.0.20060428050322.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-block/btrace/btrace-0.0.20060428050322.ebuild b/sys-block/btrace/btrace-0.0.20060428050322.ebuild
new file mode 100644
index 000000000000..e50d0e9aab2e
--- /dev/null
+++ b/sys-block/btrace/btrace-0.0.20060428050322.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/btrace/btrace-0.0.20060428050322.ebuild,v 1.1 2006/05/07 09:20:17 robbat2 Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue."
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+# this is in case Jens ever releases a real version
+MY_PV="${PV/0.0.}"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${MY_PV}"
+SRC_URI="mirror://kernel/linux/kernel/people/axboe/${MY_PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc"
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ || ( sys-kernel/linux-headers sys-kernel/mips-headers )
+ docs? ( app-text/tetex )"
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall -W" || die "emake failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" || die "emake install failed"
+ dodoc README
+ use doc && doc/blktrace.pdf
+}
+