summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-07-22 20:00:57 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-07-22 20:00:57 +0000
commitf39da4d6d8b9a501d2421dd5518e84798a538178 (patch)
treef92ec751a75de8899429588d7ef5f07e8f9c2ad9 /sys-auth
parentStable for amd64, ppc and x86. Bug #550840. (diff)
downloadgentoo-2-f39da4d6d8b9a501d2421dd5518e84798a538178.tar.gz
gentoo-2-f39da4d6d8b9a501d2421dd5518e84798a538178.tar.bz2
gentoo-2-f39da4d6d8b9a501d2421dd5518e84798a538178.zip
Fix python support. Bug #554776. Respect SSSD_OPTIONS in init script. Bug #553678
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/sssd/ChangeLog7
-rw-r--r--sys-auth/sssd/files/sssd-1.13.0-fix-init.patch28
-rw-r--r--sys-auth/sssd/sssd-1.13.0.ebuild23
3 files changed, 51 insertions, 7 deletions
diff --git a/sys-auth/sssd/ChangeLog b/sys-auth/sssd/ChangeLog
index b3af91ba9837..c00fdebbafe8 100644
--- a/sys-auth/sssd/ChangeLog
+++ b/sys-auth/sssd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/sssd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.72 2015/07/11 21:11:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.73 2015/07/22 20:00:57 hwoarang Exp $
+
+ 22 Jul 2015; Markos Chandras <hwoarang@gentoo.org>
+ +files/sssd-1.13.0-fix-init.patch, sssd-1.13.0.ebuild:
+ Fix python support. Bug #554776. Respect SSSD_OPTIONS in init script. Bug
+ #553678
*sssd-1.13.0 (11 Jul 2015)
diff --git a/sys-auth/sssd/files/sssd-1.13.0-fix-init.patch b/sys-auth/sssd/files/sssd-1.13.0-fix-init.patch
new file mode 100644
index 000000000000..d821a0740606
--- /dev/null
+++ b/sys-auth/sssd/files/sssd-1.13.0-fix-init.patch
@@ -0,0 +1,28 @@
+From 121061115d1902d8298fbe9ebc3f8d081a725934 Mon Sep 17 00:00:00 2001
+From: Tyler Gates <tgates81@gmail.com>
+Date: Mon, 20 Jul 2015 17:14:12 -0400
+Subject: [PATCH] daemon startup options as declared in conf.d/sssd
+
+---
+Gentoo bugzilla: https://bugs.gentoo.org/show_bug.cgi?id=553678
+Upstrem bugzilla: https://fedorahosted.org/sssd/ticket/2722
+---
+ src/sysv/gentoo/sssd.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sysv/gentoo/sssd.in b/src/sysv/gentoo/sssd.in
+index 30d7559..7ced44f 100644
+--- a/src/sysv/gentoo/sssd.in
++++ b/src/sysv/gentoo/sssd.in
+@@ -7,7 +7,7 @@ depend(){
+
+ start(){
+ ebegin "Starting sssd"
+- start-stop-daemon --start --exec @sbindir@/sssd -- -Df
++ start-stop-daemon --start --exec @sbindir@/sssd -- -Df ${SSSD_OPTIONS}
+ eend ${?}
+ }
+
+--
+2.0.5
+
diff --git a/sys-auth/sssd/sssd-1.13.0.ebuild b/sys-auth/sssd/sssd-1.13.0.ebuild
index 4ae8c23de23e..1a763fb38f69 100644
--- a/sys-auth/sssd/sssd-1.13.0.ebuild
+++ b/sys-auth/sssd/sssd-1.13.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.13.0.ebuild,v 1.1 2015/07/11 21:11:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.13.0.ebuild,v 1.2 2015/07/22 20:00:57 hwoarang Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit python-single-r1 multilib pam linux-info autotools multilib-minimal systemd toolchain-funcs
+inherit eutils multilib pam linux-info autotools multilib-minimal systemd toolchain-funcs
DESCRIPTION="System Security Services Daemon provides access to identity and authentication"
HOMEPAGE="http://fedorahosted.org/sssd/"
@@ -76,14 +76,19 @@ MULTILIB_WRAPPED_HEADERS=(
)
pkg_setup(){
- use python && python-single-r1_pkg_setup
linux-info_pkg_setup
}
src_prepare() {
+ # bug #553678
+ epatch "${FILESDIR}"/${P}-fix-init.patch
+
eautoreconf
multilib_copy_sources
+
+ # Maybe run it before eautoreconf?
+ epatch_user
}
src_configure() {
@@ -95,7 +100,15 @@ src_configure() {
multilib_src_configure() {
# set initscript to sysv because the systemd option needs systemd to
# be installed. We provide our own systemd file anyway.
- local myconf=(
+ local myconf=()
+ if [[ "${PYTHON_TARGETS}" == *python2* ]]; then
+ myconf+=($(multilib_native_use_with python python2-bindings))
+ fi
+ if [[ "${PYTHON_TARGETS}" == *python3* ]]; then
+ myconf+=($(multilib_native_use_with python python3-bindings))
+ fi
+
+ myconf+=(
--localstatedir="${EPREFIX}"/var
--enable-nsslibdir="${EPREFIX}"/$(get_libdir)
--with-plugin-path="${EPREFIX}"/usr/$(get_libdir)/sssd
@@ -111,7 +124,6 @@ multilib_src_configure() {
$(multilib_native_use_enable augeas config-lib)
$(multilib_native_use_with selinux)
$(multilib_native_use_with selinux semanage)
- $(multilib_native_use_with python python-bindings)
$(use_enable locator krb5-locator-plugin)
$(multilib_native_use_with nfsv4 nfsv4-idmapd-plugin)
$(use_enable nls )
@@ -179,7 +191,6 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
prune_libtool_files --all
- use python && python_optimize
insinto /etc/sssd
insopts -m600