summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-06-25 21:40:09 +0000
committerUlrich Müller <ulm@gentoo.org>2015-06-25 21:40:09 +0000
commitb062ed22c9ec7f4182b378d9816d89634cd59cfa (patch)
tree025259dc18eda1f1235dabfe125b359177366e35 /sys-auth
parentVersion bump. Added rewritten init script to fix bug #553246 (diff)
downloadgentoo-2-b062ed22c9ec7f4182b378d9816d89634cd59cfa.tar.gz
gentoo-2-b062ed22c9ec7f4182b378d9816d89634cd59cfa.tar.bz2
gentoo-2-b062ed22c9ec7f4182b378d9816d89634cd59cfa.zip
Fix compile failure with perl-5.22.0, bug 553148. Fix issue with missing timelocal.pl in skeyprune script.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/skey/ChangeLog10
-rw-r--r--sys-auth/skey/skey-1.1.5-r9.ebuild81
2 files changed, 89 insertions, 2 deletions
diff --git a/sys-auth/skey/ChangeLog b/sys-auth/skey/ChangeLog
index b7b044f71dfb..ea96baac03d4 100644
--- a/sys-auth/skey/ChangeLog
+++ b/sys-auth/skey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/skey
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/skey/ChangeLog,v 1.27 2014/01/19 20:08:26 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/skey/ChangeLog,v 1.28 2015/06/25 21:40:09 ulm Exp $
+
+*skey-1.1.5-r9 (25 Jun 2015)
+
+ 25 Jun 2015; Ulrich Müller <ulm@gentoo.org> +skey-1.1.5-r9.ebuild:
+ Fix compile failure with perl-5.22.0, bug 553148. Fix issue with missing
+ timelocal.pl in skeyprune script.
19 Jan 2014; Mike Frysinger <vapier@gentoo.org> skey-1.1.5-r8.ebuild:
Add arm64 love.
diff --git a/sys-auth/skey/skey-1.1.5-r9.ebuild b/sys-auth/skey/skey-1.1.5-r9.ebuild
new file mode 100644
index 000000000000..ce54287be658
--- /dev/null
+++ b/sys-auth/skey/skey-1.1.5-r9.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/skey/skey-1.1.5-r9.ebuild,v 1.1 2015/06/25 21:40:09 ulm Exp $
+
+EAPI=5
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Linux Port of OpenBSD Single-key Password System"
+HOMEPAGE="http://www.openbsd.org/faq/faq8.html#SKey"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~ulm/distfiles/${P}-patches-3.tar.xz"
+
+LICENSE="BSD MIT RSA BEER-WARE"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-lang/perl
+ app-arch/xz-utils"
+RDEPEND="dev-lang/perl
+ sys-libs/cracklib"
+
+src_prepare() {
+ EPATCH_SUFFIX=patch epatch
+}
+
+src_configure() {
+ tc-export CC
+ econf --sysconfdir=/etc/skey
+}
+
+src_install() {
+ into /
+ dolib.so libskey.so{.${PV},.${PV%.*},.${PV%%.*},}
+
+ into /usr
+ dobin skey skeyinit skeyinfo
+ newbin skeyaudit.sh skeyaudit
+ newsbin skeyprune.pl skeyprune
+
+ dosym skey /usr/bin/otp-md4
+ dosym skey /usr/bin/otp-md5
+ dosym skey /usr/bin/otp-sha1
+
+ if use static-libs; then
+ dolib.a libskey.a
+ gen_usr_ldscript libskey.so
+ fi
+
+ doman skey.1 skeyaudit.1 skeyinfo.1 skeyinit.1 skey.3 skeyprune.8
+
+ insinto /usr/include
+ doins skey.h
+
+ keepdir /etc/skey
+
+ # only root needs to have access to these files.
+ fperms go-rx /etc/skey
+
+ # skeyinit and skeyinfo must be suid root so users
+ # can generate their passwords.
+ fperms u+s,go-r /usr/bin/skeyinit /usr/bin/skeyinfo
+
+ dodoc README CHANGES
+}
+
+pkg_postinst() {
+ # do not include /etc/skey/skeykeys in the package, as quickpkg
+ # may package sensitive information.
+ # This also fixes the etc-update issue with #64974.
+
+ # skeyinit will not function if this file is not present.
+ touch /etc/skey/skeykeys
+
+ # these permissions are applied by the skey system if missing.
+ chmod 0600 /etc/skey/skeykeys
+
+ elog "For an introduction into using s/key authentication, take"
+ elog "a look at the EXAMPLES section from the skey(1) manpage."
+}