summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-20 00:58:21 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-20 00:58:21 +0000
commita862c9bf279e3429436e6780efcd0ef0e53f43e2 (patch)
treef3f8126b724dc25fcf62f678b3892c8c662ec6d3 /sys-auth
parentversion bump; menu icon patch from François AZELAR via bug #145455 (diff)
downloadgentoo-2-a862c9bf279e3429436e6780efcd0ef0e53f43e2.tar.gz
gentoo-2-a862c9bf279e3429436e6780efcd0ef0e53f43e2.tar.bz2
gentoo-2-a862c9bf279e3429436e6780efcd0ef0e53f43e2.zip
Version bump, fixes memory leaks.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss_ldap/ChangeLog9
-rw-r--r--sys-auth/nss_ldap/files/digest-nss_ldap-2593
-rw-r--r--sys-auth/nss_ldap/nss_ldap-259.ebuild80
3 files changed, 90 insertions, 2 deletions
diff --git a/sys-auth/nss_ldap/ChangeLog b/sys-auth/nss_ldap/ChangeLog
index db30ae45ea63..f0c029ed9775 100644
--- a/sys-auth/nss_ldap/ChangeLog
+++ b/sys-auth/nss_ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/nss_ldap
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.52 2007/11/14 03:56:40 beandog Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.53 2008/01/20 00:58:20 robbat2 Exp $
+
+*nss_ldap-259 (20 Jan 2008)
+
+ 20 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> +nss_ldap-259.ebuild:
+ Version bump, fixes memory leaks.
14 Nov 2007; Steve Dibb <beandog@gentoo.org> nss_ldap-258.ebuild:
amd64 stable, bug 198390
diff --git a/sys-auth/nss_ldap/files/digest-nss_ldap-259 b/sys-auth/nss_ldap/files/digest-nss_ldap-259
new file mode 100644
index 000000000000..803ceb5c2248
--- /dev/null
+++ b/sys-auth/nss_ldap/files/digest-nss_ldap-259
@@ -0,0 +1,3 @@
+MD5 ef29690c6e5f02dffbfd0f32f296a97b nss_ldap-259.tar.gz 274878
+RMD160 95b7fe2a4c28c4d8e86cf7d0d2e61e5e585b5a06 nss_ldap-259.tar.gz 274878
+SHA256 8b65a32717f6173911aaea8e89b2c89ccb901f14f1063f5e49b5ab77d45f1790 nss_ldap-259.tar.gz 274878
diff --git a/sys-auth/nss_ldap/nss_ldap-259.ebuild b/sys-auth/nss_ldap/nss_ldap-259.ebuild
new file mode 100644
index 000000000000..79e57ef2cbf5
--- /dev/null
+++ b/sys-auth/nss_ldap/nss_ldap-259.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-259.ebuild,v 1.1 2008/01/20 00:58:20 robbat2 Exp $
+
+inherit fixheadtails eutils multilib autotools
+
+IUSE="debug sasl kerberos"
+
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/nss_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}
+ !<net-fs/autofs-4.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ # Applied by upstream
+ #epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
+ # Applied by upstream
+ #EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-254-nss_getgrent_skipmembers.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-257-nss_max_group_depth.patch
+ sed -i.orig \
+ -e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
+ # fix head/tail stuff
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
+ # fix build borkage
+ for i in Makefile.{in,am}; do
+ sed -i.orig \
+ -e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
+ "${S}"/$i
+ done
+ epatch "${FILESDIR}"/${PN}-257.2-gssapi-headers.patch
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debugging"
+ use kerberos && myconf="${myconf} --enable-configurable-krb5-ccname-gssapi"
+ econf \
+ --with-ldap-lib=openldap \
+ --libdir=/$(get_libdir) \
+ --enable-schema-mapping \
+ --enable-paged-results \
+ --enable-rfc2307bis \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /$(get_libdir)
+
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+
+ insinto /etc
+ doins ldap.conf
+
+ dodoc ldap.conf ANNOUNCE NEWS ChangeLog AUTHORS \
+ COPYING CVSVersionInfo.txt README nsswitch.ldap certutil
+ docinto docs; dodoc doc/*
+}
+
+pkg_postinst() {
+ elog "If you use a ldaps:// string in the 'uri' setting of"
+ elog "your /etc/ldap.conf, you must set 'ssl on'!"
+}