summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-08-09 18:38:03 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-08-09 18:38:03 +0000
commit38087cc67cc8feb0debb4a4ed517dbc25c99c096 (patch)
tree0368a5eb2273ff796e7e46be6cdbe9327bbab96a /sys-auth
parentMigrate to twisted-r1. (diff)
downloadgentoo-2-38087cc67cc8feb0debb4a4ed517dbc25c99c096.tar.gz
gentoo-2-38087cc67cc8feb0debb4a4ed517dbc25c99c096.tar.bz2
gentoo-2-38087cc67cc8feb0debb4a4ed517dbc25c99c096.zip
Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
(Portage version: 2.1.12.2/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit/ChangeLog6
-rw-r--r--sys-auth/polkit/polkit-0.110.ebuild4
-rw-r--r--sys-auth/polkit/polkit-0.111-r1.ebuild16
3 files changed, 15 insertions, 11 deletions
diff --git a/sys-auth/polkit/ChangeLog b/sys-auth/polkit/ChangeLog
index aec10c1f6997..6500d85f05cf 100644
--- a/sys-auth/polkit/ChangeLog
+++ b/sys-auth/polkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/polkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.143 2013/08/08 21:10:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.144 2013/08/09 18:38:03 axs Exp $
+
+ 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
+ polkit-0.111-r1.ebuild:
+ Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
*polkit-0.111-r1 (08 Aug 2013)
diff --git a/sys-auth/polkit/polkit-0.110.ebuild b/sys-auth/polkit/polkit-0.110.ebuild
index a3d3ff5e3fa1..bc917f204a05 100644
--- a/sys-auth/polkit/polkit-0.110.ebuild
+++ b/sys-auth/polkit/polkit-0.110.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.110.ebuild,v 1.13 2013/03/19 20:35:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.110.ebuild,v 1.14 2013/08/09 18:38:03 axs Exp $
EAPI=5
inherit eutils multilib pam pax-utils systemd user
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 s390 sh sparc x86"
IUSE="examples gtk +introspection kde nls pam selinux systemd"
-RDEPEND=">=dev-lang/spidermonkey-1.8.5-r1[-debug]
+RDEPEND=">=dev-lang/spidermonkey-1.8.5-r1:0=[-debug]
>=dev-libs/glib-2.32
>=dev-libs/expat-2
introspection? ( >=dev-libs/gobject-introspection-1 )
diff --git a/sys-auth/polkit/polkit-0.111-r1.ebuild b/sys-auth/polkit/polkit-0.111-r1.ebuild
index 4d472e559bc1..92ede76fb0d5 100644
--- a/sys-auth/polkit/polkit-0.111-r1.ebuild
+++ b/sys-auth/polkit/polkit-0.111-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.111-r1.ebuild,v 1.1 2013/08/08 21:10:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/polkit-0.111-r1.ebuild,v 1.2 2013/08/09 18:38:03 axs Exp $
EAPI=5
inherit eutils multilib pam pax-utils systemd user
@@ -14,7 +14,8 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="examples gtk +introspection kde nls pam selinux systemd"
-RDEPEND="dev-lang/spidermonkey:17[-debug]
+RDEPEND="ia64? ( =dev-lang/spidermonkey-1.8.5*[-debug] )
+ !ia64? ( dev-lang/spidermonkey:17[-debug] )
>=dev-libs/glib-2.32
>=dev-libs/expat-2:=
introspection? ( >=dev-libs/gobject-introspection-1 )
@@ -70,7 +71,7 @@ src_configure() {
$(use_enable introspection) \
--disable-examples \
$(use_enable nls) \
- --with-mozjs=mozjs-17.0 \
+ $(usex ia64 --with-mozjs=mozjs185 --with-mozjs=mozjs-17.0) \
"$(systemd_with_unitdir)" \
--with-authfw=$(usex pam pam shadow) \
$(use pam && echo --with-pam-module-dir="$(getpam_mod_dir)") \
@@ -82,11 +83,10 @@ src_compile() {
# Required for polkitd on hardened/PaX due to spidermonkey's JIT
local f='src/polkitbackend/.libs/polkitd test/polkitbackend/.libs/polkitbackendjsauthoritytest'
- if has_version '>=dev-lang/spidermonkey-1.8.7[jit]'; then
- pax-mark m ${f}
- elif has_version '<dev-lang/spidermonkey-1.8.7'; then
- pax-mark mr ${f}
- fi
+ local m='m'
+ # ia64 uses spidermonkey-1.8.5 which requires different pax-mark flags
+ use ia64 && m='mr'
+ pax-mark ${m} ${f}
}
src_install() {