summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-12-11 20:20:16 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-12-11 20:20:16 +0000
commitd6e6933098f56e0b1d1096b30a58678fd178f62a (patch)
treeb640925ffdb516d1dcb1872718a4cfc0481284a1 /sys-auth/pam_ldap
parentMarking libdnet-1.8 to fix tree borkage to snort per Mr Bones request on irc. (diff)
downloadgentoo-2-d6e6933098f56e0b1d1096b30a58678fd178f62a.tar.gz
gentoo-2-d6e6933098f56e0b1d1096b30a58678fd178f62a.tar.bz2
gentoo-2-d6e6933098f56e0b1d1096b30a58678fd178f62a.zip
Bug #153916, version bump.
(Portage version: 2.1.2_rc3-r1)
Diffstat (limited to 'sys-auth/pam_ldap')
-rw-r--r--sys-auth/pam_ldap/ChangeLog7
-rw-r--r--sys-auth/pam_ldap/files/digest-pam_ldap-1833
-rw-r--r--sys-auth/pam_ldap/pam_ldap-183.ebuild45
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-auth/pam_ldap/ChangeLog b/sys-auth/pam_ldap/ChangeLog
index 91261f245c4a..8c87b5d559b0 100644
--- a/sys-auth/pam_ldap/ChangeLog
+++ b/sys-auth/pam_ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam_ldap
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/ChangeLog,v 1.29 2006/10/12 16:30:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/ChangeLog,v 1.30 2006/12/11 20:20:16 robbat2 Exp $
+
+*pam_ldap-183 (11 Dec 2006)
+
+ 11 Dec 2006; Robin H. Johnson <robbat2@gentoo.org> +pam_ldap-183.ebuild:
+ Bug #153916, version bump.
12 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> pam_ldap-180.ebuild,
pam_ldap-182.ebuild:
diff --git a/sys-auth/pam_ldap/files/digest-pam_ldap-183 b/sys-auth/pam_ldap/files/digest-pam_ldap-183
new file mode 100644
index 000000000000..8850f44030d8
--- /dev/null
+++ b/sys-auth/pam_ldap/files/digest-pam_ldap-183
@@ -0,0 +1,3 @@
+MD5 c0ad81e9d9712ddc6599a6e7a1688778 pam_ldap-183.tar.gz 127500
+RMD160 42c8622677c44b521569b906b1cf53d0e605ed39 pam_ldap-183.tar.gz 127500
+SHA256 aabce29413280efc992ba10f16ec8ab3c1bf06feebebf598d3b625ad36a715d0 pam_ldap-183.tar.gz 127500
diff --git a/sys-auth/pam_ldap/pam_ldap-183.ebuild b/sys-auth/pam_ldap/pam_ldap-183.ebuild
new file mode 100644
index 000000000000..81c2a8b2d19e
--- /dev/null
+++ b/sys-auth/pam_ldap/pam_ldap-183.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_ldap/pam_ldap-183.ebuild,v 1.1 2006/12/11 20:20:16 robbat2 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils pam autotools
+
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/pam_ldap.html"
+SRC_URI="http://www.padl.com/download/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl sasl"
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=net-nds/openldap-2.1.30-r5
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_unpack() {
+ unpack ${A}
+ #EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-176-fix-referral-tls.patch
+
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-ldap-lib=openldap `use_enable ssl` || die
+ emake || die
+}
+
+src_install() {
+ dopammod pam_ldap.so
+
+ dodoc pam.conf ldap.conf ldapns.schema chsh chfn certutil
+ dodoc ChangeLog CVSVersionInfo.txt README AUTHORS ns-pwd-policy.schema
+ doman pam_ldap.5
+
+ docinto pam.d
+ dodoc pam.d/*
+}