summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-14 04:37:24 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-14 04:37:24 +0000
commitd72063f93f97807a8cfd9629ba65065262ca05f2 (patch)
tree7761a8f9a9098651ec7170d1203e15e0113d0b07 /sys-auth/pam-script
parentRemoved dev-util/dialogblocks dev-util/helpblocks. (diff)
downloadgentoo-2-d72063f93f97807a8cfd9629ba65065262ca05f2.tar.gz
gentoo-2-d72063f93f97807a8cfd9629ba65065262ca05f2.tar.bz2
gentoo-2-d72063f93f97807a8cfd9629ba65065262ca05f2.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-auth/pam-script')
-rw-r--r--sys-auth/pam-script/ChangeLog7
-rw-r--r--sys-auth/pam-script/pam-script-1.1.7.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-auth/pam-script/ChangeLog b/sys-auth/pam-script/ChangeLog
index 3eb7129ee6a4..0923c891e559 100644
--- a/sys-auth/pam-script/ChangeLog
+++ b/sys-auth/pam-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/pam-script
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-script/ChangeLog,v 1.3 2013/05/09 05:44:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-script/ChangeLog,v 1.4 2013/05/14 04:37:24 radhermit Exp $
+
+*pam-script-1.1.7 (14 May 2013)
+
+ 14 May 2013; Tim Harder <radhermit@gentoo.org> +pam-script-1.1.7.ebuild:
+ Version bump.
09 May 2013; Tim Harder <radhermit@gentoo.org> pam-script-1.1.6.ebuild:
Update HOMEPAGE.
diff --git a/sys-auth/pam-script/pam-script-1.1.7.ebuild b/sys-auth/pam-script/pam-script-1.1.7.ebuild
new file mode 100644
index 000000000000..af93bff32e5b
--- /dev/null
+++ b/sys-auth/pam-script/pam-script-1.1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam-script/pam-script-1.1.7.ebuild,v 1.1 2013/05/14 04:37:24 radhermit Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="PAM module for executing scripts during authorization, password changes, and sessions"
+HOMEPAGE="http://sourceforge.net/projects/pam-script/ https://github.com/jeroennijhof/pam_script/"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="virtual/pam"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --libdir=/$(get_libdir)/security \
+ --sysconfdir=/etc/security/${PN}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc etc/README.examples
+ exeinto /usr/share/doc/${PF}/examples
+ doexe etc/{logscript,tally}
+ docompress -x /usr/share/doc/${PF}/examples/{logscript,tally}
+ fi
+}