summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-08-03 21:03:15 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-08-03 21:03:15 +0000
commitd62686b35d906723b5d97638c9645fca0314128f (patch)
tree2ec55f7d63d78943d0d5e5cba87024b50f97d025 /sys-apps
parentupdate patches (diff)
downloadgentoo-2-d62686b35d906723b5d97638c9645fca0314128f.tar.gz
gentoo-2-d62686b35d906723b5d97638c9645fca0314128f.tar.bz2
gentoo-2-d62686b35d906723b5d97638c9645fca0314128f.zip
glibc fixes; mask again
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/lilo/ChangeLog7
-rw-r--r--sys-apps/lilo/files/lilo-22.5.6-animated-menu.patch2
-rw-r--r--sys-apps/lilo/files/lilo-22.5.6-glibc233.patch24
-rw-r--r--sys-apps/lilo/lilo-22.5.6-r3.ebuild7
4 files changed, 36 insertions, 4 deletions
diff --git a/sys-apps/lilo/ChangeLog b/sys-apps/lilo/ChangeLog
index 0a0c53e8f4c4..f3b701b06d1b 100644
--- a/sys-apps/lilo/ChangeLog
+++ b/sys-apps/lilo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/lilo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.29 2003/08/03 13:33:37 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/ChangeLog,v 1.30 2003/08/03 21:02:20 azarah Exp $
+
+ 03 Aug 2003; Martin Schlemmer <azarah@gentoo.org> lilo-22.5.6-r3.ebuild,
+ files/lilo-22.5.6-animated-menu.patch, files/lilo-22.5.6-glibc233.patch:
+ Add fixes for latest libc. Mask again until the 'timeout=' option can be fixed
+ (for my friend chip).
*lilo-22.5.6-r3 (03 Aug 2003)
diff --git a/sys-apps/lilo/files/lilo-22.5.6-animated-menu.patch b/sys-apps/lilo/files/lilo-22.5.6-animated-menu.patch
index af8897114b94..abb64c8fbe6a 100644
--- a/sys-apps/lilo/files/lilo-22.5.6-animated-menu.patch
+++ b/sys-apps/lilo/files/lilo-22.5.6-animated-menu.patch
@@ -341,7 +341,7 @@ diff -urpN lilo-22.5.6/gfxlogo.S lilo-22.5.6.gfx/gfxlogo.S
+
+ mov ax,#0xffff
+ seg fs
-+ xchg ax,par2_timeout+SSDIFF
++ xchg ax,par2_timeout
+
+ ; map 0xffff -> 0
+ add ax,#1
diff --git a/sys-apps/lilo/files/lilo-22.5.6-glibc233.patch b/sys-apps/lilo/files/lilo-22.5.6-glibc233.patch
new file mode 100644
index 000000000000..96d582d418e8
--- /dev/null
+++ b/sys-apps/lilo/files/lilo-22.5.6-glibc233.patch
@@ -0,0 +1,24 @@
+--- lilo-22.5.6/boot.c 2003-08-03 21:02:55.000000000 +0200
++++ lilo-22.5.6.glibc233/boot.c 2003-08-03 21:03:17.000000000 +0200
+@@ -18,6 +18,9 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <a.out.h>
++#ifndef PAGE_SIZE
++# include <asm/page.h>
++#endif
+ #include <sys/stat.h>
+
+ #include "config.h"
+--- lilo-22.5.6/partition.c 2003-08-03 21:03:33.000000000 +0200
++++ lilo-22.5.6.glibc233/partition.c 2003-08-03 21:03:56.000000000 +0200
+@@ -18,6 +18,9 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <a.out.h>
++#ifndef PAGE_SIZE
++# include <asm/page.h>
++#endif
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <asm/unistd.h>
diff --git a/sys-apps/lilo/lilo-22.5.6-r3.ebuild b/sys-apps/lilo/lilo-22.5.6-r3.ebuild
index 01326fbaa541..7587b27ea7d3 100644
--- a/sys-apps/lilo/lilo-22.5.6-r3.ebuild
+++ b/sys-apps/lilo/lilo-22.5.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.6-r3.ebuild,v 1.1 2003/08/03 13:33:37 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lilo/lilo-22.5.6-r3.ebuild,v 1.2 2003/08/03 21:02:20 azarah Exp $
inherit mount-boot eutils
@@ -13,7 +13,7 @@ HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
SLOT="0"
LICENSE="BSD GPL-2"
-KEYWORDS="-* ~x86"
+KEYWORDS="-*"
DEPEND="dev-lang/nasm
>=sys-devel/bin86-0.15.5"
@@ -35,6 +35,9 @@ src_unpack() {
# Quequero <quequerp@bitchx.it>
#
epatch ${FILESDIR}/${P}-animated-menu.patch
+
+ # Fixup things for glibc-2.3.3 (and later CVS versions of 2.3.2)
+ epatch ${FILESDIR}/${P}-glibc233.patch
}
src_compile() {