summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-24 02:58:53 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-24 02:58:53 +0000
commita9273ba64961e5fbc4b90d2edd61701c931ed084 (patch)
treeb322d1f731e433c7a5a269b98ac2b1ab7cfa3a59 /sys-apps
parentUhh... I'm not G.Bevin, nor is today the 1st of February (diff)
downloadgentoo-2-a9273ba64961e5fbc4b90d2edd61701c931ed084.tar.gz
gentoo-2-a9273ba64961e5fbc4b90d2edd61701c931ed084.tar.bz2
gentoo-2-a9273ba64961e5fbc4b90d2edd61701c931ed084.zip
remove zlib support
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/modutils/ChangeLog8
-rw-r--r--sys-apps/modutils/files/digest-modutils-2.4.16-r21
-rw-r--r--sys-apps/modutils/modutils-2.4.16-r2.ebuild50
3 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/modutils/ChangeLog b/sys-apps/modutils/ChangeLog
index a0fa6e78390a..68c8d93c8611 100644
--- a/sys-apps/modutils/ChangeLog
+++ b/sys-apps/modutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/modutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.3 2002/06/20 19:30:29 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/ChangeLog,v 1.4 2002/06/24 02:58:53 azarah Exp $
+
+*modutils-2.4.16-r2 (24 Jun 2002)
+
+ 24 Jun 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Seems like a statically linked insmod do not load modules
+ on demand :(
*modutils-2.4.16-r1 (20 Jun 2002)
diff --git a/sys-apps/modutils/files/digest-modutils-2.4.16-r2 b/sys-apps/modutils/files/digest-modutils-2.4.16-r2
new file mode 100644
index 000000000000..c7a5a574eb23
--- /dev/null
+++ b/sys-apps/modutils/files/digest-modutils-2.4.16-r2
@@ -0,0 +1 @@
+MD5 0d62dc888736007a183c795b1b063c92 modutils-2.4.16.tar.bz2 216009
diff --git a/sys-apps/modutils/modutils-2.4.16-r2.ebuild b/sys-apps/modutils/modutils-2.4.16-r2.ebuild
new file mode 100644
index 000000000000..a04a997919ac
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.16-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.16-r2.ebuild,v 1.1 2002/06/24 02:58:53 azarah Exp $
+
+S=${WORKDIR}/${P}
+SLOT="0"
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.4/${P}.tar.bz2"
+
+DEPEND="virtual/glibc"
+# zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ myconf=""
+ # see bug #3897 ... we need insmod static, as libz.so is in /usr/lib
+ #
+ # Final resolution ... dont make it link against zlib, as the static
+ # version do not want to autoload modules :(
+# use zlib && myconf="${myconf} --enable-zlib --enable-insmod-static" \
+# || myconf="${myconf} --disable-zlib"
+ myconf="${myconf} --disable-zlib"
+
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --disable-strip \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D} \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ # we want insmod static if using zlib, as libz is in /usr/lib/, so
+ # move all the *.static to the normal names
+# if [ "`use zlib`" ] ; then
+# mv ${D}/sbin/insmod.static ${D}/sbin/insmod
+ # rest are symlinks pointing to "/sbin/insmod.static", so
+ # nuke them
+# rm -f ${D}/sbin/*.static
+# fi
+
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+