summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-06 02:08:41 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-06 02:08:41 +0000
commit9049429dfa36668c353c1dbdc8ecedfac35d6d7e (patch)
tree6bda4fb23b6179ba1d3cbbfcbd554fea02f716cb /sys-apps
parentVersion bump. (diff)
downloadgentoo-2-9049429dfa36668c353c1dbdc8ecedfac35d6d7e.tar.gz
gentoo-2-9049429dfa36668c353c1dbdc8ecedfac35d6d7e.tar.bz2
gentoo-2-9049429dfa36668c353c1dbdc8ecedfac35d6d7e.zip
Version bump (bug #503482).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/microcode-data/ChangeLog8
-rw-r--r--sys-apps/microcode-data/microcode-data-20140122.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/microcode-data/ChangeLog b/sys-apps/microcode-data/ChangeLog
index 63bdc4bf84bd..eeb2af2bf246 100644
--- a/sys-apps/microcode-data/ChangeLog
+++ b/sys-apps/microcode-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-data
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.27 2014/01/11 21:35:16 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.28 2014/03/06 02:08:41 radhermit Exp $
+
+*microcode-data-20140122 (06 Mar 2014)
+
+ 06 Mar 2014; Tim Harder <radhermit@gentoo.org>
+ +microcode-data-20140122.ebuild:
+ Version bump (bug #503482).
11 Jan 2014; Pacho Ramos <pacho@gentoo.org> microcode-data-20130906.ebuild:
amd64/x86 stable, bug #495928
diff --git a/sys-apps/microcode-data/microcode-data-20140122.ebuild b/sys-apps/microcode-data/microcode-data-20140122.ebuild
new file mode 100644
index 000000000000..248b3f2d1a90
--- /dev/null
+++ b/sys-apps/microcode-data/microcode-data-20140122.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/microcode-data-20140122.ebuild,v 1.1 2014/03/06 02:08:41 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+# Find updates by searching and clicking the first link (hopefully it's the one):
+# http://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
+
+NUM="23574"
+DESCRIPTION="Intel IA32 microcode update data"
+HOMEPAGE="http://inertiawar.com/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
+SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
+
+LICENSE="intel-ucode"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ cp "${FILESDIR}"/intel-microcode2ucode.c ./ || die
+}
+
+src_compile() {
+ tc-env_build emake intel-microcode2ucode
+ ./intel-microcode2ucode microcode.dat || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r microcode.dat intel-ucode
+}
+
+pkg_postinst() {
+ elog "The microcode available for Intel CPUs has been updated. You'll need"
+ elog "to reload the code into your processor. If you're using the init.d:"
+ elog "/etc/init.d/microcode_ctl restart"
+}