summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-06-09 01:36:47 +0000
committerMike Frysinger <vapier@gentoo.org>2011-06-09 01:36:47 +0000
commit546f6a8d5cc81f586c6574b6fff8e32970301d59 (patch)
tree142036bb06008cebb8b4d294d79aa61bdfa37bed /sys-apps
parentmedia-video/cheese: Fix conclict with sys-fs/udev-171 (bug ##370381) (diff)
downloadgentoo-2-546f6a8d5cc81f586c6574b6fff8e32970301d59.tar.gz
gentoo-2-546f6a8d5cc81f586c6574b6fff8e32970301d59.tar.bz2
gentoo-2-546f6a8d5cc81f586c6574b6fff8e32970301d59.zip
Control nfs support via USE=nfs to fix building with glibc-2.14 #370655 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/watchdog/ChangeLog9
-rw-r--r--sys-apps/watchdog/files/watchdog-5.9-nfs.patch78
-rw-r--r--sys-apps/watchdog/metadata.xml5
-rw-r--r--sys-apps/watchdog/watchdog-5.9-r1.ebuild42
4 files changed, 132 insertions, 2 deletions
diff --git a/sys-apps/watchdog/ChangeLog b/sys-apps/watchdog/ChangeLog
index 8f0d03679687..76e3ea504698 100644
--- a/sys-apps/watchdog/ChangeLog
+++ b/sys-apps/watchdog/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/watchdog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.30 2011/02/12 18:56:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/ChangeLog,v 1.31 2011/06/09 01:36:47 vapier Exp $
+
+*watchdog-5.9-r1 (09 Jun 2011)
+
+ 09 Jun 2011; Mike Frysinger <vapier@gentoo.org> +watchdog-5.9-r1.ebuild,
+ +files/watchdog-5.9-nfs.patch, metadata.xml:
+ Control nfs support via USE=nfs to fix building with glibc-2.14 #370655 by
+ Diego Elio Pettenò.
12 Feb 2011; Raúl Porcel <armin76@gentoo.org> watchdog-5.4.ebuild,
watchdog-5.6.ebuild, watchdog-5.9.ebuild:
diff --git a/sys-apps/watchdog/files/watchdog-5.9-nfs.patch b/sys-apps/watchdog/files/watchdog-5.9-nfs.patch
new file mode 100644
index 000000000000..cf670f7d3b47
--- /dev/null
+++ b/sys-apps/watchdog/files/watchdog-5.9-nfs.patch
@@ -0,0 +1,78 @@
+https://sourceforge.net/tracker/?func=detail&aid=3314009&group_id=172030&atid=860196
+http://bugs.gentoo.org/370655
+
+--- src/nfsmount_clnt.c
++++ src/nfsmount_clnt.c
+@@ -3,6 +3,9 @@
+ * It was generated using rpcgen.
+ */
+
++#include "config.h"
++#if HAVE_NFS
++
+ #include "nfsmount.h"
+ /*
+ * Sun RPC is a product of Sun Microsystems, Inc. and is provided for
+@@ -279,3 +282,5 @@
+ }
+ return (&clnt_res);
+ }
++
++#endif
+--- src/nfsmount.c
++++ src/nfsmount.c
+@@ -34,6 +34,10 @@
+ * nfsmount.c,v 1.1.1.1 1993/11/18 08:40:51 jrs Exp
+ */
+
++#include "config.h"
++
++#if HAVE_NFS
++
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -865,3 +869,5 @@
+ return port;
+ }
+ #endif
++
++#endif
+--- src/nfsmount_xdr.c
++++ src/nfsmount_xdr.c
+@@ -3,6 +3,9 @@
+ * It was generated using rpcgen.
+ */
+
++#include "config.h"
++#if HAVE_NFS
++
+ #include "nfsmount.h"
+ /*
+ * Sun RPC is a product of Sun Microsystems, Inc. and is provided for
+@@ -300,3 +303,5 @@
+ return FALSE;
+ return TRUE;
+ }
++
++#endif
+--- src/shutdown.c
++++ src/shutdown.c
+@@ -24,7 +24,6 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <time.h>
+-#include <rpc/types.h> /* for caddr_t */
+
+ #include "watch_err.h"
+ #include "extern.h"
+--- src/sundries.c
++++ src/sundries.c
+@@ -12,7 +12,6 @@
+ #include <mntent.h> /* for MNTTYPE_SWAP */
+ #include "fstab.h"
+ #include "sundries.h"
+-#include "nfsmount.h"
+
+
+ /* String list constructor. (car() and cdr() are defined in "sundries.h"). */
diff --git a/sys-apps/watchdog/metadata.xml b/sys-apps/watchdog/metadata.xml
index 659da0ca93c2..4bd23572dcb1 100644
--- a/sys-apps/watchdog/metadata.xml
+++ b/sys-apps/watchdog/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>base-system</herd>
+<herd>base-system</herd>
+<use>
+ <flag name='nfs'>enable support for checking nfs mounts</flag>
+</use>
</pkgmetadata>
diff --git a/sys-apps/watchdog/watchdog-5.9-r1.ebuild b/sys-apps/watchdog/watchdog-5.9-r1.ebuild
new file mode 100644
index 000000000000..49755dadc502
--- /dev/null
+++ b/sys-apps/watchdog/watchdog-5.9-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.9-r1.ebuild,v 1.1 2011/06/09 01:36:47 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="A software watchdog"
+HOMEPAGE="http://sourceforge.net/projects/watchdog/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="nfs"
+
+DEPEND="nfs? ( net-libs/libtirpc )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nfs.patch #370655
+}
+
+src_configure() {
+ if use nfs ; then
+ append-cppflags $($(tc-getPKG_CONFIG) libtirpc --cflags)
+ export LIBS+=" $($(tc-getPKG_CONFIG) libtirpc --libs)"
+ fi
+ econf $(use_enable nfs)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+
+ dodoc AUTHORS README TODO NEWS ChangeLog
+ docinto examples
+ dodoc examples/*
+}