summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-21 04:48:24 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-21 04:48:24 +0000
commit44d0f0754638cb97d39ca2356debd94186c676cc (patch)
tree0e8c7a6ffdd1405421b7d6c85feb08598f11cab3 /sys-apps
parentAdd toggle support by Patrik Kullman #62612 and a bunch of patches from Debia... (diff)
downloadgentoo-2-44d0f0754638cb97d39ca2356debd94186c676cc.tar.gz
gentoo-2-44d0f0754638cb97d39ca2356debd94186c676cc.tar.bz2
gentoo-2-44d0f0754638cb97d39ca2356debd94186c676cc.zip
build the magic subdir sep from the rest of the subdirs #81974
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-4.13.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/sys-apps/file/file-4.13.ebuild b/sys-apps/file/file-4.13.ebuild
index c4ab8335ada9..4ae711e0c8db 100644
--- a/sys-apps/file/file-4.13.ebuild
+++ b/sys-apps/file/file-4.13.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.2 2005/04/24 17:46:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.13.ebuild,v 1.3 2005/05/21 04:48:24 vapier Exp $
-inherit flag-o-matic gnuconfig eutils distutils libtool toolchain-funcs
+inherit flag-o-matic eutils distutils libtool toolchain-funcs
DESCRIPTION="Program to identify a file's format by scanning binary data for patterns"
HOMEPAGE="ftp://ftp.astron.com/pub/file/"
@@ -11,23 +11,25 @@ SRC_URI="ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="python build"
-DEPEND="virtual/libc
- !build? ( python? ( virtual/python ) )"
+DEPEND="!build? ( python? ( virtual/python ) )"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
+
+ # the magic and src subdir sometimes don't get along #81974
+ sed -i -e '/^SUBDIRS/s:magic::' Makefile.in
# This tweaks the output format for mips binaries so things like
# libtool don't barf all over the place when trying to parse it.
- epatch ${FILESDIR}/${PN}-4.xx-mips-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-4.xx-mips-gentoo.patch
# The build process tries to run the compiled file ... not a good
# thing if file was cross compiled ;)
- tc-is-cross-compiler && epatch ${FILESDIR}/${P}-cross-compile.patch
+ tc-is-cross-compiler && epatch "${FILESDIR}"/${P}-cross-compile.patch
# misc updates
cat "${FILESDIR}"/*.magic >> magic/magic.mime
@@ -42,23 +44,24 @@ src_unpack() {
src_compile() {
# file command segfaults on hppa - reported by gustavo@zacarias.com.ar
- [[ ${ARCH} == hppa ]] && filter-flags "-mschedule=8000"
+ [[ ${ARCH} == hppa ]] && filter-flags -mschedule=8000
econf --datadir=/usr/share/misc || die
-
emake || die "emake failed"
+ emake -C magic || die "emake magic failed"
use python && cd python && distutils_src_compile
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
+ make DESTDIR="${D}" install -C magic || die "make magic install failed"
if ! use build ; then
dodoc ChangeLog MAINT README
use python && cd python && distutils_src_install
else
- rm -rf ${D}/usr/share/man ${D}/usr/lib/*.a
+ rm -r "${D}"/usr/share/man "${D}"/usr/lib/*.a
fi
}