summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-04-15 16:01:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-04-15 16:01:12 +0000
commit3289f175c893f443a002ef57007ff021ef53ab05 (patch)
tree2ab6cf89b7e319f7f59f75d47a06570881f0de97 /sys-apps
parentPrevent a warning when PATCHES isn't set. (diff)
downloadgentoo-2-3289f175c893f443a002ef57007ff021ef53ab05.tar.gz
gentoo-2-3289f175c893f443a002ef57007ff021ef53ab05.tar.bz2
gentoo-2-3289f175c893f443a002ef57007ff021ef53ab05.zip
use find instead of ls
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/openrc/openrc-0.2.1-r1.ebuild4
-rw-r--r--sys-apps/openrc/openrc-0.2.1-r2.ebuild4
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/openrc/openrc-0.2.1-r1.ebuild b/sys-apps/openrc/openrc-0.2.1-r1.ebuild
index 8014cd5da6d3..1cec5f266c0e 100644
--- a/sys-apps/openrc/openrc-0.2.1-r1.ebuild
+++ b/sys-apps/openrc/openrc-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.1-r1.ebuild,v 1.6 2008/04/14 20:51:05 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.1-r1.ebuild,v 1.7 2008/04/15 16:01:12 cardoe Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -158,7 +158,7 @@ pkg_preinst() {
fi
# force net init.d scripts into symlinks
- for f in $(ls "${ROOT}"/etc/init.d/net.*) ; do
+ for f in $(find "${ROOT}"/etc/init.d/ -name 'net.*') ; do
if [[ ! -L ${f} ]] ; then
elog "Moved net service '${f##*/}' to '${f##*/}.openrc.bak' to force a symlink."
elog "You should delete '${f##*/}.openrc.bak' if you don't need it."
diff --git a/sys-apps/openrc/openrc-0.2.1-r2.ebuild b/sys-apps/openrc/openrc-0.2.1-r2.ebuild
index 597daf1e6c83..9c81a97b390d 100644
--- a/sys-apps/openrc/openrc-0.2.1-r2.ebuild
+++ b/sys-apps/openrc/openrc-0.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.1-r2.ebuild,v 1.1 2008/04/15 05:59:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.1-r2.ebuild,v 1.2 2008/04/15 16:01:12 cardoe Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -162,7 +162,7 @@ pkg_preinst() {
fi
# force net init.d scripts into symlinks
- for f in $(ls "${ROOT}"/etc/init.d/net.*) ; do
+ for f in $(find "${ROOT}"/etc/init.d/ -name 'net.*') ; do
if [[ ! -L ${f} ]] ; then
elog "Moved net service '${f##*/}' to '${f##*/}.openrc.bak' to force a symlink."
elog "You should delete '${f##*/}.openrc.bak' if you don't need it."
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 602e8a65b620..1de12ee0e349 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.26 2008/04/14 20:51:05 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.27 2008/04/15 16:01:12 cardoe Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -156,7 +156,7 @@ pkg_preinst() {
fi
# force net init.d scripts into symlinks
- for f in $(ls "${ROOT}"/etc/init.d/net.*) ; do
+ for f in $(find "${ROOT}"/etc/init.d/ -name 'net.*') ; do
if [[ ! -L ${f} ]] ; then
elog "Moved net service '${f##*/}' to '${f##*/}.openrc.bak' to force a symlink."
elog "You should delete '${f##*/}.openrc.bak' if you don't need it."