summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-04-20 07:35:12 +0000
committerMichael Januszewski <spock@gentoo.org>2008-04-20 07:35:12 +0000
commit6c7cc1ba4f27a0da05cb3f79e037bab17bb7c0f4 (patch)
tree3d8a293c1b7a77cecfc271d092a129d5c09ce7f9 /sys-apps/v86d
parentFix from upstream svn for building for older arm cpus. (diff)
downloadgentoo-2-6c7cc1ba4f27a0da05cb3f79e037bab17bb7c0f4.tar.gz
gentoo-2-6c7cc1ba4f27a0da05cb3f79e037bab17bb7c0f4.tar.bz2
gentoo-2-6c7cc1ba4f27a0da05cb3f79e037bab17bb7c0f4.zip
Version bump.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'sys-apps/v86d')
-rw-r--r--sys-apps/v86d/ChangeLog9
-rw-r--r--sys-apps/v86d/v86d-0.1.4.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index 99d7233d0b40..c84688aad14c 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/v86d
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.11 2007/12/28 14:46:09 spock Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.12 2008/04/20 07:35:12 spock Exp $
+
+*v86d-0.1.4 (20 Apr 2008)
+
+ 20 Apr 2008; Michał Januszewski <spock@gentoo.org> +v86d-0.1.4.ebuild:
+ Version bump.
28 Dec 2007; Michał Januszewski <spock@gentoo.org> -v86d-0.1.1.ebuild,
-v86d-0.1.2.ebuild:
diff --git a/sys-apps/v86d/v86d-0.1.4.ebuild b/sys-apps/v86d/v86d-0.1.4.ebuild
new file mode 100644
index 000000000000..dfb893cd3fa7
--- /dev/null
+++ b/sys-apps/v86d/v86d-0.1.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.4.ebuild,v 1.1 2008/04/20 07:35:12 spock Exp $
+
+inherit linux-info
+
+DESCRIPTION="A daemon to run x86 code in an emulated environment."
+HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
+SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug x86emu"
+
+DEPEND="dev-libs/klibc"
+RDEPEND=""
+
+S="${WORKDIR}/${P//_*/}"
+
+pkg_setup() {
+ if [ -z "$(grep V86D /usr/lib/klibc/include/linux/connector.h)" ]; then
+ eerror "You need to compile klibc against a kernel tree patched with uvesafb"
+ eerror "prior to merging this package."
+ die "Kernel not patched with uvesafb."
+ fi
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ local myconf=""
+ if use x86emu ; then
+ myconf="--with-x86emu"
+ fi
+
+ ./configure --with-klibc $(use_with debug) ${myconf}
+ make KDIR=${KV_DIR} || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins misc/initramfs
+}
+
+pkg_postinst() {
+ elog "If you wish to place v86d into an initramfs image, you might want to use"
+ elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
+}