summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-27 20:54:16 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-27 20:54:16 +0000
commit5e84bc68b122b7474f1097ab5d74eec13bd25bc2 (patch)
tree598b3f583248e96bb3e0c947fcf85011bc570b40 /sys-apps/v86d
parentSparc stable --- Bug #238859 --- been around almost 3 years now. (diff)
downloadgentoo-2-5e84bc68b122b7474f1097ab5d74eec13bd25bc2.tar.gz
gentoo-2-5e84bc68b122b7474f1097ab5d74eec13bd25bc2.tar.bz2
gentoo-2-5e84bc68b122b7474f1097ab5d74eec13bd25bc2.zip
Fix concurrent build in the current stable version of v86d.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'sys-apps/v86d')
-rw-r--r--sys-apps/v86d/ChangeLog5
-rw-r--r--sys-apps/v86d/v86d-0.1.3-r1.ebuild10
2 files changed, 12 insertions, 3 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index bf9f64cbd5e7..55ebfe90946b 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/v86d
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.24 2008/09/27 20:02:32 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.25 2008/09/27 20:54:16 spock Exp $
+
+ 27 Sep 2008; Michał Januszewski <spock@gentoo.org> v86d-0.1.3-r1.ebuild:
+ Fix concurrent build in the current stable version of v86d.
27 Sep 2008; Michał Januszewski <spock@gentoo.org>
+files/v86d-0.1.8-concurrent-make.patch, v86d-0.1.8.ebuild:
diff --git a/sys-apps/v86d/v86d-0.1.3-r1.ebuild b/sys-apps/v86d/v86d-0.1.3-r1.ebuild
index 16657401b58d..5a42e23693e7 100644
--- a/sys-apps/v86d/v86d-0.1.3-r1.ebuild
+++ b/sys-apps/v86d/v86d-0.1.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.3-r1.ebuild,v 1.2 2008/05/23 21:02:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.3-r1.ebuild,v 1.3 2008/09/27 20:54:16 spock Exp $
-inherit linux-info
+inherit eutils linux-info
DESCRIPTION="A daemon to run x86 code in an emulated environment."
HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
@@ -27,6 +27,12 @@ pkg_setup() {
linux-info_pkg_setup
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.1.8-concurrent-make.patch"
+}
+
src_compile() {
local myconf=""
if use x86emu ; then