summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 15:24:59 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 15:24:59 +0000
commitea9d837f68689a2221e477962cdfd8d09fb6a75d (patch)
tree9208ae8eccfa7994785db2ed3a462dee4a5557a5 /sys-apps/tar
parentVersion bump with avi USE toggle instead of deprecated avifile toggle (diff)
downloadgentoo-2-ea9d837f68689a2221e477962cdfd8d09fb6a75d.tar.gz
gentoo-2-ea9d837f68689a2221e477962cdfd8d09fb6a75d.tar.bz2
gentoo-2-ea9d837f68689a2221e477962cdfd8d09fb6a75d.zip
Updated tar with a symlink in /etc that allows remote tar to work
Updated the ebuild to make the documentation in the right place (missing cd )
Diffstat (limited to 'sys-apps/tar')
-rw-r--r--sys-apps/tar/ChangeLog7
-rw-r--r--sys-apps/tar/files/digest-tar-1.13.25-r21
-rw-r--r--sys-apps/tar/tar-1.13.25-r2.ebuild47
3 files changed, 54 insertions, 1 deletions
diff --git a/sys-apps/tar/ChangeLog b/sys-apps/tar/ChangeLog
index a7ea272c79a1..954e148bc81d 100644
--- a/sys-apps/tar/ChangeLog
+++ b/sys-apps/tar/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-apps/tar
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/ChangeLog,v 1.1 2002/02/01 21:53:37 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/ChangeLog,v 1.2 2002/04/12 15:24:59 spider Exp $
+*tar-1.13.25-r2 (12 Apr 2002)
+ 12 Apr 2002; Spider <spider@gentoo.org> :
+ Updating the tar with a symlink in /etc that allows remote-tar to work properly.
+ Fix a cd to make dodoc and doman work
+
*tar-1.13.25-r1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/sys-apps/tar/files/digest-tar-1.13.25-r2 b/sys-apps/tar/files/digest-tar-1.13.25-r2
new file mode 100644
index 000000000000..467f114af098
--- /dev/null
+++ b/sys-apps/tar/files/digest-tar-1.13.25-r2
@@ -0,0 +1 @@
+MD5 6ef8c906e81eee441f8335652670ac4a tar-1.13.25.tar.gz 1312227
diff --git a/sys-apps/tar/tar-1.13.25-r2.ebuild b/sys-apps/tar/tar-1.13.25-r2.ebuild
new file mode 100644
index 000000000000..8d28b334604d
--- /dev/null
+++ b/sys-apps/tar/tar-1.13.25-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tar/tar-1.13.25-r2.ebuild,v 1.1 2002/04/12 15:24:59 spider Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Use this to try make tarballs :)"
+SRC_URI="ftp://alpha.gnu.org/gnu/tar/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+
+DEPEND="virtual/glibc nls? ( >=sys-devel/gettext-0.10.35 )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --prefix=/usr --bindir=/bin --libexecdir=/usr/lib/misc \
+ --infodir=/usr/share/info --host=${CHOST} ${myconf} || die
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ #FHS 2.1 stuff
+ dodir /usr/sbin
+ cd ${D}
+ mv usr/lib/misc/rmt usr/sbin/rmt.gnu
+ dosym rmt.gnu /usr/sbin/rmt
+ # a nasty yet required symlink:
+ dodir /etc
+ dosym /usr/sbin/rmt /etc/rmt
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
+ doman ${FILESDIR}/tar.1
+ else
+ rm -rf ${D}/usr/share
+ fi
+}