summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-12-08 22:33:38 +0000
committerDonny Davies <woodchip@gentoo.org>2001-12-08 22:33:38 +0000
commitd49659001d2253879fa071f3a3941dcfe102a219 (patch)
treec4ce8a1f3e6c2767e521a6e788f94899b06ded26 /sys-apps/sysvinit
parent${PN} -> ${PARCH}; we already have a ${PN} (diff)
downloadgentoo-2-d49659001d2253879fa071f3a3941dcfe102a219.tar.gz
gentoo-2-d49659001d2253879fa071f3a3941dcfe102a219.tar.bz2
gentoo-2-d49659001d2253879fa071f3a3941dcfe102a219.zip
Wow, updates up quite a few little revisions.. nice bug fixes, various
fixes.. check the docs for details. Gentoo-wise, we dont use the contrib start-stop-daemon anymore, we stole the updated, latest and greatest from Debian's dpkg package!
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/files/digest-sysvinit-2.831
-rw-r--r--sys-apps/sysvinit/sysvinit-2.83.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/sysvinit/files/digest-sysvinit-2.83 b/sys-apps/sysvinit/files/digest-sysvinit-2.83
new file mode 100644
index 000000000000..56f45734dc68
--- /dev/null
+++ b/sys-apps/sysvinit/files/digest-sysvinit-2.83
@@ -0,0 +1 @@
+MD5 b534cbb5bfdd1ed0fb08ec10757dd741 sysvinit-2.83.tar.gz 94208
diff --git a/sys-apps/sysvinit/sysvinit-2.83.ebuild b/sys-apps/sysvinit/sysvinit-2.83.ebuild
new file mode 100644
index 000000000000..bf939533f836
--- /dev/null
+++ b/sys-apps/sysvinit/sysvinit-2.83.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.83.ebuild,v 1.1 2001/12/08 22:33:38 woodchip Exp $
+
+S=${WORKDIR}/${P}/src
+DESCRIPTION="System initialization stuff"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz"
+DEPEND="virtual/glibc"
+RDEPEND="$DEPEND sys-apps/file"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ emake LDFLAGS="" || die "problem compiling"
+}
+
+src_install() {
+
+ into /
+ newsbin init init.system
+ dosbin halt killall5 runlevel shutdown sulogin
+ dosym init /sbin/telinit
+ dobin last mesg utmpdump wall
+ dosym killall5 /sbin/pidof
+ dosym halt /sbin/reboot
+
+ doman man/*.[1-9]
+
+ dodoc README doc/*
+}
+
+pkg_postinst() {
+
+ if [ ! -e ${ROOT}sbin/init ]
+ then
+ cp -a ${ROOT}sbin/init.system ${ROOT}sbin/init
+ fi
+}