summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-06-30 19:16:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-06-30 19:16:12 +0000
commit0de9f08bce4aedaf08658641e096f7d24a114fa3 (patch)
treeeb7ea3f19311c3bb0fb59a2fd6107f51edc3ea0d /sys-apps/smartmontools
parentunmask new dev-ml packages now that everything should be fine (diff)
downloadgentoo-2-0de9f08bce4aedaf08658641e096f7d24a114fa3.tar.gz
gentoo-2-0de9f08bce4aedaf08658641e096f7d24a114fa3.tar.bz2
gentoo-2-0de9f08bce4aedaf08658641e096f7d24a114fa3.zip
Version bump.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog7
-rw-r--r--sys-apps/smartmontools/smartmontools-5.43.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 73ec128c8c88..5446bcdf9703 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.112 2012/04/14 17:18:25 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.113 2012/06/30 19:16:12 robbat2 Exp $
+
+*smartmontools-5.43 (30 Jun 2012)
+
+ 30 Jun 2012; Robin H. Johnson <robbat2@gentoo.org> +smartmontools-5.43.ebuild:
+ Version bump.
14 Apr 2012; Zac Medico <zmedico@gentoo.org> smartmontools-5.42.ebuild,
smartmontools-9999.ebuild:
diff --git a/sys-apps/smartmontools/smartmontools-5.43.ebuild b/sys-apps/smartmontools/smartmontools-5.43.ebuild
new file mode 100644
index 000000000000..0cd22320c1e1
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.43.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.43.ebuild,v 1.1 2012/06/30 19:16:12 robbat2 Exp $
+
+EAPI="3"
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://smartmontools.svn.sourceforge.net/svnroot/smartmontools/trunk/smartmontools"
+ ESVN_PROJECT="smartmontools"
+ inherit subversion autotools
+ SRC_URI=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.) monitoring tools"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static minimal caps"
+
+DEPEND="!minimal? ( caps? ( sys-libs/libcap-ng ) )"
+RDEPEND="${DEPEND}
+ !minimal? ( virtual/mailx )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ #./autogen.sh
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf
+ use minimal && einfo "Skipping the monitoring daemon for minimal build."
+ use static && append-ldflags -static
+
+ if ! use minimal; then
+ myconf="${myconf} $(use_with caps libcap-ng)"
+ else
+ # disable it so that we stay safe
+ myconf="${myconf} --without-libcap-ng"
+ fi
+
+ econf \
+ --with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-initscriptdir="/toss-it-away" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ if use minimal ; then
+ dosbin smartctl || die
+ doman smartctl.8
+ else
+ emake install DESTDIR="${D}" || die
+ rm -rf "${D}"/toss-it-away
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}