summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-10-16 04:16:30 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-10-16 04:16:30 +0000
commit7d168182934526920ce47f67affbd7d8eeed89b1 (patch)
treeb585331435ff920de3dd6740d4d3d7614e09428f /sys-apps/sg3_utils
parentVersion bump. (diff)
downloadgentoo-2-7d168182934526920ce47f67affbd7d8eeed89b1.tar.gz
gentoo-2-7d168182934526920ce47f67affbd7d8eeed89b1.tar.bz2
gentoo-2-7d168182934526920ce47f67affbd7d8eeed89b1.zip
Bump.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog7
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.37.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 5cba3c7a6e27..87ef4a38ceb9 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.105 2013/08/04 11:33:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.106 2013/10/16 04:16:30 robbat2 Exp $
+
+*sg3_utils-1.37 (16 Oct 2013)
+
+ 16 Oct 2013; Robin H. Johnson <robbat2@gentoo.org> +sg3_utils-1.37.ebuild:
+ Bump.
04 Aug 2013; Agostino Sarubbo <ago@gentoo.org> sg3_utils-1.36.ebuild:
Stable for ia64, wrt bug #477568
diff --git a/sys-apps/sg3_utils/sg3_utils-1.37.ebuild b/sys-apps/sg3_utils/sg3_utils-1.37.ebuild
new file mode 100644
index 000000000000..de9912af94e4
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.37.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.37.ebuild,v 1.1 2013/10/16 04:16:30 robbat2 Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/scsi*
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${D}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+
+ prune_libtool_files
+}