summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-16 14:57:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-16 14:57:43 +0000
commit104df0b0a3d157caaf4bbd4581f93783c6eb9727 (patch)
tree1015b16d0f4b2e839d33b8955ffba7d4945b8483 /sys-apps/sed
parentVersion bump. (diff)
downloadgentoo-2-104df0b0a3d157caaf4bbd4581f93783c6eb9727.tar.gz
gentoo-2-104df0b0a3d157caaf4bbd4581f93783c6eb9727.tar.bz2
gentoo-2-104df0b0a3d157caaf4bbd4581f93783c6eb9727.zip
Add simple patch to compile on non-GNU systems, and readd ~x86-fbsd keyword.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog6
-rw-r--r--sys-apps/sed/files/sed-4.1.5-alloca.patch14
-rw-r--r--sys-apps/sed/sed-4.1.5.ebuild5
3 files changed, 22 insertions, 3 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 8694ed0e746a..f77a1a9fbdda 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/sed
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.71 2006/05/16 14:09:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.72 2006/05/16 14:57:43 flameeyes Exp $
+
+ 16 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/sed-4.1.5-alloca.patch, sed-4.1.5.ebuild:
+ Add simple patch to compile on non-GNU systems, and readd ~x86-fbsd keyword.
16 May 2006; Diego Pettenò <flameeyes@gentoo.org> sed-4.1.5.ebuild:
Drop ~x86-fbsd keyword for 4.1.5 version until it works.
diff --git a/sys-apps/sed/files/sed-4.1.5-alloca.patch b/sys-apps/sed/files/sed-4.1.5-alloca.patch
new file mode 100644
index 000000000000..9c92ba6ce357
--- /dev/null
+++ b/sys-apps/sed/files/sed-4.1.5-alloca.patch
@@ -0,0 +1,14 @@
+Index: sed-4.1.5/lib/regex_internal.h
+===================================================================
+--- sed-4.1.5.orig/lib/regex_internal.h
++++ sed-4.1.5/lib/regex_internal.h
+@@ -410,7 +410,9 @@ static unsigned int re_string_context_at
+ #define re_string_skip_bytes(pstr,idx) ((pstr)->cur_idx += (idx))
+ #define re_string_set_index(pstr,idx) ((pstr)->cur_idx = (idx))
+
++#ifdef HAVE_ALLOCA_H
+ #include <alloca.h>
++#endif
+
+ #ifndef _LIBC
+ # if HAVE_ALLOCA
diff --git a/sys-apps/sed/sed-4.1.5.ebuild b/sys-apps/sed/sed-4.1.5.ebuild
index 177513ea4268..693a532e5bf3 100644
--- a/sys-apps/sed/sed-4.1.5.ebuild
+++ b/sys-apps/sed/sed-4.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.5.ebuild,v 1.2 2006/05/16 14:09:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.5.ebuild,v 1.3 2006/05/16 14:57:43 flameeyes Exp $
inherit flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/sed/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="nls static build bootstrap"
RDEPEND="nls? ( virtual/libintl )"
@@ -39,6 +39,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-4.1.4-makeinfo-c-locale.patch
+ epatch "${FILESDIR}"/${P}-alloca.patch
sed -i \
-e "/docdir =/s:/doc:/doc/${PF}/html:" \
doc/Makefile.in || die "sed html doc"