summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-16 22:21:52 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-16 22:21:52 +0000
commit6c02fd5983076c5f325fcbc84602eb303e40ffe7 (patch)
treefa65c85ae8aea6e9221bf41a7c732f56c375a658 /sys-apps/rlocate
parentppc stable (diff)
downloadgentoo-2-6c02fd5983076c5f325fcbc84602eb303e40ffe7.tar.gz
gentoo-2-6c02fd5983076c5f325fcbc84602eb303e40ffe7.tar.bz2
gentoo-2-6c02fd5983076c5f325fcbc84602eb303e40ffe7.zip
Clean out devfs #140848 by CBke.
(Portage version: 2.1.1)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog6
-rw-r--r--sys-apps/rlocate/files/rlocate-0.5.2-no-devfs.patch27
-rw-r--r--sys-apps/rlocate/rlocate-0.5.2.ebuild3
3 files changed, 34 insertions, 2 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index 064520e9366b..d031e452d6c5 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.16 2006/09/16 05:29:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.17 2006/09/16 22:21:52 vapier Exp $
+
+ 16 Sep 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/rlocate-0.5.2-no-devfs.patch, rlocate-0.5.2.ebuild:
+ Clean out devfs #140848 by CBke.
*rlocate-0.5.2 (16 Sep 2006)
diff --git a/sys-apps/rlocate/files/rlocate-0.5.2-no-devfs.patch b/sys-apps/rlocate/files/rlocate-0.5.2-no-devfs.patch
new file mode 100644
index 000000000000..62bb6c117ecd
--- /dev/null
+++ b/sys-apps/rlocate/files/rlocate-0.5.2-no-devfs.patch
@@ -0,0 +1,27 @@
+--- src/rlocate-module/rlocate.c
++++ src/rlocate-module/rlocate.c
+@@ -42,7 +42,6 @@
+ #include <linux/rwsem.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/devfs_fs_kernel.h>
+ #include <linux/namei.h>
+ #include <linux/jiffies.h>
+
+@@ -673,8 +672,6 @@
+ }
+ class_device_create(rlocate_class, NULL, MKDEV(Major, 0), NULL,
+ DEVICE_NAME);
+- // devfs
+- devfs_mk_cdev(MKDEV(Major, 0), S_IFCHR|S_IRUSR|S_IWUSR, DEVICE_NAME);
+ goto out;
+
+ no_simple_class:
+@@ -688,7 +685,6 @@
+ */
+ void rlocate_dev_unregister(void)
+ {
+- devfs_remove(DEVICE_NAME);
+ class_device_destroy(rlocate_class, MKDEV(Major, 0));
+ class_destroy(rlocate_class);
+ unregister_chrdev(Major, DEVICE_NAME);
diff --git a/sys-apps/rlocate/rlocate-0.5.2.ebuild b/sys-apps/rlocate/rlocate-0.5.2.ebuild
index 6f80500515ee..25033778088b 100644
--- a/sys-apps/rlocate/rlocate-0.5.2.ebuild
+++ b/sys-apps/rlocate/rlocate-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.2.ebuild,v 1.1 2006/09/16 05:29:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.2.ebuild,v 1.2 2006/09/16 22:21:52 vapier Exp $
inherit eutils linux-mod
@@ -29,6 +29,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.5.2-build.patch
+ epatch "${FILESDIR}"/${PN}-0.5.2-no-devfs.patch
}
src_compile() {