summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-01-31 09:07:38 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-01-31 09:07:38 +0000
commit8789375d4ca7a4656145f0ec78a7a4b72e9dee9f (patch)
treede4f3365f4028b0ec4bfff1fc1abac3e9ff3eef4 /sys-apps/policycoreutils
parentInitial import. Ebuild submitted by Alexander Kellet <lypanov@kde.org> in bug... (diff)
downloadgentoo-2-8789375d4ca7a4656145f0ec78a7a4b72e9dee9f.tar.gz
gentoo-2-8789375d4ca7a4656145f0ec78a7a4b72e9dee9f.tar.bz2
gentoo-2-8789375d4ca7a4656145f0ec78a7a4b72e9dee9f.zip
rlpkg update
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/ChangeLog7
-rw-r--r--sys-apps/policycoreutils/files/rlpkg17
2 files changed, 12 insertions, 12 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index 6337510287b2..7e0b1e2ae1cb 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/policycoreutils
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.15 2003/12/16 20:44:51 pebenito Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.16 2004/01/31 09:07:38 pebenito Exp $
+
+ 31 Jan 2004; Chris PeBenito <pebenito@gentoo.org> files/rlpkg:
+ Switch to portageq from inline python. Add missing quotes for completeness.
16 Dec 2003; Chris PeBenito <pebenito@gentoo.org>
policycoreutils-1.4.ebuild:
diff --git a/sys-apps/policycoreutils/files/rlpkg b/sys-apps/policycoreutils/files/rlpkg
index 229b49068c6c..772d27aee01f 100644
--- a/sys-apps/policycoreutils/files/rlpkg
+++ b/sys-apps/policycoreutils/files/rlpkg
@@ -1,7 +1,7 @@
#!/bin/bash
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/files/rlpkg,v 1.1 2003/08/11 00:05:08 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/files/rlpkg,v 1.2 2004/01/31 09:07:38 pebenito Exp $
# Author: Chris PeBenito <pebenito@gentoo.org>
# this probably isnt the cleanest script, but it works.
@@ -13,7 +13,7 @@
. /sbin/functions.sh
PROG=`basename ${0}`
-if [ -z ${1} ]; then
+if [ -z "${1}" ]; then
echo "The Gentoo Linux package relabeler"
echo
echo "Usage: ${PROG} <pkg1> [<pkg2> ...]"
@@ -35,21 +35,18 @@ if [ "${build}" == " " ]; then
exit 1
fi
-# ask portage what POLICYDIR is set to (inline python)
+# ask portage what POLICYDIR is set to
# this should catch env vars too
-POLICYDIR="`python << EndOfFile
-import portage
-print portage.settings['POLICYDIR'];
-EndOfFile`"
+POLICYDIR="`portageq envvar POLICYDIR`"
-if [ -z ${POLICYDIR} ]; then
+if [ -z "${POLICYDIR}" ]; then
POLICYDIR="/etc/security/selinux/src/policy"
ewarn "Warning, no POLICYDIR set, using ${POLICYDIR}."
echo
fi
# make sure the policydir exists
-if [ ! -d ${POLICYDIR} ]; then
+if [ ! -d "${POLICYDIR}" ]; then
echo "The policy directory ${POLICYDIR} doesnt exist!"
echo
echo "Set the policy dir in make.conf: POLICYDIR=\"/etc/security/selinux/src/mypolicy\""