summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-11-07 14:59:23 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-11-07 14:59:23 +0000
commit9684b46fcf548f90400b23e7eb1281d2bf6a2843 (patch)
treefc7b1cf1d27c29742b42d57f3b01a354b5aa85ed /sys-apps/openrc
parentNew ebuild provided by Hendrik v. Raven<hendrik@consetetur.de> in bug #399645 (diff)
downloadgentoo-2-9684b46fcf548f90400b23e7eb1281d2bf6a2843.tar.gz
gentoo-2-9684b46fcf548f90400b23e7eb1281d2bf6a2843.tar.bz2
gentoo-2-9684b46fcf548f90400b23e7eb1281d2bf6a2843.zip
Fix references to $EROOT and $ED. References to $EROOT should be quoted and not followed with /. References to $ED should be quoted.
(Portage version: 2.2.0_alpha142/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild124
1 files changed, 62 insertions, 62 deletions
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 3cd60fa98a2a..8a179bda7366 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.114 2012/10/31 23:43:01 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.115 2012/11/07 14:59:23 williamh Exp $
EAPI=4
@@ -141,24 +141,24 @@ add_boot_init() {
local runlevel=${2:-boot}
# if the initscript is not going to be installed and is not
# currently installed, return
- [[ -e ${ED}/etc/init.d/${initd} || -e ${EROOT}/etc/init.d/${initd} ]] \
+ [[ -e "${ED}"/etc/init.d/${initd} || -e "${EROOT}"etc/init.d/${initd} ]] \
|| return
- [[ -e ${EROOT}/etc/runlevels/${runlevel}/${initd} ]] && return
+ [[ -e "${EROOT}"etc/runlevels/${runlevel}/${initd} ]] && return
# if runlevels dont exist just yet, then create it but still flag
# to pkg_postinst that it needs real setup #277323
- if [[ ! -d ${EROOT}/etc/runlevels/${runlevel} ]] ; then
- mkdir -p "${EROOT}"/etc/runlevels/${runlevel}
- touch "${EROOT}"/etc/runlevels/.add_boot_init.created
+ if [[ ! -d "${EROOT}"etc/runlevels/${runlevel} ]] ; then
+ mkdir -p "${EROOT}"etc/runlevels/${runlevel}
+ touch "${EROOT}"etc/runlevels/.add_boot_init.created
fi
elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
- ln -snf "${EROOT}"/etc/init.d/${initd} "${EROOT}"/etc/runlevels/${runlevel}/${initd}
+ ln -snf "${EROOT}"etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
}
add_boot_init_mit_config() {
local config=$1 initd=$2
if [[ -e ${EROOT}${config} ]] ; then
- if [[ -n $(sed -e 's:#.*::' -e '/^[[:space:]]*$/d' "${EROOT}"/${config}) ]] ; then
+ if [[ -n $(sed -e 's:#.*::' -e '/^[[:space:]]*$/d' "${EROOT}"${config}) ]] ; then
add_boot_init ${initd}
fi
fi
@@ -172,55 +172,55 @@ pkg_preinst() {
# manager doesnt go throwing etc-update crap at us -- postinst is
# too late to prevent that. this behavior also lets us keep the
# file in the CONTENTS for binary packages.
- [[ -e ${EROOT}/etc/conf.d/net ]] && \
- cp "${EROOT}"/etc/conf.d/net "${ED}"/etc/conf.d/
+ [[ -e "${EROOT}"etc/conf.d/net ]] && \
+ cp "${EROOT}"etc/conf.d/net "${ED}"/etc/conf.d/
# avoid default thrashing in conf.d files when possible #295406
- if [[ -e ${EROOT}/etc/conf.d/hostname ]] ; then
+ if [[ -e "${EROOT}"etc/conf.d/hostname ]] ; then
(
unset hostname HOSTNAME
- source "${EROOT}"/etc/conf.d/hostname
+ source "${EROOT}"etc/conf.d/hostname
: ${hostname:=${HOSTNAME}}
[[ -n ${hostname} ]] && set_config /etc/conf.d/hostname hostname "${hostname}"
)
fi
# upgrade timezone file ... do it before moving clock
- if [[ -e ${EROOT}/etc/conf.d/clock && ! -e ${EROOT}/etc/timezone ]] ; then
+ if [[ -e ${EROOT}etc/conf.d/clock && ! -e ${EROOT}/etc/timezone ]] ; then
(
unset TIMEZONE
- source "${EROOT}"/etc/conf.d/clock
- [[ -n ${TIMEZONE} ]] && echo "${TIMEZONE}" > "${EROOT}"/etc/timezone
+ source "${EROOT}"etc/conf.d/clock
+ [[ -n ${TIMEZONE} ]] && echo "${TIMEZONE}" > "${EROOT}"etc/timezone
)
fi
# /etc/conf.d/clock moved to /etc/conf.d/hwclock
local clock
use kernel_FreeBSD && clock="adjkerntz" || clock="hwclock"
- if [[ -e ${EROOT}/etc/conf.d/clock ]] ; then
- mv "${EROOT}"/etc/conf.d/clock "${EROOT}"/etc/conf.d/${clock}
+ if [[ -e "${EROOT}"etc/conf.d/clock ]] ; then
+ mv "${EROOT}"etc/conf.d/clock "${EROOT}"etc/conf.d/${clock}
fi
- if [[ -e ${EROOT}/etc/init.d/clock ]] ; then
- rm -f "${EROOT}"/etc/init.d/clock
+ if [[ -e "${EROOT}"etc/init.d/clock ]] ; then
+ rm -f "${EROOT}"etc/init.d/clock
fi
- if [[ -L ${EROOT}/etc/runlevels/boot/clock ]] ; then
- rm -f "${EROOT}"/etc/runlevels/boot/clock
- ln -snf /etc/init.d/${clock} "${EROOT}"/etc/runlevels/boot/${clock}
+ if [[ -L "${EROOT}"etc/runlevels/boot/clock ]] ; then
+ rm -f "${EROOT}"etc/runlevels/boot/clock
+ ln -snf /etc/init.d/${clock} "${EROOT}"etc/runlevels/boot/${clock}
fi
- if [[ -L ${EROOT}${LIBDIR}/rc/init.d/started/clock ]] ; then
- rm -f "${EROOT}${LIBDIR}"/rc/init.d/started/clock
- ln -snf /etc/init.d/${clock} "${EROOT}${LIBDIR}"/rc/init.d/started/${clock}
+ if [[ -L "${EROOT}"${LIBDIR}/rc/init.d/started/clock ]] ; then
+ rm -f "${EROOT}"${LIBDIR}/rc/init.d/started/clock
+ ln -snf /etc/init.d/${clok} "${EROOT}"${LIBDIR}/rc/init.d/started/${clock}
fi
# /etc/conf.d/rc is no longer used for configuration
- if [[ -e ${EROOT}/etc/conf.d/rc ]] ; then
+ if [[ -e "${EROOT}"etc/conf.d/rc ]] ; then
elog "/etc/conf.d/rc is no longer used for configuration."
elog "Please migrate your settings to /etc/rc.conf as applicable"
elog "and delete /etc/conf.d/rc"
fi
# force net init.d scripts into symlinks
- for f in "${EROOT}"/etc/init.d/net.* ; do
+ for f in "${EROOT}"etc/init.d/net.* ; do
[[ -e ${f} ]] || continue # catch net.* not matching anything
[[ ${f} == */net.lo ]] && continue # real file now
[[ ${f} == *.openrc.bak ]] && continue
@@ -276,8 +276,8 @@ migrate_udev_init_script() {
# >=OpenRC-0.11.3 requires udev-mount to be in the sysinit runlevel with udev.
migrate_udev_mount_script() {
- if [ -e "${EROOT}"/etc/runlevels/sysinit/udev -a \
- ! -e "${EROOT}"/etc/runlevels/sysinit/udev-mount ]; then
+ if [ -e "${EROOT}"etc/runlevels/sysinit/udev -a \
+ ! -e "${EROOT}"etc/runlevels/sysinit/udev-mount ]; then
add_boot_init udev-mount sysinit
fi
return 0
@@ -297,22 +297,22 @@ migrate_from_baselayout_1() {
add_boot_init_mit_config /etc/conf.d/dmcrypt dmcrypt
add_boot_init_mit_config /etc/mdadm.conf mdraid
add_boot_init_mit_config /etc/evms.conf evms
- [[ -e ${EROOT}/sbin/dmsetup ]] && add_boot_init device-mapper
- [[ -e ${EROOT}/sbin/vgscan ]] && add_boot_init lvm
+ [[ -e "${EROOT}"sbin/dmsetup ]] && add_boot_init device-mapper
+ [[ -e "${EROOT}"sbin/vgscan ]] && add_boot_init lvm
elog "Add on services (such as RAID/dmcrypt/LVM/etc...) are now stand alone"
elog "init.d scripts. If you use such a thing, make sure you have the"
elog "required init.d scripts added to your boot runlevel."
# Upgrade our state for baselayout-1 users
- if [[ ! -e ${EROOT}${LIBDIR}/rc/init.d/started ]] ; then
+ if [[ ! -e "${EROOT}"${LIBDIR}/rc/init.d/started ]] ; then
(
- [[ -e ${EROOT}/etc/conf.d/rc ]] && source "${EROOT}"/etc/conf.d/rc
+ [[ -e "${EROOT}"etc/conf.d/rc ]] && source "${EROOT}"/etc/conf.d/rc
svcdir=${svcdir:-/var/lib/init.d}
- if [[ ! -d ${EROOT}${svcdir}/started ]] ; then
+ if [[ ! -d "${EROOT}"${svcdir}/started ]] ; then
ewarn "No state found, and no state exists"
elog "You should reboot this host"
else
- mkdir -p "${EROOT}${LIBDIR}/rc/init.d"
+ mkdir -p "${EROOT}"${LIBDIR}/rc/init.d
einfo "Moving state from ${EROOT}${svcdir} to ${EROOT}${LIBDIR}/rc/init.d"
mv "${EROOT}${svcdir}"/* "${EROOT}${LIBDIR}"/rc/init.d
rm -rf "${EROOT}${LIBDIR}"/rc/init.d/daemons \
@@ -324,13 +324,13 @@ migrate_from_baselayout_1() {
fi
# Handle the /etc/modules.autoload.d -> /etc/conf.d/modules transition
- if [[ -d ${EROOT}/etc/modules.autoload.d ]] ; then
+ if [[ -d "${EROOT}"etc/modules.autoload.d ]] ; then
elog "Converting your /etc/modules.autoload.d/ files to /etc/conf.d/modules"
- rm -f "${EROOT}"/etc/modules.autoload.d/.keep*
- rmdir "${EROOT}"/etc/modules.autoload.d 2>/dev/null
- if [[ -d ${EROOT}/etc/modules.autoload.d ]] ; then
+ rm -f "${EROOT}"etc/modules.autoload.d/.keep*
+ rmdir "${EROOT}"etc/modules.autoload.d 2>/dev/null
+ if [[ -d "${EROOT}"etc/modules.autoload.d ]] ; then
local f v
- for f in "${EROOT}"/etc/modules.autoload.d/* ; do
+ for f in "${EROOT}"etc/modules.autoload.d/* ; do
v=${f##*/}
v=${v#kernel-}
v=${v//[^[:alnum:]]/_}
@@ -354,7 +354,7 @@ migrate_from_baselayout_1() {
' "${f}" >> "${ED}"/etc/conf.d/modules
done
rm -f "${f}"
- rmdir "${EROOT}"/etc/modules.autoload.d 2>/dev/null
+ rmdir "${EROOT}"etc/modules.autoload.d 2>/dev/null
fi
fi
}
@@ -363,29 +363,29 @@ pkg_postinst() {
local LIBDIR=$(get_libdir)
# Remove old baselayout links
- rm -f "${EROOT}"/etc/runlevels/boot/{check{fs,root},rmnologin}
- rm -f "${EROOT}"/etc/init.d/{depscan,runscript}.sh
+ rm -f "${EROOT}"etc/runlevels/boot/{check{fs,root},rmnologin}
+ rm -f "${EROOT}"etc/init.d/{depscan,runscript}.sh
# Make our runlevels if they don't exist
- if [[ ! -e ${EROOT}/etc/runlevels ]] || [[ -e ${EROOT}/etc/runlevels/.add_boot_init.created ]] ; then
+ if [[ ! -e "${EROOT}"etc/runlevels ]] || [[ -e "${EROOT}"etc/runlevels/.add_boot_init.created ]] ; then
einfo "Copying across default runlevels"
- cp -RPp "${EROOT}"/usr/share/${PN}/runlevels "${EROOT}"/etc
- rm -f "${EROOT}"/etc/runlevels/.add_boot_init.created
+ cp -RPp "${EROOT}"usr/share/${PN}/runlevels "${EROOT}"etc
+ rm -f "${EROOT}"etc/runlevels/.add_boot_init.created
else
- if [[ ! -e ${EROOT}/etc/runlevels/sysinit/devfs ]] ; then
- mkdir -p "${EROOT}"/etc/runlevels/sysinit
- cp -RPp "${EROOT}"/usr/share/${PN}/runlevels/sysinit/* \
- "${EROOT}"/etc/runlevels/sysinit
+ if [[ ! -e "${EROOT}"etc/runlevels/sysinit/devfs ]] ; then
+ mkdir -p "${EROOT}"etc/runlevels/sysinit
+ cp -RPp "${EROOT}"usr/share/${PN}/runlevels/sysinit/* \
+ "${EROOT}"etc/runlevels/sysinit
fi
- if [[ ! -e ${EROOT}/etc/runlevels/shutdown/mount-ro ]] ; then
- mkdir -p "${EROOT}"/etc/runlevels/shutdown
- cp -RPp "${EROOT}"/usr/share/${PN}/runlevels/shutdown/* \
- "${EROOT}"/etc/runlevels/shutdown
+ if [[ ! -e "${EROOT}"etc/runlevels/shutdown/mount-ro ]] ; then
+ mkdir -p "${EROOT}"etc/runlevels/shutdown
+ cp -RPp "${EROOT}"usr/share/${PN}/runlevels/shutdown/* \
+ "${EROOT}"etc/runlevels/shutdown
fi
fi
# /etc/conf.d/net.example is no longer valid
- local NET_EXAMPLE="${EROOT}/etc/conf.d/net.example"
+ local NET_EXAMPLE="${EROOT}etc/conf.d/net.example"
local NET_MD5='8ebebfa07441d39eb54feae0ee4c8210'
if [[ -e "${NET_EXAMPLE}" ]] ; then
if [[ $(md5sum "${NET_EXAMPLE}") == ${NET_MD5}* ]]; then
@@ -395,11 +395,11 @@ pkg_postinst() {
sed -i '1i# This file is obsolete.\n' "${NET_EXAMPLE}"
elog "${NET_EXAMPLE} should be removed."
fi
- elog "The new file is ${EROOT}/usr/share/doc/${PF}/net.example"
+ elog "The new file is ${EROOT}usr/share/doc/${PF}/net.example"
fi
# /etc/conf.d/wireless.example is no longer valid
- local WIRELESS_EXAMPLE="${EROOT}/etc/conf.d/wireless.example"
+ local WIRELESS_EXAMPLE="${EROOT}etc/conf.d/wireless.example"
local WIRELESS_MD5='d1fad7da940bf263c76af4d2082124a3'
if [[ -e "${WIRELESS_EXAMPLE}" ]] ; then
if [[ $(md5sum "${WIRELESS_EXAMPLE}") == ${WIRELESS_MD5}* ]]; then
@@ -410,11 +410,11 @@ pkg_postinst() {
elog "${WIRELESS_EXAMPLE} is deprecated and should be removed."
fi
elog "If you are using the old style network scripts,"
- elog "Configure wireless settings in ${EROOT}/etc/conf.d/net"
- elog "after reviewing ${EROOT}/usr/share/doc/${PF}/net.example"
+ elog "Configure wireless settings in ${EROOT}etc/conf.d/net"
+ elog "after reviewing ${EROOT}usr/share/doc/${PF}/net.example"
fi
- if [[ -d ${EROOT}/etc/modules.autoload.d ]] ; then
+ if [[ -d "${EROOT}"etc/modules.autoload.d ]] ; then
ewarn "/etc/modules.autoload.d is no longer used. Please convert"
ewarn "your files to /etc/conf.d/modules and delete the directory."
fi
@@ -450,7 +450,7 @@ pkg_postinst() {
local netscript=net.lo
fi
- if [ ! -e "${EROOT}"/etc/runlevels/boot/${netscript} ]; then
+ if [ ! -e "${EROOT}"etc/runlevels/boot/${netscript} ]; then
ewarn "Please add the $netscript script to your boot runlevel"
ewarn "as soon as possible. Not doing so could leave you with a system"
ewarn "without networking."
@@ -460,7 +460,7 @@ pkg_postinst() {
ewarn "satisfies the net virtual."
ewarn "If you have services now which do not start because of this,"
ewarn "They can be fixed by adding rc_need=\"!net\""
- ewarn "to the ${EROOT}/etc/conf.d/<servicename> file."
+ ewarn "to the ${EROOT}etc/conf.d/<servicename> file."
ewarn "You should also file a bug against the service asking that"
ewarn "need net be dropped from the dependencies."
ewarn "The bug you file should block the following tracker:"